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Class 1: AFM - The Data Center Firewall

1.1 Getting Started

Please follow the instructions provided by the instructor to start your lab and access your jump host.

Note: All work for this lab will be performed exclusively from the Windows jumphost. No installation or
interaction with your local system is required.

1.1.1 Lab Topology

The training lab is accessed over remote desktop connection.

Your administrator will provide login credentials and the URL.

Within each lab environment there are the following Virtual Machines:
» Windows 7 Jumpbox
» username: external_user password: P@sswOrd!

Two BIG-IP Virtual Editions (VE) — running TMOS 15.1

+ username: admin password: f5DEMOs4u

LAMP Server (Web Servers)
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F5 Products Subnets Systems

bigip02 Management Windows Jumpbox
BIGIP 15.0.0-0039 1041024 Windows

ACCESSv  DETAILS DETAILS ACCESS v DETAILS
bigip01 Subnet 10 LAMP v4
BIGIP 15.0.0-00.39 10.1.10.024 Uburty
> > >
ACCESSv  DETAILS DETAILS ACCESS v DETAILS
Subnet 20
10120024
| 4

DETAILS

Lab Components

Below are all the IP addresses that will be used during the labs. Please refer back to this page and use the
IP addresses assigned to your site.

IP Addresses
Lampserver | 10.1.20.11, 10.1.20.12, 10.1.20.13 ,10.1.20.14, 10.1.20.15

1.2 Lab 1 — Advanced Firewall Manager (AFM)

1.2.1 Lab Overview

During this lab, you will configure the BIG-IP system to permit traffic to multiple backend servers. You will
then run simulated user flows against BIG-IP and verify the traffic flow, reporting and logging of these flows.

1.2.2 Base BIG-IP Configuration

In this lab, the VE has been configured with the basic system settings and the VLAN/self-IP configurations
required for the BIG-IP to communicate and pass traffic on the network. Inspect the Virtual Servers which
have been configured. Note that they are Wwildcard (listen for all traffic) and have SNAT auto-map enabled.
We’ll now need to configure the BIG-IP to pass it to the back-end server.

1.2.3 Advanced Firewall Manager

Welcome to Initech! Today is your first day as the principal firewall engineer, congratulations! The employee
you are replacing, Milton, is rumored to be sitting on a beach in Key West sipping Mai Tai’s and took his red
stapler but left no documentation. ..
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The marketing team, now led by Bill Lumbergh, launched a new campaign for Initech’s TPS reports
overnight and no one can access the web server. The only information the web server administrators
know is that the IP address of the Web server is 10.30.0.50 and that Mr. Lumbergh is furious the world
does not know about the glory of TPS reports!!

Let’s start by testing the web server to verify. On your workstation open a browser (we prefer you use the
Chrome shortcut labeled BIG-IP Ul, all the tabs are pre-populated) and enter the address of the web server
(http://10.1.20.11). No Bueno! Let’s see if we can even ping the host. Launch a command prompt (startrun
cmd) and type ‘ping 10.1.20.11°. Bueno! Looks like the server is up and responding to pings, as such, this
is likely not a network connectivity issue.

You ask one of your colleagues, who just got out of his meeting with the Bob’s, if he knows the IP address
of the firewall. He recalls the firewall they would traverse for this communication is bigip0O1.f5demo.com and
its management IP address is 10.1.1.4. In your browser, open a new tab and navigate to https://10.1.1.4.
The credentials to log into the device are username: admin and password: fSDEMOs4u (these can also be
found on the login banner of the device for convenience). Note if you receive a security warning it is ok to
proceed to the site and add as a trusted site.

F5? F5 makes a data center firewall? Maybe | should do a little reading about what the F5 firewall is before
| proceed deeper into the lab. ..

1.2.4 Advanced Firewall Manager (AFM)

Advanced Firewall Manager (AFM) is a module that was added to TMOS in version 11.3. F5 BIG-IP Ad-
vanced Firewall Manager™ (AFM) is a high-performance ICSA certified, stateful, full-proxy network firewall
designed to guard data centers against incoming threats that enter the network on the most widely deployed
protocols—including HTTP/S, SMTP, DNS, SIP, and FTP.

By aligning firewall policies with the applications, they protect, BIG-IP AFM streamlines application deploy-
ment, security, and monitoring. With its scalability, security and simplicity, BIG-IP AFM forms the core of the
F5 application delivery firewall solution.

One Platform

Eﬂ

£ € El o)

ICSA-Certified Traffic Application Access DDoS S5L
Firewall Management Security Control Mitigation Inspection Security -/

Some facts below about AFM and its functionality:

» Advanced Firewall Manager (AFM) provides “Shallow” packet inspection while Application Security
Manager (ASM) provides “Deep” packet inspection. By this we mean that AFM is concerned with
source IP address and port, destination IP address and port, and protocol (this is also known as
5-tuple/quintuple filtering).

» AFM is used to allow/deny a connection before deep packet inspection ever takes place, think of it as
the first line of firewall defense.

* AFM is many firewalls in one. You can apply L4 firewall rules to ALL addresses on the BIG-IP or you
can specify BIG-IP configuration objects (route domains, virtual server, self-IP, and Management-IP).

1.2. Lab 1 - Advanced Firewall Manager (AFM) 7
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* AFM runs in 2 modes: ADC mode and Firewall mode. ADC mode is called a “blacklist”, all traffic is
allowed to BIG-IP except traffic that is explicitly DENIED (this is a negative security model). Firewall
mode is called a “whitelist”, all traffic is denied to BIG-IP except traffic that is explicitly ALLOWED. The
latter is typically used when the customer only wants to use us as a firewall or with LTM.

+ We are enabling “SERVICE DEFENSE IN DEPTH” versus traditional “DEFENSE IN DEPTH”. This
means, instead of using multiple shallow and deep packet inspection devices inline increasing infras-
tructure complexity and latency, we are offering these capabilities on a single platform.

» AFM is an ACL based firewall. In the old days, we used to firewall networks using simple packet filters.
With a packet filter, if a packet doesn’t match the filter it is allowed (not good). With AFM, if a packet
does not match criteria, the packet is dropped.

* AFM is a stateful packet inspection (SPI) firewall. This means that BIG-IP is aware of new packets
coming to/from BIG-IP, existing packets, and rogue packets.

» AFM adds more than 100 L2-4 denial of service attack vector detections and mitigations. This may be
combined with ASM to provide L4-7 protection.

 Application Delivery Firewall is the service defense in depth layering mentioned earlier. On top of
a simple L4 network firewall, you may add access policy and controls from L4-7 with APM (Access
Policy Manager), or add L7 deep packet inspection with ASM (web application firewall), You can add
DNS DOS mitigation with LTM DNS Express and GTM + DNSSEC. These modules make up the entire
Application Delivery Firewall (ADF) solution.

1.2.5 Creating AFM Network Firewall Rules

For this lab, you will complete the following sections:

Default Actions

The BIG-IP® Network Firewall provides policy-based access control to and from address and port pairs,
inside and outside of your network. Using a combination of contexts, the network firewall can apply rules
in many ways, including: at a global level, on a per-virtual server level, and even for the management port
or a self IP address. Firewall rules can be combined in a firewall policy, which can contain multiple context
and address pairs, and is applied directly to a virtual server.

By default, the Network Firewall is configured in ADC mode, a default allow configuration, in which all traffic
is allowed through the firewall, and any traffic you want to block must be explicitly specified.

The system is configured in this mode by default so all traffic on your system continues to pass after you
provision the Advanced Firewall Manager. You should create appropriate firewall rules to allow necessary
traffic to pass before you switch the Advanced Firewall Manager to Firewall mode. In Firewall mode, a
default deny configuration, all traffic is blocked through the firewall, and any traffic you want to allow through
the firewall must be explicitly specified.

This lab has been pre-configured in Firewall mode.

You can change the BIG-IP AFM Network Firewall mode by modifying the Default Firewall Action setting.
When you enable Firewall mode, the AFM system allows access only when specific firewall rules are put
in place. While this method reduces the overall attack surface, it may impact services that you are not be
aware of. ADC mode is currentl the default and most popular choice. These steps change the AFM mode
from the default ADC mode to firewall mode.

The BIG-IP® Network Firewall provides policy-based access control to and from address and port pairs,
inside and outside of your network. By default, the network firewall is configured in ADC mode, which is a
default allow configuration, in which all traffic is allowed to virtual servers and self IPs on the system, and
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any traffic you want to block must be explicitly specified. This applies only to the Virtual Server & Self IP
level on the system.

Important: Even though the system is in a default allow configuration, if a packet matches no rule in any
context on the firewall, a Global Drop rule drops the traffic.

Rule Hierarchy

With the BIG-IP® Network Firewall, you use a context to configure the level of specificity of a firewall rule
or policy. For example, you might make a global context rule to block ICMP ping messages, and you might
make a virtual server context rule to allow only a specific network to access an application.

Context is processed in this order:
+ Global
» Route domain
+ Virtual server / self IP
* Management port*
+ Global drop*

The firewall processes policies and rules in order, progressing from the global context, to the route domain
context, and then to either the virtual server or self IP context. Management port rules are processed
separately, and are not processed after previous rules. Rules can be viewed in one list, and viewed and
reorganized separately within each context. You can enforce a firewall policy on any context except the
management port. You can also stage a firewall policy in any context except management.

Tip: You cannot configure or change the Global Drop context. The Global Drop context is the final context
for traffic. Note that even though it is a global context, it is not processed first, like the main global context,
but last. If a packet matches no rule in any previous context, the Global Drop rule drops the traffic.

1.2. Lab 1 - Advanced Firewall Manager (AFM) 9
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Global rules

Route domain rules

| ADC Mode/

N Firewall Made

Virtual server [ .| actions drop,
self IP rules reject, allow]

apply here

70.10.1.0/24
Denied all access

DEMY SRC 70.10.1.0/24
PORT* PROTOCOL®

Management
port rules

£0.10.1.0,24
Allowed to FTP only

External nEtwur(Iic;;_\

S G

Global drop rule J

90.10.1.0,/24

ALLOW SRC 80.10.1.0/24
Allowed to all VIPs

DEST 70.168.15.104 PORT 21

App server 2
10.10.1.10

GLLOW SRC 90.1.0/24 DEST* PORT*
App server 1 FTP s

10.10.1.11 70.168
Application servers
& network resources

pyCreate and View Log Entries

In this section, you will generate various types of traffic through the firewall as you did previously, but now
you will view the log entries using the network firewall log. Open your web browser and once again try to
access http://10.1.20.11. Also, try to ping 10.1.20.11.

Open the Security > Event Logs > Network > Firewall page on bigip01.f5demo.com (10.1.1.4). The log
file shows the ping requests are being accepted and the web traffic is being dropped:

I [Ecsmes ars [E palrms & Plertams. |7 | eubsaioa o] subsererraus & Rt & Faon 2 Adees [ Pan [ v Tomel | Foon | Fan | Addtess | Par | FoieDamai < viaa sarer] - ros
2150520021139 Gl s oba e o o Unlrown uniaown 10250200 S8 CommONGUTOGE Unknawn  uniown 1030050 8 o Top
2180820021135 Gl e lobarep v uninown Unirown unrown 10250200 1608 CommanUTSGE Uninewn urirown 1035080 8 o Top
2150820021135 Gl oo osa e o uninown Unirown unirown 10250200 1605 CommonUTSGE Uninewn  uniovn 1030080 8 o Top
218082002113 Gl s losarep v uninown Unirown unirown 10250200 1607 CommanUTSGE Uninewnurirown 1035080 8 o Top
210520021132 Gl ertoras osa o o wninown Unrown unrown 10250200 1608 CommonUTSGE Uninewnunirown 1035080 8 o Top
2160820021132 Gl s losarep v uninown Unirown unirown 10250200 1605 CommanUTSGE Uninewn urirown 1035080 8 o Top
2189520021130 Gl oo osa e o uninown Unirown unirown 10250200 607 CommonUTSGE Uninawn  unirovn 1030080 80 o Top
210820021120 Gl e lobarep v uninown Unirown unrown 10250200 1608 CommanUTSGE Uninewn urirown 1035080 8 o Top
1082002112 Gl oo osa e o uninown Unirown unirown 10250200 1605 CommonUTSGE Uninewn  uniovn 1030080 8 o Top
2198 20021117 Gl s P oo o Unlrown unirown 10200200 | CommonouTsGE Ui unirown 1030080 2018 o e

10.20.0.200 1 ICarmmoniDMZ 10.30.0.50 048 0 ICMP.
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Although we will not configure external logging in this lab, you should be aware that the BIG-IP supports
high speed external logging in various formats including SevOne, Splunk and ArcSight.

Navigate ** Security > Options > Network Firewall > Firewall Options **

Default Firewall options configuration determine if the system is in ADC mode or Firewall Mode. In the
screenshot below note the Virtual Server & Self IP Contexts Value. If it is set to Accept (system default) the
Firewall is in ADC mode. For ths lab we will use Firewall Mode with the value set to Reject

Local-db-publisher is linked to the global-network logging profile in the next step

Security » Options : Network Firewall : Firewall Options

{4 ~ | Firewall Options | External Redirection

Default Firewall Options

Virtual Server & Self IP Contexts

Log Publisher

Global Context Reject v
FQDN Resaolver

Global Context None \j

Refresh Interval 60 seconds
Firewall Policy Management

Firewall Compilation Mode Automatic

Firewall Deployment Mode Automatic

Log Configuration Changes Automatic

local-do-publisher

Inline Rule Editor #| Enabled

Auto Generate UUID Disabled
Firewall NAT

Metwork Address Translation Mone

|Pv6 Prefix Length 128 Al
Packet Filter

Packet Filter Policy Mone

Update

Add a log publisher to the log configuration

1.2. Lab 1 - Advanced Firewall Manager (AFM)
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Navigate Security>>Event Logs>>Logging Profiles
Navigate Select Global Network
Navigate Click on the Network Firewall Tab

Navigate Use the publisher pulldown to select local-db-publisher

Review the configuration. The Storage Format section allows you to select the values included in the log.

Security »» Event Logs : Logging Profiles : Edit Logging Profile
E » J0S

Edit Logging Profile

Logging Profile Properties

Profile Mame global-networls
Partition / Path Commaon
Description Default logging profile for network events
Protocol Security “ Enabled
Metwork Firewall ¢ Enabled
Network Address Translation | Enabled
Dos Protection Enabled
Protocol Inspection Enabled
Packet Filter Enabled
Classification Enabled
Auto Discovery Enabled
Metflow Enabled

Protocol Security | Metwork Firewall | Metwork Address Translation

Metwork Firewall

FPublisher local-de-publisher r
Aggregate Rate Limit Indefinite
#| pccept

Rate Limit| Indefinite

* Drop

L Al EIE 2 Rate Limit| Indefinite v

¥ Reject
Rate Limit| Indefinite
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Create a Rule List

Rule lists are a way to group a set of individual rules together and apply them to the active rule base as
a group. A typical use of a rule list would be for a set of applications that have common requirements for
access protocols and ports. As an example, most web applications would require TCP port 80 for HTTP
and TCP port 443 for SSL/TLS. You could create a Rule list with these protocols, and apply them to each
of your virtual servers.

Let’'s examine some of the default rule lists that are included with AFM.
Go to Security >Network Firewall > Rule Lists. They are:
» _sys_self allow_all

» _sys_self allow_defaults

» _sys_self _allow_management

Security :» Metwork Firewall : Rule Lists

£+

Active Rules Rule Lists

Falicies FartLists Schedules IP Intelligence

‘
~ Marne = Description |¢ Fartition f Path
[ _sys_sel_allow_all cormman
[ _sys_seli_allow_defaults Comman
[ _svs_self_allow_management Cormman

If you click on _sys_self_allow_management you'll see that it is made up of two different rules that will
allow management traffic (port 22/SSH and port 443 HTTPS). Instead of applying multiple rules over and
over across multiple servers, you can put them in a rule list and then apply the rule list as an ACL.

Rules I Source || Destination | [m]
‘ Mame ‘ State | Schedule |Address ‘ Part | YLAN ! Tunnel | Address | Port | Protocol ‘ Action | Logging
[ _sys_allow_ssh Enzhled Any Any  Any Any 23 B(TCPFY Accept Disabled
E _sve_allow_web Enabled Any Any Ay Any 443 B(TCF) Accept Disabled

On bigip01.f5demo.com (10.1.1.4) create a rule list to allow Web traffic. A logical container must be created
before the individual rules can be added. You will create a list with two rules, to allow port 80 (HTTP)
to servers 10.1.20.11 through 10.1.20.13 and another to allow port 443 (HTTPS) to servers 10.1.20.13
through 10.1.20.15. First you need to create a container for the rules by going to:

Security > Network Firewall > Rule Lists and select Create.

For the Name enter web_rule_list, provide an optional description and then click Finished.

Security »» Network Firewall : Rule Lists :» Hew Rule List...

General Properties

Mame | web_rule_list

Description | Commaonly Used Protocols

[ cancel || Repeat || Finished |

Edit the web_rule_list by selecting it in the Rule Lists table, then click the Add button in the Rules section.
Here you will add two rules into the list; the first is a rule to allow HTTP.

1.2. Lab 1 - Advanced Firewall Manager (AFM) 13
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Security »» Network Firewall : Rule Lists » web_rule_list

General Properties

Marme web_rule_list
Partition § Path Common
Description Commonly Used Protocols
Rules \ e || Destinat Rearder
‘ ‘ Mame ‘ State | Schedule ‘ Address | Port | VLAN [ Tunnel |AI§1FJVEES | Pﬂ?’t| Pratocol | Action | Lnggmg ‘
‘Nn records to display. ‘
Name allow_http
Protocol TCP
Source Leave at Default of Any

Destination Address | Specify...10.1.20.11, 10.1.20.13 then click Add
Destination Port Specify... Port 80, then click Add

Action Accept-Decisively

Logging Enabled

14 Chapter 1. Class 1: AFM — The Data Center Firewall
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Security » Network Firewall : Rule Lists » web_rule_list : New Rule...

Rule Properties

Name allow_http

uuiD Auto Generate UUID
Description

Order last ¥

State Enabled ¥

Protocol TCP Y6

Subscriber: Any
Address/Region: | Any
Source Port Any
VLAN / Tunnel: | Any
Zone: Any

ENE e

Address/Region: Specify.. ¥
Address ' Address List ® Address Range ' Blacklist Categories ' Counfry/Region
‘10.1.20.11I to| 10.1.20.13 Add
10.1.20.11-10.1.20.13

Edit |Delste
Destination Port Specify.. ¥
® Port') Port Range ' Port List
30 Add
a0
Edit |Delete
Zone: Any v
iRule Hone Y
Action Accept Decisively ¥
Send to Virtual Mone T
Logging Enabled ¥
Senvice Policy Mone ¥
Protocol Inspecion Profile Hong v
Classificafion Policy None ¥

Cancel | Repeat || Finished

Select Repeat when done.

Name allow_https

Protocol TCP

Source Leave at Default of Any

Destination Address | Specify...10.1.20.14, 10.1.20.15 then click Add
Destination Port Specify... Port 443, then click Add

Action Accept-Decisively

Logging Enabled

Select Finished when completed. When you exit, you'll notice the reject rule is after the allow_https rule.
This means that HTTP traffic from 10.1.20.0/24 will be accepted, while all other traffic from this subnet will
be rejected based on the ordering of the rules as seen below:

1.2. Lab 1 - Advanced Firewall Manager (AFM) 15
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Create a Policy with a Rule List

Policies are a way to group a set of individual rules together and apply them to the active policy base as a
group. A typical use of a policy list would be for a set of rule lists that have common requirements for access
protocols and ports.

Create a policy list to allow the traffic you created in the rule list in the previous section. A logical container
must be created before the individual rules can be added. First you need to create a container for the policy
by going to:

Security > Network Firewall > Policies and select Create.

You'll notice that before Milton detached from Initech, he created a global policy named ‘Global’ to allow
basic connectivity to make troubleshooting easier.

For the Name enter rd_0_policy, provide an optional description and then click Finished. (Note: We
commonly use “RD” in our rules to help reference the “Route Domain”, default is 0)

Security » Metwork Firewall : Policies » New Policy...

General Properties

MName rd_0_policy

Description

| Cancel || Repeat || Finished |

Edit the rd_0_policy by selecting it in the Policy Lists table, then click the Add Rule List button. Here you
will add the rule list you created in the previous section. For the Name, start typing web_rule_list, you
will notice the name will auto complete, select the rule list /Common/web_rule_list, provide an optional
description and then click Done Editing.

Filter Active Rules Lis )

Add Rule List | v | | Add Rule | v |

o ] name sue Frowml e Sesnaton s Lo

Enabled v

Unsaved changes to the policyt
one h the comrmitied 1o the systern before taking effect

[ cormmit Changes to System | | Cancel Changes |

General Properties

Narne. 1d_0_poliey

Partion Common

Description

iter Acve Rutes List hd Add Rule List | + | [ Add Ruls [ + |

state Protacol Source. Destination Actions. Logging,

Enabled Any

You will notice the changes are unsaved and need to be committed to the system. This is a nice feature to
have enabled to verify you want to commit the changes you’ve just made without a change automatically
being implemented.

To commit the change, simply click “Commit Changes to System” located at the top of the screen.

Security » Network Firewall: Policies »» /Commonird_0_poli

IPintelligence ~

Palicies

Unsaved changes to the policy!
4 oneor olicy rules have been modified but not system. be committed to

Cormmit Changes to System | | Cancel Changes

Once committed you'll notice the rule now becomes active and the previous commit warning is removed.
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iPinteligence

it Actve Rutes Ust v

Add Rule List | v | | Add Rule | » |

state Protacol Source. Destination Actions Logging

Enabled Any

Add the Rule List to a Route Domain

In this section, you are going to attach the rule to a route domain using the Security selection in the top bar
within the Route Domain GUI interface.

Go to Network, then click on Route Domains, then select the hyperlink for route domain 0.

Now click on the Security top bar selection, which is a new option that was added in version 11.3.

In the Network Firewall section, set the Enforcement: to “Enabled...”.

Select the Policy you just created, “rd_0_policy” and click Update.

| vans | AP, DMZ, OUTSIDE, htp-tunnel, socks-tunmel

Enforcement; Enabled... v Policy rd_0_policy |

Staging | Disables v

| e Tt | sne

Mbps

e
oo o
| e
| ne

| evn ot

Review the rules that are now applied to this route domain by navigating to:
Security > Network Firewall > Active Rules.
From the Context Filter select Route Domain 0.

Click on the Add Rule List to Global from the ypper right corner of the screen and click Cancel (note:this
is a GUI bug)

Click on the Add Rule List to Route Domain from the ypper right corner of the screen and click Cancel
(note:this is a GUI bug)

your screen should show the web_rule _list you assigned earlier through the Route Domain Screen.

The sceen should look similar to the below screen shot.

Security » Network Firewall : Active Rules

Active Rules. Policies

o~ Rule Lists Schedules IP Inteligence  ~

Context Filter

Policy Type Enforced v

Context Route Domain... v |[0

[ Fitter Active Rules Lis v AddRule List~ | | Add Rule v | | Reset Stats ~

[ [ Name State | Protocal Source Destination Action Loggin Add Tule st to Global Latest Match
Add rule list to Route Domain

&) Global with policy Global

Select rules to see more actions
1 Ping Enabled IcMP Any Any Accept-Decisively Yes | Selectrulesfosee moreactions |y g g
=) Route Domain 0 with policy rd_0_policy

1 £ web_rule Jist Enabled Any

(Default) Enabled Any Any Any Reject No 0 Never

Test the New Firewall Rules

Once again you will generate traffic through the BIG-IP AFM and then view the AFM (firewall) logs.
» Ping 10.1.20.11, 10.1.20.12, 10;120.13, 10.120.14, and 10.1.20.15 (why does ths work?)

1.2. Lab 1 - Advanced Firewall Manager (AFM) 17
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* Open a new Web browser and access http://10.1.20.11
» Open a new Web browser and access https://10.1.20.11 (this should fail-why?)
* Open a new Web browser and access https://10.1.20.14
In the Configuration Utility, open the Security > Event Logs > Network > Firewall page.
Access for ports 80 / 443 was granted to a host using the web_rule_list: allow_http and **allow_https**rule.

Note the source address of the user (10.1.10.199). The IP forwarding VIPs are configured with SNAT auto-
map. Packets forwarded by the BIG-IP to the servers have a source address 10.1.20.245. This arrangement
is common in cloud deplouments since it simplifies traffic routing.

Denied connections are not logged in this configuration. These are dropped by the final reject rule in the
global policy

Socutly » EventLogs - Network - Firowal
= etk

= | Mabwork Ao Transiton ~ | Do

oo |Prdocn + | Loggng Prfies

I () Cestnstion 1
P S Y Yy vy ppm pyovypyeres T P i T 2 1P Gt o Ve s 3 Pt PR

Erorsd Cormmanid 0 polcy Kemreniueb kst bips

Cormrorie] 0 pfcy [Commorfuch,_rlistallon iz urkon koo

(Carmarind Q_paicy (Cammartueb,_rl_fstallon_bips

(Cammarird _picy (Camrartush e istallon_bips ?
(a0 pley [Comrertueb_rle st hips urkon unknown 3
(Carmarind Q_paicy (Cammartueb,_rl_fstallon_bips =
(ermrorir,0 ey Comentueb,_rl st bips i

Hodap 3

Moot T Comt

Noaop T e
(a0 ey [Comertuet_rl st hips [P ™

N ok TP Comd

You may verify this, by going to Security > Network Firewall > Active Rules, then selecting the context
for route domain 0. Note the Count field next to each rule as seen below. Also note how each rule will
also provide a Latest Matched field so you will know the last time each rule was matched: (Investigating
Counter behavior)

‘Socurlty » Network Firewall: Active Rules

Ruls Lists Address Lists || PortLists P insligence

Context Fiter

Polcy e Enforced v

Contost Route Domain.. v 0

[Fiter rcve s Lst v | Add Rule List v | | Add Rule v
I3 [+ Name [stte Frotocol Source Destination Action. Logging Count LatestMateh

= Global with policy Global

1 Ping Enabled icwP Any any AcceptDecisively Yes. o Never
2 Drop_DNS Enatied any Any frasses Drap No 1208 Jun 21 2018 01:47:57-0700
Clean up DNS noise for b 8844
8888

< Route Domain 0 with policy 10 policy.

1 Enabled Any
Enabled Tep Any prasses AcesptDecisivaly Yes 1" Jun 21 2018 01:44:14-0700
1030.0.50
Pans
a0
reject 102000 Enabled Tep pora— any Reject Yes a7 Jun 21 2018 01:46:47-0700
10200024
(Defaul) Enabled Any. Any. Any. Relect No 0 Never

Creating an Additional Rule List for Additional Services

Rules and Rule Lists can also be created and attached to a context from the Active Rules section of the
GUI. Go to the
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Security > Network Firewall > Rule Lists
Create a Rule List called application_rule_list then click Finished.

Enter the rule list by clicking on its hyperlink, then in the Rules section click Add, and add the following
information, then click Finished.

Name allow_http_8081 10.1.20.11
Protocol TCP
Source Leave at Default of Any

Destination Address

Specify...10.1.20.11, then click Add

Destination Port

Specify. .. Port 8081, then click Add

Action
Logging

Accept-Decisively
Enabled

Securtfy i Mebwork Firewedl - Rule Lists » applicafion_rule lst : allow_hitps 10 1_20 11

Rula Proparties
Hame allew_higgs 10120 11
(LT ] Autn Ganerate ILID
Partition ! Path Camman
Deseriplion
Stale Enabled ¥
Protocol TCFR LAk
Subscriber: Any T
AddressRegion: [ Any T
Source Fort: Any v
VLAN / Tunnel: [Any ¥
Zore: Any T
Addres=Region: [ Specify . ¥
= Atdress ' Addres= List ' Addre=s Range ' Blacklisl Cateparies ' Country/Region
101201 A
L
Edil| [Deeeter
Dexslinalion Poit: Spacify_ ¥
% PardY Pari Ranga Y Port List
L=
80 I
-
Edil| [Delete
Zone: Any v
iRuls Hana ¥
Action Accepl Deosively W
Send |o Wirtual Mana v
Loggng Enabled ¥
Senice Policy Hane T
Protacol Inspeclion Profie Hane T
Classification Palicy Hone ¥
Upsdaser || Crbete

Enter the rule list by clicking on its hyperlink, then in the Rules section click Add, and add the following
information, then click Finished.
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Name allow_ssh 10.1.20.11

Protocol TCP

Source Leave at Default of Any

Destination Address | Specify...10.1.20.11, then click Add
Destination Port Specify. .. Port 22, then click Add
Action Accept-Decisively

Logging Enabled

_static/classl/image214.png

Add Another Rule List to the Policy

Use the Policies page to add the new firewall rule list to the rd_0_policy.
Open the Security > Network Firewall > Policies page.

Click on the policy name to modify the policy.
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The only current active rule list is for the web_policy. Click on the arrow next to Add Rule List, then
select, Add the rule list AT END) to add the new rule list you just created. For Name begin typing
‘application_rule_list’, select /Common/application_rule_list, then click Done Editing.

Remember to Commit the changes to system before proceeding.

Once completed, you should see a policy similar to the one below:

M ewe takb el +T
[ & wetl Fcd o iZtrl + -]

Mewe incogrhito weind o CErl + =Zhift + M

Review the rules that are now applied to this route domain by navigating to:
Security > Network Firewall > Active Rules.
From the Context Filter select Route Domain 0.

Click on the Add Rule List to Global from the ypper right corner of the screen and click Cancel (note:this
is a GUI bug)

Click on the Add Rule List to Route Domain from the ypper right corner of the screen and click Cancel
(note:this is a GUI bug)

your screen should show the web_rule _list you assigned earlier through the Route Domain Screen.

Seerity 1 Network Firewal - Active Rules
# - | hetve Rules
[

Policies.

Rule Lists:

Context Filter

Poly Tyee Enfarezd ¥

Context Route Domai... ¥ |[0

[FiterActve RlesLis T AddRue Lt || AddRuk

‘ ‘ D ‘ + ‘ Name Sue Proocal Souree Destration faton Logaing ot LastMach
| Glol with ol Glod
Eratiss o sy ay [rmr—— T 0 Heser
| Route Doman 0 it paey ¢ 1 5oy
Ersiss sy
i s g Ersisd TP sy sy [rn— = 0 Neser
0121012013
Porta.
0
: s s Eratiss Tt sy et [rmr—— e 0 erer

101.201410.1.20.18
Ports
44

Enabled TCP Ay Adtresean AcozptDecisiely Ves 0 Hever
101201
Ports
442

{Defat) Enabied day by by Refect o 0 Hever

The new ordering should look something like the screen shot below:
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Security » Network Firewall : Active Rules

75 v Active Rules Policies Rule Lists Schedules IP Intelligence v
—

Context Filter

Policy Type
Context
[ Fiter Actve Rules List v [ Ada Rule List~ | [ Add Rule v | [ Reset stats »
[JD [ + ‘Name ‘Sta(e ‘ Protocol Source Destination Action ‘Lnggmg ‘Cnunt ‘ Latest Match

) Global with policy Global
o Ping Enabled IcMP Any Any Accept-Decisively Yes 0 Never
£ Route Domain 0 with policy rd_0_policy
g 1 B web_rule list Enabled Any

11 alllow_http Enabled Tcp Any Addresses Accept-Decisively Yes 0 Never
10.1.20.11-10.1.20.13
Ports
80

1.2 allow_https Enabled TCP Any Addresses. Accept-Decisively Yes 0 Never
10.1.20.14-10.1.20.15
Ports
443

13 Allow_8081_10_1_20_11 Enabled Tcp Any Addresses Accept-Decisively Yes 0 Never
10.1.20.11
Ports
8081

(Default) Enabled Any Any Any Reject No 0 Never

Test Access to the Servers

» Open the incognito Web browser and access http://10.1.20.11:8081
* Open a new Web browser and access http://10.1.20.11

Success!!

et window

New ncogitowindo — Cll+Shifze

» Next open Putty Application on the Desktop, select Lamp Server-10.1.20.11.

» For the login as: type in f5 and hit <Enter>
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_static/classl/image2l13.png

» If you received a login prompt in your Putty terminal

Success!!

Test Server Access 8081 & SSH

Before we continue let’s clean up the rules just a little for best practices. Use the Rule Lists page to con-
solidate the firewall rule ‘web_rule_list’ with the “application_rule_list’ since these rules would ttypically
be in the same rule list

Open the Security > Network Firewall > Polocies page.

Select the RD_0_policy

Check the box in front of ‘application_rule_list’ and press the Delete button

Commit Changes to System

Open the Security > Network Firewall > RuleLists page.

Check the box in front of “application_rule_list’ and press the Delete button (2x-Confirm action)
Click on the rule list ‘web_rule_list’ to modify the rule list.

Enter the rule list by clicking on its hyperlink, then in the Rules section click Add, and add the following
information, then click Repeat.
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Name allow_http_8081_10_1 20 11
Protocol TCP

Source Leave at Default of Any

Destination Address | Specify...10.1.20.11, then click Add
Destination Port Specify...Port 8081, then click Add
Action Accept-Decisively

Logging Enabled

Remove the IPaddress and Port, enter the following information, then click Finished.

Name allow_ssh 10.1.20.12

Protocol TCP

Source Leave at Default of Any

Destination Address | Specify...10.1.20.12, then click Add
Destination Port Specify... Port 22, then click Add
Action Accept-Decisively

Logging Enabled

Inspect the properties of the rule list to verify the changes were made
Review the rules that are now applied to this route domain by navigating to:
Security > Network Firewall > Active Rules.

From the Context Filter select Route Domain 0.

Click on the Add Rule List to Global from the upper right corner of the screen and click Cancel (note:this
is a GUI bug)

Click on the Add Rule List to Route Domain from the ypper right corner of the screen and click Cancel
(note:this is a GUI bug)

your screen should show the web_rule _list you assigned earlier through the Route Domain Screen.

Securly 1 Nebwork Firewall: Active Rules
4~ AcweRues | Foices

Context Filter

Poly Type: Enforced ¥
Cortext Roe Domein__ V][0

A Add Rule List~ | | Add Rule = | | Reset Stais~

‘ ‘ D ‘ ¥ ‘Nan\e e [ e Destinston baton Leggng ot Lates Mstch

2 Gotel with poiey Gl

Ensbied cuP Ay by Aozt Decisiely

H

- Route Domain  with policy rd_0_policy
Ensbied foy

1 low_hp Ensbied el Ay oo

g Aozt Decisiely
0120414012013
]

H

il

2 low_hps Ensbied e iy Loomess

g Aoyt Decisiely
0120141012015
]

H

)

13 alow_hps_ 10120141 Enabled o oy Aames

. Aoyt Decisively
101204
3

g

)

(e Enstied foy foy by Rejec Ho 0 Neer

Test the New Firewall Rules

Once again you will generate traffic through the BIG-IP AFM and then view the AFM (firewall) logs.
» Ping 10.1.20.11
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* Open a new Web browser and access http://10.1.20.11

» Open a new Web browser and access http://10.1.20.11:8081

» Open a new Web browser and access https://10.1.20.12 (site cant be reached)

<Enter>

Next open Putty Application on the Desktop, select Lamp Server-10.1.20.12. login as: type in f5 and

In the Configuration Utility, open the Security > Event Logs > Network > Firewall page.

Inspect for the expected log entries

During this lab we have used Rules/Rule Lists applied to global and Route Domain objects. This is typical
in a “Data Center” firewall implemntation where BIG-IP is positioned as a standalone firewall.

The BIG-IP Firewall module can also be used on a BIG-IP configured as an Application Delivery Con-
troller/Load Balancer. For these environments additional granularity and East - West traffic control can be
implemented by applying Ruls/Rule Lists to specific Virtual Servers or Self-IP’s

View Firewall Reports

View several of the built-in network firewall reports and graphs on the BIG-IP system. Open the Security
>Reporting > Network > Enforced Rules page. The default report shows all the rule contexts that were

matched in the past hour.

View By:| Rule Contexts (Enforced) v | | TimePeriod:| Last Hour ¥ | | Expand Atvanced Filters v

Measurernen t[Top v ||ACLmatches ¥ | | Charttype:  Absolute ¥

100

Auto Refresh Disabled ¥

o -
0z:05 0z:10 0zi15 0zizn 0z:2s

@ B common IFV4_TCF.
@ E aggregated

@ W Global

v W oerall

0z:30

02i35

0z:i40 0245 0zi50 02i55

¥ ACL matches

The default view gives reports per Context, in the drop-down menu select Enforced Rules.
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View By:| Rules (Enforced) v | Time Period:| LastHour v | | Expand Atvanced Filiers ¥ Auta Refresh | Disabled v

Measurement Top ¥ | ACLmatches ¥ | | Charttype: | Absolute ¥

ACL matches per Rule {Enforced)

250

200

150

100

S0

~_ —
02105 02:10 0215 0220 0225 0230 02:35 0z:40 02:45 02:50 0z:55

Details
| Rule Enforced) | ¥ acL matches
@ M (st 450
@ B jCommontweb_rule_lstreject 10_20_0_0 a
@ [ iCommantweb_nie_istallow_htp 2
@ B scommoniapplication_rule_lstallow_http 1
v W ping 1
2 W overal 589

Total Entries:§

From the View By list, select Destination Ports (Enforced).

View By: | Destination Ports (Enforced) - | Timg
Rule Context Types (Enforced)
Rule Actions (Enforced)
VLANSs (Enforced)

Policies (Enforced)

Scurce |P Addresses (Enforced) FS pe
Source Ports (Enforced)
Destination |IP Addresses (Enforced)

This redraws the graph to report more detail for all the destination ports that matched an ACL.

View By:  Destination Ports (Enforce ) v | | Time Period: |LastHour v | | Expand Advanced Filters v

Auta Refresh| Disabled ¥

Measurement | Top v |[ACLmatches ¥ | | Charttype: Absolute ¥

ACL matches per Destination Port (Enforced)
250 4

200 -

150 -

100 -

02:05 0210 02:15 0z:20 0225 02:30 02:35 0240 02:45 0250 02:55

Detaits

! Destination Part Enforcen) | v act matenes

v W 101
@ m 7 165
v @ 100 118
W W 5355 106
v W s 6
@ W sggregated 4
v W e 1
v W Overall 589

Total Entries: 7

From the View By list, select Source IP Addresses (Enforced). This shows how source IP addresses
matched an ACL clause:
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eeeeeeeeeeeeeeeeeeee

ACL matches per Source IP Address (Enforced)

nnnnnn

v act matces \

1.2.6 AFM Reference Material
» Network World Review of AFM: F5 data center firewall aces performance test:
http://www.networkworld.com/reviews/2013/072213-firewall-test-271877.html

* AFM Product Details on www.f5.com:
http://www.f5.com/products/big-ip/big-ip-advanced-firewall-manager/overview

* AFM Operations Guide:

https://support.f5.com/content/kb/en-us/products/big-ip-afm/manuals/product/
f5-afm-operations-guide/_jcr_content/pdfAttach/download/file.res/f5-afm-operations-guide.pdf

**Written for TMOS 15.1.0

i « IT aqility. Your way.

1.3 Lab 2 - AFM Packet Tester, Flow Inspector, Stale Rule Lab

1.3.1 Lab Overview

New in the v13 release of the BIG-IP Advanced Firewall Manager is the capability to insert a packet trace
into the internal flow so you can analyze what component within the system is allowing or blocking packets
based on your configuration of features and rule sets.
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1/0
HUD Chain
ePVA LTM+ASM+GTM+APM L7 DOS

2.4 P HW Flow Input
DOS Intel Accel

L2
NEE S
Packet Filter Rules

Flow Lookup

Listener
L3 Lookup

T'CT-94d

Virtual
Global IP Intel Server
12.1+

L2-4 DOS DROP = Silently Discard
(software) REJECT = TCP Reset or ICMP Unreachable
NO MATCH = Silently Discard

The packet tracing is inserted at L3 immediately prior to the Global IP intelligence. Because it is after the
L2 section, this means that:

» we cannot capture in tcpdump so we can’t see them in flight, and
* no physical layer details will matter as it relates to testing.

That said, it’s incredibly useful for what is and is not allowing your packets through. You can insert tcp, udp,
sctp, and icmp packets, with a limited set of (appropriate to each protocol) attributes for each.

1.3.2 Advanced Firewall Manager (AFM) Packet Tracer

Create and View Packet Tracer Entries

In this section, you will generate various types of traffic as you did previously, but now you will view the flow
using the network packet tracer. Login to bigip01.f5demo.com

(10.1.1.4), navigate to Security > Debug > Packet Tester.
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Network » Network Security : Packet Tester

Packet Parameters

Protocol TCP ¥
TCP Flags SYN # ACK RST URG PUSH FIN
IP Address
Source Port
VLAN DMZ v
TTL 255
IP Address
Destination
Port
Trace Options Use Staged Policy No v | Trigger Log | No v

Faun Trace

Create a packet test with the following parameters:

Protocol TCP
TCP Flags SYN
Source IP -1.2.3.4 Port — 9999 Vlan — external
TTL 255

Destination IP—-10.1.20.11 Port - 80
Trace Options | Use Staged Policy — no Trigger Log - no

Click Run Trace to view the response. Your output should resmeble the allowed flow as shown below:

Security » Debug : Packet Tester

Packet Parameters

Protocol TcP v
TCP Flags SYN ¥ ACK RET URG PUSH FIN
IF Address | 1.23.4
Source Port 9999
WLAN OUTSIDE ¥
TTL 255
IP Address | 10.30.0.50
Destination
Fort a0
Trace Options Use Staged Policy | Mo v | TriggerLog | Mo v

Meww Packet Trace | ¢/ Clear data

Trace Results 2018-07-27 14:58:26
Device Device Device Route Domain Route Damain Virtual Server Vitual Server Virtual Senver Device
IP Intelligence Dos Rules IP Intelligence Rules P Intelligence Cos Rules Default

‘ MNAT |

You can also click on the “Route Domain Rules” trace result and see which rule is permitting the traffic.
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Trace Results

Device Device Device Route Domain Route Domain Wirtual Server Wirtual Server
IP Intelligence DoS Rules IP Intelligence Rules IP Intelligence DoS
AT Result Decisive Allow
Policy iCommondrd_0_policy
Name -

Policy type Enforced

Policy

Staged Mo

Rule Name /Commonfet_role_listallow

Route
Domain {Commond
Hame

Source
FQDN

Source
Geo Mo-lookup
Location

unknown

Destination unknown
FQDN
Nastinatinn T

3

Virtual Server
Rules

Click New Packet Trace (optionally do not clear the existing data — aka leave checked).

Create a packet test with the following parameters:

Protocol

TCP

TCP Flags

SYN

Source

IP -1.2.3.4 Port — 9999 Vlan — Outside

TTL

255

Destination

IP-10.1.20.11 Port - 8081

Trace Options

Use Staged Policy — no Trigger Log - no

2018-07-06 06:1 305

Device
Default

Click Run Trace to view the response. Your output should resemble the allowed flow as shown below:

Security » Debug : Packet Tester

tor 3 ster Redirect Drop

Packet Parameters

Protocal TCP_~

TGP Flags SVM ACK RET URG PUEH

IP Address | 1.2.3.4

Source Fort 9999
VLAR APP
TTL 255
IP Address | 10.30.0.50
Destination

Part 2081

Trace Options Use Staged Policy | Mo v | Triggerleg |Mo

FIN

Mew Packet Trace Clear data
Trace Results
Device Device Device Route Domain Route Dorman wirtual Server wirtual Server
IP Intelligence Dos Rules IP Intelligence Rules IP Intelligence Dos

Virtual Semver
Rules

——

2018-06-21 18:145:38

Device
Default
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Protocol TCP

TCP Flags SYN

Source IP - 1.2.3.4 Port — 9999 Vlan — Outside
TTL 255

Destination IP—-10.1.20.11 Port - 443

Trace Options | Use Staged Policy — no Trigger Log - no

This traffic will be blocked by the default deny rule

This shows there is no rule associated with the route domain or a virtual server which would permit the
traffic. As such, the traffic would be dropped/rejected.

1.3.3 Advanced Firewall Manager (AFM) Flow Inspector

Create and View Flow Inspector Data

A new tool introduced in version 13 is the flow inspector. This tool is useful to view statistical information
about existing flows within the flow table. To test the flow inspector, navigate to Security > Debug > Flow
Inspector. Refresh the web page we’ve been using for testing (http://10.1.20.11) and click “Get Flows”.

MK—SSH from jumphost to 10.1.20.11 (no login but session will show up in flows)

(mkurath—Opened incident C3173863 — | could not see any flow data)

ssssssss

mmmmmmm

Cliont Side

aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

nnnnnnnn

M Lasthop Igle Timeout

This will show the TMM this is tied to as well as the last hop and the idle timeout. This data is extremely
valuable when troubleshooting application flows.

It is also worth noting you can click directly on the IP address of a flow to pre-populate the data in the packet
tester for validating access and/or where the flow is permitted.

1.3.4 Stale Rule Report

AFM also can list out stale rules within the device its self. You must first enable the feature. To enable,
navigate to Security >Reporting > Settings > Report Settings. You will then need to check “Collect
Stale Rules Statistics” found under the Network Firewall Rules Section. Please be sure to click “Save”
before proceeding.
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Security » Reporting : Settings : Reporting Settings

¥+ ~ | Reporting Settings | Real-Time 5

eporting Settings

Local Storage #| Enabled

Remaote Starage Enabled

DoS HTTP Collect All DoS Statistics
Frotocol DME ¥ Collect Source IP Address
DoS Metwark ¥ Collect Source IP Address

#| Collect Source P Address

#| Collect Destination IP Address
Collect Source IP Part

#| Collect Destination IP Part
Collect Server Side Statistics

#| Collect Stale Rules Statistics

Metwork Firewall Rules

¥ Collect Source IP Address and Port

TCFRIF Errars
¥ Collect Destination IP Address and Port

SMTF Configuration for Repoarts
Export

Save

Once enabled, navigate to Security >Reporting > Network > Stale Rules. Feel free to refresh the web
page we've been testing with (http:/10.1.20.11) to see data populate into the rules.

na canfiguration found ¥ (|Create...

Note: It could take 60+ seconds for data to populate

Security » Reporting : Network : Stale Rules

2 /[ Enfore

wules | TCPAP Errors

1Pintelige

Time Range | LastHour v | | Expand Advanced Fiters ¥

Stale Rules.
Context Type Context Name. Palicy Name Policy Type Rule  Hit Count ~ Last Created / Updated

ol Domei oommond Soommoni.0_solc Enis p————— o o S, 14 secnds a0
[ FoueDoman ] Entoe ommripptctinietalon o o T ——

| oiobal rewallnies Enforced
| otovat

| Rose comain

0 1 hour 3 minutes, 14 seconds ago

rewall-rules Enforced

2 1 hour, 3 minutes, 14 seconds ago

Enforced 23 1 hour, 3 minutes, 14 seconds ago

This information is quite useful for keeping a rule base tidy and optimized.
Anyone can create a firewall rule, but who is the person that removes the unneccesary ones?
**Written for TMOS 15.1.0

« IT agility. Your way.
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1.4 Lab 3 - AFM DDoS Lab

1.4.1 Lab Overview

During this lab, you will configure the BIG-IP system to detect and report on various network level Denial of
Service events. You will then run simulated attacks against the BIG-IP and verify the mitigation, reporting
and logging of these attacks.

1.4.2 Detecting and Preventing DNS DoS Attacks on a Virtual Server

It is day two of your career at Initech, and you are under attack!! You walk into the office on day two only
to learn your DNS servers are being attacked by Joanna who took out her flair frustrations on your DNS
servers. Before you can protect the servers however, you must first tune and configure them appropriately.
(The most challenging part of DoS based protection is tuning correctly).

In this section of the lab, we’ll focus on creating DOS profiles that we can assign to virtual servers for
protection. Let’s get started!

Base BIG-IP Configuration

In this lab, the VE has been configured with the basic system settings and the VLAN/self-IP configurations
required for the BIG-IP to communicate and pass traffic on the network. We will now need to configure the
BIG-IP to listen for traffic and pass it to the back-end server.

1. Launch the Chrome shortcut titled “BIG-IP UI” on the desktop of your lab jump server. For this lab
you will be working on bigip1.dnstest.lab (http://192.168.1.100). The credentials for the BIG-IP are
conveniently displayed in the login banner. Just in case: admin / 401elliottW!

2. Navigate to Local Traffic > Nodes and create a new node with the following settings, leaving unspec-
ified fields at their default value:

* Name: lab-server-10.10.0.50
« Address: 10.10.0.50
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Local Traffic » Nodes : Node List » New Hode...

General Properties

Name | Iab-server-10.10.0.50
Description |

@ address ) FQDN
Address

| 10.10.0.50

Configuration

Health Monitors I MNode Default :

Ratio | 1
Connection Limit |0
Connection Rate Limit | 0

[ Cancel ] [ Repeat ] [ Finished ]

3. Click Finished to add the new node.

4. Navigate to Local Traffic > Pools and create a new pool with the following settings, leaving unspeci-

fied attributes at their default value:
» Name: lab-server-pool
+ Health Monitors: gateway_icmp
* New Members: Node List
— Address: lab-server-10.10.0.50

— Service Port: * (All Services)

— Click Add to add the new member to the member list.

34
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Local Traffic » Pools : Pool List :» New Pool...

Configuration: I Basic :
Name | lab-senver-pool
Description [
Active Available
'Common ‘Common 5

Health Monitors

gateway_icmp http |E|

http_head_f5
https

https_443 -

Resources
Load Balancing Method | Round Rabin |=]
Priority Group Activation I Disabled :
2 Mew Node ) New FQDN Mode @ Node List
Address: | lab-server-10.10.0.50 (10.10.0.50) ||
Senice Port | 7| [ All Services |+ |
MNew Members L Add
Mode Mame | Address/FQDN ‘ Senice Port | Auto Populate | Priority
lab-server-10.10.0.50 10.10.0.50 * 0

[ Cancel ][ Repeat ] [ Finished]

5. Click Finished to create the new pool.

6. Because the attack server will be sending a huge amount of traffic, we'll need a large SNAT pool.
Navigate to Local Traffic > Address Translation > SNAT Pool List and create a new SNAT pool

with the following attributes:
* Name: inside_snat_pool
* Member List (click Add after each IP):

10.10.0.125, 10.10.0.126, 10.10.0.127, 10.10.0.128, 10.10.0.129, 10.10.0.130

 Click Finished

1.4. Lab 3 - AFM DDoS Lab
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Local Traffic » Address Translation : SNAT Pool List :: New SNAT Pool...

General Properties

I Mame inside_snat_poaol

Configuration

P Address:l 10.10.0.130|
Add

10.10.0.125

Member List 10.10.0126

10100127 ‘
10.10.0.128
10.10.0.129 o

|3

leam |

| Cancel || Repeat | | Finished |

7. Navigate to Local Traffic > Virtual Servers and create a new virtual server with the following settings,
leaving unspecified fields at their default value:

* Name: udp_dns_VS
+ Destination Address/Mask: 10.20.0.10
+ Service Port: 53 (other)
* Protocol: UDP
» Source Address Translation: SNAT
» SNAT Pool: inside_snat_pool
+ Default Pool: lab-server-pool
8. Click Finished
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Local Traffic » Virtual Servers : Virtual Server List »

udp_dns_WV5

Properties Resources Security - | Statistics E|

o~

‘General Properties

Name udp_dns_W5S

Partition / Path Commaon

Descripticn |

Type | standard =
Source Address [0.00.00

Destination Address/Mask [10.200.10

Service Port [ 53 [ Cther: =]
Metify Status to Virtual

Address

Availability () Awailable (Enabled) - The virtusl server is available
Syncockie Status Off

State Enabled :
Configuration: | Basic :

Protocol UoP
Protocol Profile {Client) udp
Frotocol Profile (Senver) | {Use Client Profile) E|
Selected Available

- Common -

SSL Profile [Client) clientss] s 5]
clientssk-insecure-compatible [=
clientssl-secure
w crypto-server-default-clientssl =
Selected Available

- Common -

SSL Profile (Server) apm-default-serverss| |:|
crypto-client-default-serverss|
pooip-default-serverss|

- serverss| =
SMTPS Profile MNone
Client LDAP Profile MNone
Server LDAP Profile None
SMTP Profile MNone
Netflow Profile Nene
VLAN and Tunnel Traffic | [ All VLANs and Tunnels [+ |

Source Address Translation SMNAT
SMAT Pool inside_snat_pool :

Content Rewrite

Rewrite Profile | Mone El
HTML Profile None
Acceleration

| Rate Class | None :

9. We'll now test the new DNS virtual server. SSH into the attack host by clicking the “Attack Host
(Ubuntu)” icon on the jump host desktop.

10. Issuethe dig @10.20.0.10 www.example.com +short command onthe BASH CLI of the
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attack host. You should see output similar to:

This verifies that DNS traffic is passing through the BIG-IP.

11. Return to the BIG-IP and navigate to Local Traffic > Virtual Servers and create a new virtual server
with the following settings, leaving unspecified fields at their default value:

» Name: other_protocols_VS
+ Destination Address/Mask: 10.20.0.10
« Service Port: * (All Ports)
 Protocol: * All Protocols
+ Any IP Profile: ipother
» Source Address Translation: SNAT
» SNAT Pool: inside_snat_pool
+ Default Pool: lab-server-pool
12. Click Finished
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Local Traffic »» Virtual Servers: Virtual Server List »» New Virtual Server...

General Properties

Mame I other_protocols_WS
Description I
Type | Standard E
Source Address I
Destination Address/Mask I 10.20.0.10
Senice Port E [ranPots |+
Motify Status to Vifual Address
State I Enabled :
Configuration: I Basic |«
Protocol |“AII Protocols :
HTTP Proxy Connect Prafile [ Nane =]
Any IP Praofile I ipother j
S5H Proxy Profile I Mone j
VLAN and Tunnel Traffic [ Al VLANS and Tunnels [» |
Source Address Translation | SMAT :
SHAT Poal I inside_snat_pool :
Resources
Enabled Available
- ‘Commaon <
_sys_APM_ExchangeSupport_OA_BasicAuth| |
iRules _sys_APM_ExchangeSupport_OA_Ntimauth
il _sys_APM_ExchangeSupport_helper
_sys_APM_ExchangeSupport_main -
Default Poal I lab-zerver-pool :

13. Return to the Attack Host SSH session and attempt to SSH to the server using SSH 10.20.0.10.
Simply verify that you are prompted for credentials and press CTRL+C to cancel the session. This
verifies that non-DNS traffic is now flowing through the BIG-IP.

Establishing a DNS server baseline

Before we can prevent Joanna from attacking our DNS server, again, we should establish a baseline for
how many QPS our DNS server can handle. For this lab, let’s find the magic number of QPS that causes
50% CPU utilization on the BIND process.

1. Connect to the Victim Server SSH session by double-clicking the Victim Server (Ubuntu) shortcut
on the jump host desktop.

2. From the BASH prompt, enter top and press Enter to start the top utility.

3. You will see a list of running processes sorted by CPU utilization, like the output below:

1.4. Lab 3 - AFM DDoS Lab 39



F5 Firewall Solutions Documentation

ubuntu@wvictirmserver: ~ ===l @
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4. Connect to the Attack Host SSH session by double-clicking the Attack Host (Ubuntu) shortcut on the
jump host desktop.

5. Start by sending 500 DNS QPS for 30 seconds to the host using the following syntax:

dnsperf -s 10.20.0.10 -d queryfile-example-current -c 20 -T 20 -1 30 —-g
10000 -0 500"

6. Observe CPU utilization over the 30 second window for the named process. If the CPU utilization
is below 45%, increase the QPS by increasing the -Q value. If the CPU utilization is above 55%,
decrease the QPS. This

7. Record the QPS required to achieve a sustained CPU utilization of approximately 50%. Consider this
the QPS that the server can safely sustain for demonstration purposes.

8. Now, attack the DNS server with 10,000 QPS using the following syntax:
dnsperf -s 10.20.0.10 -d queryfile-example-current -c 20 -T 20 -1 30 —qg
10000 -0 10000°

9. You'll notice that the CPU utilization on the victim server skyrockets, as well as DNS query timeout
errors appearing on the attack server’s SSH session. This shows your DNS server is overwhelmed.

Configuring a DoS Logging Profile

We’'ll create a DoS logging profile so that we can see event logs in the BIG-IP Ul during attack mitigation.

1. On the BIG-IP web Ul, navigate to Security > Event Logs > Logging Profiles and create a new
profile with the following values, leaving unspecified attributes at their default value:

 Profile Name: dns-dos-profile-logging
* DoS Protection: Enabled
» DNS DoS Protection Publisher: local-db-publisher and click Finish.
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Security » Event Logs : Logging Profiles :» Create New Logging Profile...

Logging Profile Properties

I Profile Mame | dns-daos-profile-lagging
Description |
Protocaol Security [CEnabled
Metwork Firewall "l Enabled
Metwork Address Translation [l Enabled
DoS Protection Enabled
Protocol Inspection [l Enabled
Classification [Tl Enabled
DoS Protection
DNS DoS Protection
Publisher | local-db-publisher =
SIP DoS Protection
Publisher | none E
Hetwork Do5 Protection
Publisher | none E

| Cancel | | Finished |

Configuring a DoS Profile
We will now create a DoS profile with manually configured thresholds to limit the attack’s effect on our
server.

1. Navigate to Security > DoS Protection > DoS Profiles

2. Create a new DoS profile with the name dns-dos-profile.

3. Click Finished.
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Security » DoS5 Protection : Do5 Profiles :: New Dos Profile

Properties

Mame dns-das-profile

Description

| Cancel || Finished

The Ul will return to the DoS Profiles list. Click the dns-dos-profile name.
Click the Protocol Security tab and select DNS Security from the drop-down.
. Click the DNS A Query vector from the Attack Type list.

N o o &

Modify the DNS A Query vector configuration to match the following values, leaving unspecified at-
tributes with their default value:

+ State: Mitigate

+ Threshold Mode: Fully Manual

+ Detection Threshold EPS: (Set this at 80% of your safe QPS value)
+ Mitigation Threshold EPS: (Set this to your safe QPS value)
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8.

DNS A Query

State

I Mitigate :

Threshold Mode
) Fully Automatic
) Manual Detection / Auto Mitigation

@ Fully Manual

Detection Threshold EFS
| Specify [+ | 400 |

Detection Threshold Percent
| Specify [ | | 500 |

Mitigation Threshold EPS
| Specify [ | | 500 |

["] simulate Auto Threshald

["| Bad Actor Detection

[ Cancel ][ Update

Make sure that you click Update to save your changes.

Attaching a DoS Profile

We will attach the DoS profile to the virtual server that we configured to manage DNS traffic.

1.

Navigate to Local Traffic > Virtual Servers > Virtual Server List.

2. Click on the udp_dns_VS name.

3. Click on the Security tab and select Policies.
4.
5

In the DoS Protection Profile field, select Enabled and choose the dns-dos-profile.

. In the Log Profile, select Enabled and move the dns-dos-profile-logging profile from Available to

Selected.
Click Update.

Simulate a DNS DDoS Attack

1.
2.

Open the SSH session to the victim server and ensure the top utility is running.

Once again, attack your DNS server from the attack host using the following syntax:

dnsperf -s 10.20.0.10 -d queryfile-example-current -c 20 -T 20 -1 30 —-g
10000 -0 10000
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3. On the server SSH session running the top utility, notice the CPU utilization on your server remains in
a range that ensures the DNS server is not overwhelmed.

4. Atfter the attack, navigate to Security > Event Logs > DoS > DNS Protocol. Observe the logs to see
the mitigation actions taken by the BIG-IP. Be sure to scroll right. ..

(& BIG-IP® - bigipLdnstestlab (1 X (3]

< g ® & https//192,168.1.100 Aui/ e @ | Q Search IN = @0 =
Pairtition: _Common -

ewall: Congistent
I OHLINE (ACTIVE)}
| Standalone

Security » Event Logs : Do% : DNS Protocol

% ~ | Protocol » | Metwork islation = | DoS * | Logging Profiles
—

iApps
@ DNS Jame |¢ Action | < Attack D | = Packets Inisec | = Dr
7 :am Drop ATH3856962 303 280
' Local Traffic

2 Drop ATH3556962 369 345
r—{ Traffic Intelligence hlogspatearm Drop 3793556862 138 17

net Dron ATH3A56962 365 nr

DNS DDoS Mitigations for Continued Service

At this point, you have successfully configured the BIG-IP to limit the amount of resource utilization on the
BIG-IP, thus further frustrating Joanna on her flair rage. Unfortunately, even valid DNS requests can be
caught in the mitigation we’ve configured. There are further steps that can be taken to mitigate Joanna’s
attack that will allow non-malicious DNS queries.

Bad Actor Detection

Bad actor detection and blacklisting allows us to completely block communications from malicious hosts at
the BIG-IP, completely preventing those hosts from reaching the back-end servers. To demonstrate:
Navigate to Security > DoS Protection > DoS Profiles.

Click on the dns-dos-profile profile name.

Click on the Protocol Security tab then select DNS Security.

Click on the DNS A Query attack type name.

o & 0N

Modify the vector as follows:
+ Bad Actor Detection: Checked
+ Per Source IP Detection Threshold EPS: 80
* Per Source IP Mitigation Threshold EPS: 100
+ Add Source Address to Category: Checked
» Category Name: denial_of_service
+ Sustained Attack Detection Time: 15 seconds

» Category Duration Time: 60 seconds
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DNS A Query

State

| Mitigate |

Threshold Mode

) Fully Automatic

() Manual Detection / Auto Mitigation
@ Fully Manual

Detection Threshold EPS
|Speciny| 400 |

Detection Threshold Percent
| Specify [+ | 500 |

Mitigation Threshold EPS
| Specify [+ | 500 |

[C] simulate Auto Threshaold
[V] Bad Actor Detection

Per Source IP Detection Threshold EPS
| specity [=] | 80 |

Per Source IP Mitigation Threshold ERPS
|Speciny| 100 |

Add Source Address to Category

Category Namel denial_of_service

Sustained Attack Detection Time
| 15 |sec0nds

Category Duration Time
| &0 |seconds

[C] Allow External Advertisement

6. Make sure you click Update to save your changes.

7. Navigate to Security > Network Firewall > IP Intelligence > Policies and create a new IP Intelli-
gence policy with the following values, leaving unspecified attributes at their default values:

» Name: dns-bad-actor-blocking

» Default Log Actions section:

— Log Blacklist Category Matches: Yes

+ Blacklist Matching Policy

— Create a new blacklist matching policy:

« Blacklist Category: denial_of_service

= Click Add to add the policy then click finished
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Security »» Network Firewall : IP Intelligence : Policies » New IP Intelligence Policy...

General Properties

MName oad-aclor-blocking

Description |

IP Intelligence Policy Properties

Selected Available
‘Common - -
Feed Lists Global

IP Reputation

Default Action Drop j

Log Whitelist Overrides No j
Default Log Actions

Log Blacklist Category Matches | Yes :

Blacklist Category IWE
Action lmg
Log Blacklist Category Matmeslmm
Log Whitelist Overrides lm‘z’
Match Override IWE

EER TR TR T Blacklist Category || Action 1 Log Blacklist Category Matches 1l Log Whitelist Overrides || Match Override

denial_of_semice Use Policy Default Use Policy Default Use Policy Default Match Source

8. Navigate to Local Traffic > Virtual Servers > Virtual Server List.
9. Click on the udp_dns_VS virtual server name.
10. Click on the Security tab and select Policies.

11. Enable IP Intelligence and choose the dns-bad-actor-blocking policy.
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Resources

% + | Properties

Local Traffic »» Virtual Servers : Virtual Server List ;» udp_dns_V5S

Security
N

Policy Settings: | Basic :
Destination 10.20.0.10:53
Service DMS

[[use Device Policy

F'olicyl Mone :

Maximum Bandwidth I 0 Mbps

Enforcemem:l Disabled :
Metwork Firewall
Staging: I Disabled :

Metwork Address Translation [[luse Route Domain Policy

Protocal Inspection Profile I Disabled :
IEnabIed... :

Service Policy None |+

Eviction Policy [ None

IP Intelligence [Enabled. [+] F‘olicy:| dns-bad-actor-blacking |= |
Do Protection Profile [Enabled. [+] F'roﬂle:l dns-dos-profile | = |

Auto Threshald

Dynamic Signatures Learning Phase End Time (Metwork):

Learning Phase End Time(DNS):

Selected
‘Common .
Log Profile dns-dos-profile-logging Log all requests
Log ilagal requests
globalnetwaork
- local-dos -
Update

12. Make sure you click Update to save your changes.

13. Navigate to Security > Event Logs > Logging Profiles.

14. Click the global-network logging profile name.

15. Under the Network Firewall tab (next to Protocol Security), set the IP Intelligence Publisher to
local-db-publisher and check Log Shun Events.

IP Intelligence

Publisher

Agagregate Rate Limit

| local-db-publisher

I Indefinite :

Log Translation Fields | Enabled
Log Shun Events Enabled
Log RTBH Events [“|Enabled
Log Scrubber Events | Enabled

(=]

16. Click Update to save your changes.
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17. Click the dns-dos-profile-logging logging profile name.

18. Check Enabled next to Network Firewall.
Security » Event Logs : Logging Profiles :: Edit Logging Profile

i+ -~ | Edit Logging Profile

Logging Profile Properties

Profile Mame dns-dos-profile-logaging
Partition / Path Common

Description |

Protocol Security [CEnabled

Network Firewall Enabled

Metwork Address Translation [C|Enabled

DoS Protection [¥| Enabled
Protocol Inspection [CIEnabled
Classification [C|Enabled

19. Under the Network Firewall tab, change the IP Intelligence Publisher to local-db-publisher and
click Update.

IP Intelligence

Publisher | local-db-publisher =]
Aggregate Rate Limit [ingefinite [=]

Log Translation Fields [Tl Enabled

Log Shun Events [CIEnabled

Log RTBH Events [CIEnabled

Log Scrubber Events [l Enabled

20. Bring into view the Victim Server SSH session running the top utility to monitor CPU utilization.

21. On the Attack Server host, launch the DNS attack once again using the following syntax:

dnsperf -s 10.20.0.10 -d queryfile-example-current -c 20 -T 20 -1 30 —-g
10000 -0 10000

22. You'll notice CPU utilization on the BIG-IP begin to climb, but slowly drop. The attack host will show
that queries are timing out as shown below. This is due to the BIG-IP blacklisting the bad actor.

out

23. Navigate to Security > Event Logs > Network > IP Intelligence. Observe the bad actor blocking
mitigation logs.

24. Navigate to Security > Event Logs > Network > Shun. This screen shows the bad actor being
added to (and later deleted from) the shun category.
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Security » Event Logs : Network : Shun

£+ + | Protocol

§

-

Metwiork

b

| Last Hour

Metwork Address Translation -

Cios

E Search| Custom Search..,

- | Logging Profiles

= Time

|
| = Shun P | = Shun Categary

2018-02-06 09:59:42
2018-02-06 08:58:42
2018-02-06 09:48:31

2018-02-06 08:47:30

1020050 iCommonfdenial_of_setvice
10.200.50 iCommontidenial_of_service
10.2000.80 iCommonidenial_of_serice
10.20.0.50

ICommonidenial_of_service

+ BhunTTL + Shun Action
1] Delete

59 Add

0 Delete

0 Add

25. While the attack is running, navigate to Security > DoS Protection> DoS Overview (you may need
to refresh or set the auto refresh to 10 seconds). You will notice from here you can see all the

details of the active attacks. You can also modify an attack vector right from this screen by clicking on
the attack vector and modifying the fly out.

Security » Do Protection : DoS Overview

fiew Filter

o Rotesn Siatios v Rotesh |
Eeredortore V] \ itk sttus = \ \ | Detocton ThesholaEP
Profile AftackVector & State & Family 4 Leaming & Confed & |- Aggregate 4 - BadActor & - Aftacked Destination 4 Curent 1min 1hour  Aggregate BadActor Aftacked Destination Threshold Mode Aggregate Bad Actor Aftacked [
dns-dos-profile A queny D05 Mitigate @ Learning udp_dns_vs {) None (-] @ None 200 9 0 12 o 0 FullyManual 800 20 NiA

DNS A Query

State
Mitigate: v
Thresheld Mode
Manual Detection / Auto Mitigation
© Fully Manual
iy
Detection Threshold Percent
Speciy *
Specify ¥ || 1000
¥ Bad Actor Detection
Specify ¥
Per Source IP Mitigation Threshold EPS
Specify ¥ || 100
¥ Add Source Address to Category
Category Name  denial_of_senice
Sustained Attack Detection Time
15 |sesanas
seconds

Allow Extemal Advertisernent

Cancel || Update

26. Navigate to Security > Reporting > Protocol > DNS. Change the View By drop-down to view
various statistics around the DNS traffic and attacks.
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‘ MeasurememlTUp : Fackets : Chart type: | Absolute :

Packets per VYirtual Server

200k -

150k -

100k

S0k -

T T T T T
08:10 06:20 0&;30 0&:40 06:50

Details

] i virtual Setver ¥ Packets |

B jCommaoniudp_dns_WS 294,554|

B Device Level
7 W overal 435,078 |

140,524 |

27. Navigate to Security > Reporting > Network > IP Intelligence. The default view may be blank.
Change the View By drop-down to view various statistics around the IP Intelligence handling of the

attack traffic.
28. Navigate to Security > Reporting > DoS > Dashboard to view an overview of the DoS attacks and
timeline. You can select filters in the filter pane to highlight specific attacks.

Security » Reporting : DoS : Dashboard

Last hour Feb &, 08:05:00 - 09:05:12 5 min. » > Refresh
3 1
[l ogm 0820 0830 0840 0850 agon i
Attack Duration . | ons
Il
[ Network | s
-
= Attack IDs [
o Q- Droppe..
& 127584038 0
g
5 3845487151 0
] Mot attacked o
. I I I I I 4052301326 0
0810 08:20 0830 0840 0850 08:00 = VNS AR 2
Criical @ High Moderate B Law S Rtps]
ICommanfudp_dns_8 ]
Attacks Device Leve| 0

# of Attacks (i}
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29. Finally, navigate to Security > Reporting > DoS > Analysis. View detailed statistics around each
attack.

31G-1P Health
Memory Usage (68)
® T ® Swp Other

£

[
4
2
0
06:15 06:30 06:25 06:30 06:35 08:40 06:45 06:50 06:55 o7:00 o708 o710

Top Busiest CPU Cores (%)

®CPU2 ®CPUD ® CcPUT ®CPU4 CPUT

0
06:15 06:20 06:25 06:30 06:35 06:40 06:45 06:50 06:55 07:00 0705 o710

Remote Triggered Black Holing

The BIG-IP supports the advertisement of bad actor(s) to upstream devices via BGP to block malicious
traffic closer to the source. This is accomplished by publishing a blacklist to an external resource. This is
not demonstrated in this lab.

Silverline Mitigation

F5’s Silverline service offers “always on” and “on demand” DDoS scrubbing that could assist in this scenario
as well. This is not demonstrated in this lab.

Filtering specific DNS operations
The BIG-IP offers the ability to filter DNS query types and header opcodes to act as a DNS firewall. To
demonstrate, we will block MX queries from our DNS server.

1. Open the SSH session to the Attack Host.

2. Perform an MX record lookup by issuing the following command:
dig @10.20.0.10 MX example.com

3. The server doesn’t have a record for this domain. This server doesn’t have MX records, so those
requests should be filtered

4. Navigate to Security > Protocol Security > Security Profiles > DNS and create a new DNS security
profile with the following values, leaving unspecified attributes at their default value:

* Name: dns-block-mx-query

* Query Type Filter: move mx from Available to Active and click finished
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Security »» Protocol Security : Secunty Profiles : DNS :: New Security Profile...

Properties
Name | dns-block-mx-query
Description |
Query Type IEchusion :
Active Available
[r— [ -
Query Type Filter == b
y Typ it (
¥25
- afsdb -
Active Ayailable
A quel}' -
Header Opcode Exclusion

[ Cancel | [ Repeat | [ Finished |

5. Navigate to Local Traffic > Profiles > Services > DNS. NOTE: if you are mousing over the services,
DNS may not show up on the list. Select Services and then use the pulldown menu on services to
select DNS.

6. Create a new DNS services profile with the following values, leaving unspecified values at their default
values:

» Name: dns-block-mx
» DNS Traffic
— DNS Security: Enabled
— DNS Security Profile Name: dns-block-mx-query. Click finished
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Local Traffic » Profiles : Services : DNS »» New DNS Profile...

General Properties

Mame

Parent Profile

I dns-block-mx
I dns :

Denial of Service Protection

Rapid Response Mode

Rapid Response Last Action

I Disabled

Drop

Hardware Acceleration

Protocol Validation

Response Cache

Disabled

Disabled

DNS Features

DNSSEC
GSLB
DMS Express

DMNS Cache

DMNE Cache Name
DNS IPvE to IPvd
Unhandled Query Actions

Use BIND Server on BIG-IP

Enabled

Enabled

Enabled

Disabled

Select...

Disabled

Allow

Enabled

DMNS Traffic

DMNS Security

Zone Transfer

DS Security Profile Name

Process Recursion Desired

Disabled

(LRLLLELULLRLL

Enabled

dns-block-mx-query |z|

Enabled

Logging and Reporting

Logging

Logging Profile

AVR Statistics Sample Rate

Disabled

LB

Select...

[ Cancel ] [ Repeat ] [ Finished]

7. Navigate to Local Traffic > Virtual Servers > Virtual Server List.

8. Click on the udp_dns_VS virtual server name.

9. In the Configuration section, change the view to Advanced.
10. Set the DNS Profile to dns-block-mx.
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SN rume | raune
Netflow Profile [Nome [~
WebSocket Profile [Nome  [-]
SplitSession Client Profile I Mone
SplitSession Server Profile | Mone

DNS Profile [dns-block-mx [« ]
QoE Profile [None -]

GTP Profile [Nome -]
Request Adapt Profile [None  [7]
Response Adapt Profile [None  [¢]

RADILIS Profile I Mona
11. Click Update to save your settings.
12. Navigate to Security > Event Logs > Logging Profiles.
13. Click on the dns-dos-profile-logging logging profile name.
14. Check Enabled next to Protocol Security.
15. In the Protocol Security tab, set the DNS Security Publisher to local-db-publisher and check all
five of the request log types.
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Security » Event Logs : Logging Profiles :: Edit Logging Profile

7+ ~ EditLogging Profile

Logging Profile Properties

Profile Mame dns-dos-profile-logging
Fartition / Path Common

Description |

Protocol Security

Metwork Firewall Enabled

Metwork Address Translation [[Enabled

Do$ Protection [¥ Enabled
Protocol Inspection [[Enabled
Classification [[Enabled

Protocal Security | Metwork Firewall DoS Protection

HTTP, FTP, and SMTP Security

Publisher [ none I~
DNS Security

Publisher | local-db-publisher =

Log Dropped Requests [¥| Enabled

Log Filtered Dropped Requests Enabled

Log Malformed Requests [¥| Enabled
Log Rejected Requests [¥| Enabled
Log Malicious Requests Enabled

Storage Format |N0ne :

16. Make sure that you click Update to save your settings.

17. Return to the Attack Server SSH session and re-issue the MX query command:
dig @10.20.0.10 MX example.com

18. The query hangs as the BIG-IP is blocking the MX lookup.

19. Navigate to Security > Event Logs > Protocol > DNS. Observe the MX query drops.

Security » Event Logs: Protocol : DNS

¥ - | Protocol > | » | Logging Profiles

Source || Destination |

‘ort © YLAN = Address | < Part = Rowute Domain = DNS Query Type = DNS Query Mame  © Aftack Type | = Action
112 ICommonfoutzide 10.20.010 53 a [LE example com M Drop
112 fCommonfoutside 10.20.010 53 1} [k example.com M Crop
112 ICommaonioutside 1020010 53 o M example.cam MH Drop

This concludes the DNS portion of the lab. On the Victim Server, stop the top utility by pressing CTRL + C.
No mail for you Joannal!
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1.4.3 Advanced Firewall Manager (AFM) Detecting and Preventing System DoS and
DDoS Attacks

In this part of the lab, you'll focus on creating system-wide policies that mitigate attacks across the entire
BIG-IP instance.

Configure Logging
Configuring a logging destination will allow you to verify the BIG-IPs detection and mitigation of attacks, in
addition to the built-in reporting.
1. In the BIG-IP web Ul, navigate to Security > DoS Protection > Device Configuration > Properties.
2. Under Log Pubisher, select local-db-publisher.
3. Click the Commit Changes to System button.

Securily » Do$S Protection : Device Configuration : Properties

7% ~ | DoS Ovenview DoS Profiles Device Configuratio
Properties

Log Publisher | local-db-publisher E

Threshold Sensitivity I Medium :

Eviction Palicy | default-eviction-policy E

Simulating a Christmas Tree Packet Attack

Joanna was feeling festive this morning. In this example, we’ll set the BIG-IP to detect and mitigate Joanna’s
attack where all flags on a TCP packet are set. This is commonly referred to as a Christmas Tree Packet
and is intended to increase processing on in-path network devices and end hosts to the target.

We’ll use the hping utility to send 25,000 packets to our server, with random source IPs to simulate a DDoS
attack where multiple hosts are attacking our server. We’ll set the SYN, ACK, FIN, RST, URG, PUSH, Xmas
and Ymas TCP flags.

1. In the BIG-IP web Ul, navigate to Security > DoS Protection > Device Configuration > Network
Security.

2. Expand the Bad-Header-TCP category in the vectors list.
3. Click on the Bad TCP Flags (All Flags Set) vector name.
4. Configure the vector with the following parameters:

« State: Mitigate

» Threshold Mode: Fully Manual

« Detection Threshold EPS: Specify 50

 Detection Threshold Percent: Specify 200

» Mitigation Threshold EPS: Specify 100
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Bad TCP Flags (All Flags Set)

State

I Mitigate :

Threshold Mode

@ Fully Manual

Detection Threshold EPS
Specify 50

Detection Threshold Percent
Specify 200

Mitigation Threshold EPS
Specify 100

Cancel Update

5. Click Update to save your changes.

6. Open the BIG-IP SSH session and scroll the Itm log in real time with the following command: tail -f

/var/log/Itm
7. On the attack host, launch the attack by issuing the following command on the BASH prompt:
sudo hping3 10.20.0.10 --flood —--rand-source --destport 80 -c 25000 --syn
-—ack --fin --rst --push --urg --xmas —--ymas
8. You'll see the BIG-IP Itm log show that the attack has been detected:
9. After approximately 60 seconds, press CTRL+C to stop the attack.
1 1 i . NG wroe ——-destport ol
10. Navigate to Security > DoS Protection> DoS Overview (you may need to refresh or set the auto
refresh to 10 seconds). You'll notice from here you can see all the details of the active attacks. You
can also modify an attack vector right from this screen by clicking on the attack vector and modifying
the details in the fly out panel.
dos-device-conflg EadTOPﬂaBS'(aHﬂaEs sef) Mmuat; N-:-mc-n .R’Eadv' Device : Detected : QNU"E : eNDHE : o 728 o [ o o Fully Manual 50 A A
11. Return to the BIG-IP web Ul. Navigate to Security > Event Logs > DoS > Network > Events.
Observe the log entries showing the details surrounding the attack detection and mitigation.
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Security » Event Logs : DoS : Network : Events

- Address Translation = | DoS = | Logging Profiles

£ ~ | Frotocol > | Metwork ~ | Metwo

| Destination |
Cuntext| + Address i = FPort . = Event I = Twpe i = Action i = Aftack D ! = Packets Inf sec | = Dropp
evice Aftack Stopped  Bad TCP flags (all lags sety  Mone 41123876591 0 0
Evice 1020010 80 Aftack Sampled Bad TCP flags {all flags sety Crop 4112387681 597 5497
evice 1020010 80 Aftack Sampled Bad TCP flags {all flags sety Crop 4112387681 593 593
Bvice 1020010 &0 Aftack Sampled Bad TCP flags {all lags sety Drop 41123876591 601 601

12. Navigate to Security > Reporting > DoS > Analysis. Single-click on the attack ID in the filter list to
the right of the charts and observe the various statistics around the attack.

Simulating a TCP SYN DDoS Attack

In the last example, Joanna crafted a packet that is easily identified as malicious, as its invalid. We’ll now
simulate an attack with traffic that could be normal, acceptable traffic. The TCP SYN flood attack will attempt
to DDoS a host by sending valid TCP traffic to a host from multiple source hosts.

1. Inthe BIG-IP web Ul, go to Security > DoS Protection > Device Configuration > Network Security.

2. Expand the Flood category in the vectors list.
3. Click on TCP Syn Flood vector name.

4. Configure the vector with the following parameters:

« State: Mitigate

» Threshold Mode: Fully Manual

+ Detection Threshold EPS: 200

+ Detection Threshold Percent: 500
+ Mitigation Threshold EPS: 400
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TCP SYN Flood

State

I Mitigate :

Threshold Moda
_! Fully Automatic
_' Manual Detection / Auto Mitigation

9 Fully Manual

Detection Threshold EPS

I Specify : 400

Detection Threshold Percent
I Specify : 500

Mitigation Threshold EPS

ISpecify : 500

["] simulate Auto Threshold
["] Bad Actor Detection

[”] Attacked Destination Detection

5. Click Update to save your changes.

6. Open the BIG-IP SSH session and scroll the Itm log in real time with the following command: tail
-f /var/log/ltm

7. On the attack host, launch the attack by issuing the following command on the BASH prompt:

sudo hping3 10.20.0.10 --flood —--rand-source --destport 80 --syn -d 120 -w
64

8. After about 60 seconds, stop the flood attack by pressing CTRL + C.

9. Return to the BIG-IP web Ul and navigate to Security > Event Logs > DoS > Network > Events.
Observe the log entries showing the details surrounding the attack detection and mitigation.

10. Navigate to Security > Reporting > DoS > Dashboard to view an overview of the DoS attacks and
timeline. You can select filters in the filter pane to highlight the specific attack.

11. Finally, navigate to Security > Reporting > DoS > Analysis. View detailed statistics around the
attack.

Preventing Global DoS Sweep and Flood Attacks

In the last section, the focus was on attacks originating from various hosts. In this section, we will focus on
mitigating flood and sweep attacks from a single host.

Single Endpoint Sweep
The single endpoint sweep is an attempt for an attacker to send traffic across a range of ports on the target
server, typically to scan for open ports.

1. In the BIG-IP web Ul, navigate to Security > DoS Protection > Device Configuration > Network
Security.

2. Expand the Single-Endpoint category in the vectors list.
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3. Click on Single Endpoint Sweep vector name.
4. Configure the vector with the following parameters:
+ State: Mitigate
» Threshold Mode: Fully Manual
» Detection Threshold EPS: 150
+ Mitigation Threshold EPS: 200
» Add Source Address to Category: Checked
» Category Name: denial_of_service
+ Sustained Attack Detection Time: 10 seconds
+ Category Duration Time: 60 seconds

» Packet Type: Move All IPv4 to Selected

single Endpoint Sweep

State

I Mitigate :

Threshold Mode

@ Fully Manual

Detection Threshold EPS
[ specity [« | 150 |

Mitigation Threshold EPS
| Specify [ | 200 |

[¥] Add Source Address to Category

Category Mame | denial_of_sermice |E|

Sustained Attack Detaction Time

| 10 |seconds
Category Duration Time
| 60 |seconds

[T sllow External Advertisement

Packet Type
Selected Available
All P4 - All IPvE

Any ICMP (IPvd)

Any ICMP (IPvE)

Any Other IPv4 Protocol
Any Other IPvE Protocol
Atomic Fragment

== |Bad Packet

DMS A Query

| DNS AAAA Query

~| DNS ANY Quuery

DMS AXFR Query

DS CHNAME Query
DMS IXFR Query

DMS MX Query

e DMNS NS Query
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5. Click Update to save your changes.

6. Navigate to Security > Network Firewall > IP Intelligence > Policies.

7. In the Global Policy section, change the IP Intelligence Policy to ip-intelligence.

Global Policy

IP Intelligence Palicy |ip—inte|ligence |Z|

Description |

Update

8. Click Update.

. Click on the ip-intelligence policy in the policy list below.

. Create a new Blacklist Matching Policy in the IP Intelligence Policy Properties section with the following

attributes, leaving unspecified attributes with their default values:
+ Blacklist Category: denial-of-service
 Action: drop
 Log Blacklist Category Matches: Yes

11. Click Add to add the new Blacklist Matching Policy.
General Properties
Name ip-intelligence
Partition / Path Comman
Description
IP Intelligence Policy Properties
Selected Availahle
ICommon
Feed Lists + Glabal
IP Reputation
Default Action Drop ¥
) Log Whitelist Overrides Mo v
Default Log Actions
Log Blacklist Category hatches | Na v
Blacklist Categary denial_of_service v
Action Drop v
Log Blacklist Category Matches | Yas A
Log Whitelist Overrides Use Policy Default ¥
Match Override Match Source v
Add| Replace
Blacklist hatching Policy Blacklist Category Action Log Blacklist Category Matches Loy Whitelist Overrides Match Override
denial_of_serice Drop Yes Use Policy Default Match Source
Delete
12. Click Update to save changes to the ip-intelligence policy.
13. Open the BIG-IP SSH session and scroll the Itm log in real time with the following command: tail
-f /var/log/ltm
14. On the victim server, start a packet capture with an SSH filter by issuing sudo tcpdump -nn not port
22
15. On the attack host, launch the attack by issuing the following command on the BASH prompt:
sudo hping3 10.20.0.10 --flood --scan 1-65535 -d 128 -w 64 --syn
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16.

17.

18.

19.

20.

21.

22.

23.

24.

You will see the scan find a few open ports on the server, and the server will show the inbound sweep
traffic. However, you will notice that the traffic to the server stops after a short time (10 seconds, the
configured sustained attack detection time.) Leave the test running.

After approximately 60 seconds, sweep traffic will return to the host. This is because the IP Intelligence
categorization of the attack host has expired. After 10 seconds of traffic, the bad actor is again
blacklisted for another 60 seconds.

Stop the sweep attack on the attack host by pressing CTRL + C.

Return to the BIG-IP web Ul and navigate to Security > Event Logs > DoS > Network > Events.
Observe the log entries showing the details surrounding the attack detection and mitigation.

Navigate to Security > Event Logs > Network > IP Intelligence. Observe the log entries showing
the mitigation of the sweep attack via the ip-intelligence policy.

Navigate to Security > Event Logs > Network > Shun. Observe the log entries showing the blacklist
adds and deletes.

Navigate to Security > Reporting > Network > IP Intelligence. Observe the statistics showing the
sweep attack and mitigation. Change the View By drop-down to view the varying statistics.

Navigate to Security > Reporting > DoS > Dashboard to view an overview of the DoS attacks and
timeline. You can select filters in the filter pane to highlight the specific attack.

Finally, navigate to Security > Reporting > DoS > Analysis. View detailed statistics around the
attack.

Single Endpoint Flood

The single endpoint flood attack is an attempt for an attacker to send a flood of traffic to a host in hopes of
overwhelming a service to a point of failure. In this example, we'll flood the target server with ICMP packets.

1.

In the BIG-IP web Ul, navigate to Security > DoS Protection > Device Configuration > Network
Security.

Expand the Single-Endpoint category in the vectors list.
Click on Single Endpoint Flood vector name.
Configure the vector with the following parameters:

+ State: Mitigate

» Threshold Mode: Fully Manual

 Detection Threshold EPS: 150

+ Mitigation Threshold EPS: 200

» Add Destination Address to Category: Checked

» Category Name: denial_of_service

+ Sustained Attack Detection Time: 10 seconds

» Category Duration Time: 60 seconds

» Packet Type: Move Any ICMP (IPv4) to Selected
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Single Endpoint Flood

State

I Mitigate :

Threshold Mode

@ Fully Manual
Detection Threshold EPS
['Specity [+ ][ 150
Mitigation Threshold EPS

ISpecify : 200

[¥] 1dd Destination Address to Category

Category Name|denia|_0f_ser\fice Iz‘

Sustained Attack Detection Time
10 seconds

Category Duration Time
60 seconds

[Z] Allow External Advertisement

Packet Type
Selected Available
Any ICMP (IPvd) e All 1Pvd
All IPvE
Any ICMP (IPvE)

Any Other IPvd Protocol
Any Other IPvE Protocol
Atomic Fragment

=» | Bad Packet

DMNS A Query

== | DNS AAAA Query

DMS ANY Query

DMS AXFR Query

DNS CNAME Query
DNS IXFR Query

DMNS MX Query

- DMNS NS Query

5. Click Update to save your changes.

10.

11.
12.

13.

. Open the BIG-IP SSH session and scroll the Itm log in real time with the following command: tail

-f /var/log/ltm

. We'll run a packet capture on the victim server to gauge the incoming traffic. On the victim server,

issue the following command: sudo tcpdump -nn not port 22

. On the attack host, launch the attack by issuing the following command on the BASH prompt:

sudo hping3 10.20.0.10 --faster -c 25000 —--icmp

. The attack host will begin flooding the victim server with ICMP packets. However, you will notice that

the traffic to the server stops after a short time (10 seconds, the configured sustained attack detection
time.)

After approximately 60 seconds, run the attack again. ICMP traffic will return to the host. This is
because the IP Intelligence categorization of the attack host has expired.

Return to the BIG-IP web UI.

Navigate to Security > Event Logs > DoS > Network > Events. Observe the log entries showing
the details surrounding the attack detection and mitigation.

Navigate to Security > Event Logs > Network > IP Intelligence. Observe the log entries showing
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the mitigation of the sweep attack via the ip-intelligence policy.

14. Navigate to Security > Reporting > Network > IP Intelligence. Observe the statistics showing the
sweep attack and mitigation.

15. Navigate to Security > Reporting > DoS > Dashboard to view an overview of the DoS attacks and
timeline. You can select filters in the filter pane to highlight the specific attack.

16. Finally, navigate to Security > Reporting > DoS > Analysis. View detailed statistics around the
attack.

This concludes the DoS/DDoS portion of the lab. You have successfully defeated Joanna, she has de-
cided a career at Chotchkie’s is more prosperous than nefarious internet activities, even with the new flair
requirements. Well done!

Written for TMOS 13.1.0.1/BIG-1Q 6.0

Y

« IT agility. Your way.

1.5 Lab 4 - Device Management Workflows

1.5.1 Lab Overview

Day 3, you get a little curious and wonder why both BIG-IP’s you’ve been working on say they’re managed
by BIG-IQ (look near the red f5 ball on the top left of both BIG-IP’s). Unbelievable, all this time you've
been configuring both devices independently when you could have been configuring them on a central
management device.

Central Management Version - 6.0 was a major evolution of the BIG-1Q product line designed to become the
primary source of centralized management for all physical and virtual F5 BIG-IP devices. BIG-IQ extends
its offerings for security users, improving the user experience, and adding robustness and scale throughout
the platform.

1.5.2 Base BIG-IQ Configuration

In this lab, the VE has been configured with the basic system settings and the VLAN/self-IP configurations
required for the BIG-1Q to communicate and pass traffic on the network. Additionally, the Data Collection
Device has already been added to BIG-1Q and the BIG-IP’s have been imported and have been gathering
health statistics. They have not however had their configurations imported.

1.5.3 New features

Statistics Dashboards

This is the real first step managing data statistics using a DCD (data collection device) evolving toward a
true analytics platform. In this guide, we will explore setting up and establishing connectivity using master
key to each DCD (data collection device).
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+ Enabling statistics for each functional area as part of the discovery process. This will allow BIG-IQ to
proxy statistics gathered and organized from each BIG-IP device leveraging F5 Analytics iApp service
(https://devcentral.f5.com/codeshare/f5-analytics-iapp).

 Configuration and tuning of statistic collections post discovery allowing the user to focus on data
specific to their needs.

 Viewing and interaction with statistics dashboard, such as filtering views, differing time spans, selec-
tion and drilldown into dashboards for granular data trends and setting a refresh interval for collections.

Auto-scaling in a VMware cloud environment

You can now securely manage traffic to applications in a VMware cloud environment, specifying the pa-
rameters in a service scaling group to dynamically deploy and delete BIG-IP devices as needed. BIG-IQ
manages the BIG-IP devices that are load balancing to the BIG-IP VE devices in the cloud, as well as to
the BIG-IP devices’ application servers.

Auto-scaling in an AWS environment

You can now securely manage traffic to applications in a VMware cloud environment, specifying the pa-
rameters in a service scaling group to dynamically deploy and delete BIG-IP devices as needed. You can
manage the BIG-IP VE devices from a BIG-IQ system on-premises, or in the cloud. You have the option to
use an F5 AWS Marketplace license, or your own BIG-IP license.

BIG-IQ VE deployment in MS Azure
You can now deploy a BIG-1Q VE in a MS Azure cloud environment.
Intuitive visibility for all managed applications

BIG-1Q now provides an overview of all managed applications with the option for a more detailed view of
each application. Both the overview and detailed views provide information about the application’s perfor-
mance, Web Application Security status, and network statistics.

Easy application troubleshooting based on application traffic and security data

You can now enable enhanced analytics to view detailed application data in real-time, which allows you to
isolate traffic characteristics that are affecting your application’s performance and security status.

Real-time notifications for monitored devices and applications

You can now receive real time alerts and events for BIG-IP devices and their connected applications. These
notifications are integrated into the BIG-IQ Ul charts and allow you to pinpoint activities that are currently
affecting your application.

Enhanced HTTP and Web Application Security visibility for all applications

You can use the HTTP and Web Application Security Dashboards to monitor all applications managed by
BIG-1Q Centralized Management. These dashboards allow you to compare applications, pool members,
and other aspects of traffic to your applications. In addition, the enhanced view includes real time events
and alerts within the charts, and enhanced analytics data.

Added object and management support for DNS features

Creating, reading, updating, and deleting DNS GSLB objects, and listeners is now supported from the
BIG-1Q user interface and the API.

Visibility into managed service scaling groups

An automatically scalable environment of BIG-IP VE devices can be defined to provide services to a set of
applications. System administrators of BIG-1Q Centralized Management can monitor performance data for
these BIG-IP VE devices.

Enhanced DNS visibility & configuration
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BIG-1Q provides the ability to configure and have an enhanced view into DNS traffic, which now includes
both peak traffic values and average traffic values over a selected period of time.

Application templates
Enhanced application/service templates that make deployments simple and repeatable.
Security policies and profiles available in applications

You can now add security policies and profiles to applications, including Web Application Security policies,
Network Security firewall policies, DoS profiles, and logging profiles.

Automatically deploy policy learning
You can now enable automatic deployment of policy learning using Web Application Security.
Extended ASM/advanced WAF management that includes
+ Auto-deploy policy learning
* Brute-force attack event monitoring
 Event correlation
» Manage DataSafe profiles
Initial ASM and HTTP monitoring dashboards
Enhanced AFM Management

» AFM and DoS event visualization
» Multi device packet tester
» Enhanced debugging
APM enhancements
» Management capabilities for APM Federation through BIG-1Q (SAML, IdP and SP)

* Management capabilities for APM SSO configuration for Web Proxy Authentication Support Through
BIG-IQ

Manage cookie protection

You can now manage cookie protection for BIG-IP devices using Web Application Security.
Monitoring dashboard for Web Application Security statistics

You can review Web Application Security policy statistics using a graphical dashboard.
Manage DataSafe profiles

You can now manage DataSafe profiles using Fraud Protection Security.

Enhanced support for NAT firewalls

You can now use the enhanced NAT firewall support in Network Security.

Subscriber support in firewall rules

You can now add subscriber IDs and groups to firewall rules in Network Security for BIG-IP devices that
support them.

Firewall testing using packet flow reports
You can now create and view packet flow reports to test firewall configurations in Network Security.

Support for multiple BIG-IP devices with packet tester reports
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You can now select multiple BIG-IP devices when generating packet tester reports in Network Security.
Renaming of firewall objects supported

You can now rename firewall objects, such as firewall policies in Network Security.

Enhanced support for DoS profiles, device DoS configurations, and scrubber profiles

You can now manage additional features of DoS profiles, device DoS configurations, and scrubber pro-
files that are found in BIG-IP version 13.1, such as new vectors, stress-based mitigation, DNS dynamic
signatures, and VLAN support in scrubber profiles.

Copying device DoS configurations

You can now copy device DoS configurations from one BIG-IP device to multiple BIG-IP devices with the
same version.

Viewing logs for DoS and firewall events in the user interface

You can now configure and view logging of DoS and firewall events, and for DoS events, see that information
in a graphical format.

Additional details can be found in the full release notes:

https://support.f5.com/kb/en-us/products/big-ig-centralized-mgmt/releasenotes/product/
relnote-big-ig-central-mgmt-6-0-0.html

BIG-IP Versions AskF5 SOL with this info:
https://support.f5.com/kb/en-us/solutions/public/14000/500/s0l14592.html

1.5.4 Changes to BIG-IQ User Interface

The user interface in the 6.0 release navigation has changed to a more Ul tab-based framework.

In this section, we will go through the main features of the user interface. Feel free to log into the BIG-1Q
(https://192.168.1.50) username: admin password: 401elliottW! device to explore some of these features in
the lab.

After you log into BIG-1Q, you will notice:
A navigation tab model at the top of the screen to display each high level functional area.

» Atree based menu on the left-hand side of the screen to display low-level functional area for each tab.

* A large object browsing and editing area on the right-hand side of the screen.

bigiqu1-de local Jul 06, 2018 10:58:181ED. ort tasks BIGIP121.0.1 Bulld 0.0.8 Poin Release 1

bigip2 anstestiab 1921681150 Enadles bigiqu1-dedlocal Jul 06, 2018 10:57 S ED.

 Let us look a little deeper at the different options available in the bar at the top of the page.
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<
Device Health
ALERTS & NOTIFICATIONS

» AUDITLOGS
Lasthourv  Friday Jul 6, 09:59:08 - 10:59:08 30 sec. v 2 Refresh Events
v DASHBOARDS. -

— os0 ost0 0020 0030 050 oasn [ijooo 1o 1020 1030 o0

CPU Usage (percent)

® User Systerm 100 Wait ® stolen

User Surmary

a
» Logging Messages (AI) »
Remote Logging Configuration
o
» SecureWeb Gatemay

o
~ Device 1000 1005 10:10 10:15 10:20 1025 030 1035 1090

Top 6 CPU Cores (Percent)
Traffic

» ons @ bigipt dnstestlab bigip1 dnstestab bigip1 dnstestlab, ® bigip dnstestlab bigip dnstestiab ® bigip2.dnstest lab

> Local Traffc

72PN A-E NN P = ~
Soo0 100 o0 1ous 1020 1028 1020 1025 o0 1o

+ At the top, each tab describes a high-level functional area for BIG-1Q central management:
» Monitoring —Visibility in dashboard format to monitor performance and isolate fault area.

» Configuration — Provides configuration editors for each module area.

« Deployment — Provides operational functions around deployment for each module area.

» Devices — Lifecycle management around discovery, licensing and software install / upgrade.
+ System — Management and monitoring of BIG-1Q functionality.

 Applications — Build, deploy, monitor service catalog-based applications centrally.

1.5.5 Workflow 1: Creating a Backup Schedule

BIG-IQ is capable of centrally backing up and restoring all the BIG-IP devices it manages. To create a
simple backup schedule, follow the following steps.

1. Click on the Back Up & Restore submenu in the Devices header.

2. Expand the Back Up and Restore menu item found on the left and click on Backup Schedules
<

¥ BACK UP & RESTORE

Backup Schedules @

Backup Files

3. Click the Create button
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Backup Schedules

Back Up Maowy Create

Status Marne

4. Fill out the Backup Schedule using the following settings:
* Name: Nightly
» Local Retention Policy: Delete local backup copy 1 day after creation
+ Backup Frequency: Daily
+ Start Time: 00:00 Eastern Daylight Time
» Devices: Groups (radio button): All BIG-IP Group Devices

Your screen should look similar to the one below.

& .../ New Backup Schedule *

+Backup Properties

Backup Frequency Daily
Start Date Ju106,2018 B Start time: 0 0 Eastern Daylight Time
@ Noend date

Endon JUl06, 2018 @

bigip2dnstest ab 192168.1.150
bigipT.dnstestlab 1521681100

5. Click Save & Close to save the scheduled backup job.

6. Optionally feel free to select the newly created schedule and select “Run Schedule Now” to immedi-
ately backup the devices.

» Add a Name for the Back Up
* Click Start

* When completed the backups will be listed under the Backup Files section

1.5.6 Workflow 2: Uploading QKviews to iHealth for a support case

BIG-1Q can now push gkviews from managed devices to ihealth.f5.com and provide a link to the report
of heuristic hits based on the gkview. These gkview uploads can be performed ad-hoc or as part of a
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F5 support case. If a support case is specified in the upload job, the gkview(s) will automatically be as-
sociated/linked to the support case. In addition to the link to the report, the gkview data is accessible at
ihealth.f5.com to take advantage of other iHealth features like the upgrade advisor.

1. Navigate to Monitoring Reports Device iHealth Configuration
I Monitaring I Configuration I Deployment I Devices I System _

Configuration
ALERTS & MOTIFICATIOMS

b AUDITLOGS
Properties
» DASHECARDS
v REFORTS CkNiew Transfer Limit 2 max simultaneous QkView file transfers Edit
¥ Diewi .
St Credentials
¥ iHealth
. ) Add Delete
Configuration
Uplaads Marme Username Description
Reparts

2. Add Credentials to be used for the gkview upload and report retrieval. Click the Add button under
Credentials.

Credentials

Add Delete

W

Warning: If you do not have credentials, please raise your hand and speak to an instructor

3. Fill in the credentials that you used to access hitps://ihealth.f5.com:
» Name: Give the credentials a name to be referenced in BIG-IQ
» Username: <Username you use to access iHealth.f5.com>

» Password: <Password you use to access iHealth.f5.com>

&« .../ AddiHealth Credential *

Credential Properties

Marme Fred Wittenherg
Username fwittenbergi@ms.cam
Password 00 ss=sssses

Description

Connection Test Test
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4. Click the Test button to validate that your credentials work.
5. Click the Save & Close button in the lower right.
6. Click the QKview Upload Schedules button in the BIG-IP iHealth menu.
Monitoring > Reports > Device > iHealth > QKView Upload Schedule
7. Click Create with the following values
* Name — Weekly Upload
+ Description — Nightly QKView Upload
» Credential — (use what was created in step 3)
» Upload Frequecny — Weekly (Select Sunday)
« Start Time — Select todays date at 00:00
» End Date — No End date should be checked
+ Select both devices
+ Click the right arrow to move to the “Selected” Area
* Click Save & Close.

€ ... Weekly Upload
Properties
Mame Weekly Upload
Description
Credential Fred ittenberg v

Status @ Scheduled

Upload Schedule
Upload Frequency Weekly ¥ @ Sunday  Monday ( Tuesday | Wednesday «  Thursday | Friday ( Saturday
Start Date Jul 06,2018 B Starttime: 00 v .00 M
End Date Jul 06, 201% g ¥ NoEnd Date

Devices

lterns: 2

Device Last Report

higipt.dnstestlab

bigipz.dnstest.lab

You will now have a fresh set of QKView in iHealth every Sunday morning. This is extremely useful for when
new cases are opened, one less step you'll need for support to engage quicker.

1.5.7 Workflow 3: Device Import

BIG-IQ is capable of centrally managing multiple products, for this lab we will only manage LTM and AFM.
To import the device configurations, follow the steps below

1. Navigate to the Devices tab and click on BIG-IP Devices (left panel)
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<

BIG-IP Devices

BIG-IP DEVICES

» BIG-IP CLUSTERS
All BIG-IP Devices v

DEVICE GROURS

Add Device || Export Inventory Remove Device | | Remove All Services Hore v ltems: 2
¥ BACK UP & RESTORE
Staws  Device Name = 1P Address Cluster Display Name  Stats Collection Status  Data Collection Device  Stats Last Collection Date Services
Backup Schedules
Backup Flles . bigip! .dnstest.lah 192.168.1.100 Enabled bigig01-dcd.lacal Jul 06, 2018 15:05:1 SIED. Complete import tasks
et Enpreliey . bigipz.anstestlah 192.168.1.150 Enabled bigiq01-ded.lacal Jul 06, 2018 15:05:1 AED. Complete impart tasks

2. You'll notice both devices have not completed the import tasks, to remedy this simply click on the
“Complete Import Tasks” Link

First Re-discover the LTM service
Then Discover the AFM service

Once Re-discovery has completed, import both the LTM and AFM services

o o bk~ w

Repeat this same procedure for both devices, once completed your screen will show the following.

Note: For any conflicts you may encounter — leave BIG-1Q selected resolution

BIG-IP Devices

All BIG-IP Devices v

Add Device Export Inventory Remove Device Remove All Services More v Items: 2
Status Device Name ~ IP Address Cluster Display Name Stats Collection Status Data Colledion Device Stats Last Collection Date Services
L bigipt dnstestlab 1921681100 Enabled bigiqo1-ded local Jul 08, 2018 15:13:3%ED...  WManagement, LT, AFR1
L] higipZ.dnstest.lab 192.168.1.150 Enabled higig01-ded local Jul 06, 2018 15:14:04ED... Management, LTH, AFM

1.5.8 BIG-IQ Statistics Dashboards

Workflow 1: Reviewing the data in the dashboards

Navigate to Monitoring Dashboards Device Health

Device Health

Last hourv  Friday Jul 6, 14:00:26 - 15:00:26 a0 sec. v 2 Refresh Events

0 1510 1520 1530 1540 1550 Ao 1o 1420 1430 1w a0 15
e

= BIG-IP Host Names v
CPU Usage (percent) -

® User Systerm 110 Wit @ Stolen

= BIG-IP Blades v
2
= BIG-IP CPU Cores v
w \ S > ~ > ~ - ~ S ~ 2 ~
o = Interface Names v/
Top 6 CPU Cores (Percent) - = Partitions v
® bigip1.dnstestlab. bigip2.dnstest lab. bigipt.dnstest lab. ® bigipT.dnstestlab. bigipt.dnstest lab. ® bigip2 dnstest |ab.
w
\
AAN— - -
o

1.5.9 Workflow 2: Interacting with the data in the dashboards

* You can narrow the scope of what is graphed by selecting a object or objects from the selection
panels on the right. For example, if you only want to see data from BIG-IP01, you can click on it to
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filter the data.
= BIG-IP Host Names ~ 710G

CPL
- Total Usage

bigip1.dnstest. lab 8.16

* You can create complex filters by making additional selections in other panels

* You can zoom in on a time, by selecting a section of a graph or moving the slider at the top of the
page

® User @ System %:ID Wait

Apr01 2017, 05:59:06 Apr01 2017, 06:07:24

5 05:56 0557 05:53 05:59 0600 06:01 05:02 06:03 05:04 0G:05 06:05 0507 06:03 0509 0f

or
30 sec. w i Refresh

(5240 {hjm 05:50 I

« All the graphs update to the selected time.

* You can change how far in the data you want to look back by using the selection in the upper left
(note you may need to let some time elapse before this option becomes available)
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Device Health

Last 30 minutE{b Friday
Last hour G
Last 3 hours

Last 6 hours

Last 12 hours

All

Written for TMOS 13.1.0.1/BIG-IQ 6.0

ig*’ IT agility. Your way.

1.6 Lab 5 - Network Security (AFM) Management Workflows

1.6.1 Network Security (AFM) Management Workflows

Workflow 1: Managing AFM from BIG-IQ

Day 4, it turns out no one thought about managing the new web and application servers, as such SSH is
blocked to both devices. Let’s first validate this by using the packet tester tool within BIG-1Q, note this is
the same tool within BIG-IP with one major exception. Within BIG-IQ you can trace a packet through more
than one firewall. This is very useful if you have multiple AFM devices in a packets path, now you can test
the flow end to end from one central location.

Task 1 — Packet Tracer

1. Navigate to Monitoring > Reports > Security > Network Security > Packet Traces
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f5 BIG-IQ

Monitoring

Packet Traces
ALERTS & MOTIFICATIONS

» AUDITLOGS Credte Campare Clone Delete

» DASHEOARDS
[ & Mame=

¥ REPORTS
F Device
¥ Security
¥ Metwork Security
Active Firewall Policies
Firewsall Rule Reports
Reporting
Rule Statistics

Compilation Statistics

Packet Traces

2. Click on the “Create” button from the top menu.
3. Complete the following information

* Name — ssh_trace

* Protocol — tcp

» TCP Flags — Syn

+ Source IP Address — 10.20.0.200

» Source Port — 9999

* Destination IP Address — 10.30.0.50

+ Destination Port — 22

» Use Staged Policy — No

« Trigger Log — No

4. Under the Devices section click “Add” (notice you’ll see all the devices with AFM provision listed), for
our lab however; just add bigip2.dnstest.lab
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Devices
Available Selected
Iterms: 1 Selected 1 of 1
Mame Address Group Mame &  Mame Address Group Mame
bigip1l.dnstest.lab  192.168.1.100 Firewall Group ¥ bigip2.dnstest.lab 192.168.1.150  Firewall Graup

Add Cancel

5. Select the “/Common/OUTSIDE” Vlan as the Source VLAN from the dropdown.

When completed your screen should look like the screen shot below:

Facket Parameters
Mame
Protocol
TCPFlags
Source |P Address
Source Port
TTL
Destination IP Address
Destination Port
Use Staged Policy

Trigger Log

Devices

Add Celete

Device

higip2.dnstest.lab

6. Click “Run Trace”

ssh_trace
tep v
1 5T ACK R&T URG PUSH FIr
10.20.0.200
Q999
2535
10.30.0.50
22
Yes @ MNo
‘fes @ Mo
Source VLAMN
FfCommonfOUTSIDE * [+ #| Apply these WLAMS 10 all Devices.

You can see from the trace results; the traffic is indeed being denied
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» Packet Parameters

» Devices

Trace Results

Device Mame: bigip2 dnstest lab Source VLAN: /Common/OUTSIDE

Device IF Intelligence Device Dos Device Rules Route Domain P Intelligence  Route Domain Rules Virtual Server IP Intelligence  Virtual Server Dos irtual server Rules
NAT (Network Addry’ Translation)

Route Domain Rules
Result

Palicy Mame

Falicy type

Folicy Staged

Rule Mame

Reject
iComman/rd_0_policy
Enfarced

o

rejent 102000

Device Default

Another nice feature of Packet Trace within BIG-IQ is the ability to clone a trace, when you complete the
next two tasks, we’ll return to the packet tracer tool to re-run the results using the clone option. Additionally,
the traces are saved and can be reviewed later, this can be very helpful in long troubleshooting situations
where application teams are asking for results after changes are made to policies.

Follow the steps below to allow SSH access to both devices using BIG-1Q as a central management tool.

Task 2 — Modify Rule Lists

1. Navigate to the Configuration > Security > Network Security > Rule Lists

. Click on the “application_rule_list”
. Click Create Rule button.

(o206 B - N VS B \V

. Notice the previously created rule lists have been imported into BIG-1Q

. Click on the pencil (edit rule) of the newly created rule listed with Id of 2.

. Create a new rule with the below information. Be prepared to scroll to find all the options

Name allow_ssh

Source Address 10.20.0.200
Source Port any

Source VLAN any

Destination Address | 10.30.0.50
Destination Port 22

Action Accept-Decisively
Protocol TCP

State enabled

Log True (checked)

7. Click Save & Close when finished.

8. Repeat the same procedure for the web_rule_list, be sure to change the destination to 10.30.0.50, all

other setting remains the same.

1.6. Lab 5 - Network Security (AFM) Management Workflows
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Task 3 — Deploy the Firewall Policy and related configuration objects

Now that the desired firewall configuration has been created on the BIG-IQ, you need to deploy it to the
BIG-IP. In this task, you create the deployment, verify it, and deploy it.

1. From the top navigation bar, click on Deployment (tab).
2. Click on the EVALUATE & DEPLOY section on the left to expand it.
3. Click on Network Security in the expansion.

Monitoring I Configuration I Deployment I Devices I System I

Evaluate and Deploy - Network Security
¥ DEPLOYMEMNT TRACKIMNG

Access

Evaluations
DME
Fraud Protection Create Deploy Cancel Delete
Local Traffic & Metwwork Mame Devices

Metwork Security

Web Application Security
¥ EVALUATE & DEPLOY

ALCCESS

CHS

Fraud Protection

Local Traffic & Metwork

Metwark Security

Wieh Application Security

Click on the top Create button under the Evaluations section.

Give your evaluation a name (ex: deploy_afm1).

Evaluation Source should be Current Changes (default).

Source Scope should be All Changes (default)

Remove Unused Objects should be Remove Unused Objects (default)

Target Device(s) should be Device.

© © ® N o o &

Select bigip2.dnstest.lab from the list of Available devices and move it to Selected area.
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11.

12.

13.

14,

15.

16.

< ../ New Evaluation - Network Security

General
Narme deploy_afm1
Description
Evaluation
Source ® Current Changes () Existing Snapshot
Source Scope ® AllChanges ) Partial Changes
Unused Objeds ® Remove Unused Objects () Keep Unused Objedts
Target Devicels)
Available Selected
hems: 1 Selected 1 of 1
Hame Address @ MName Address

bigipt.dnstest1ab 192.168.1.100 = 4 bigp2dnstestiab 1921681150

=

Click the Create button at the bottom right of the page.
You should be redirected to the main Evaluate and Deploy page.

This will start the evaluation process in which BIG-IQ compares its working configuration to the con-
figuration active on each BIG-IP. This can take a few moments to complete.

The Status section should be dynamically updating. .. (What states do you see?)

Once the status shows Evaluation Complete you can view the evaluation results.

Note: Before selecting to deploy, feel free to select the differences indicated to see the proposed
deployment changes. This is your check before making changes on a BIG-IP.

Click the number listed under Differences — Firewall.

Scroll through the list of changes to be deployed.

Click on a few to review in more detail.

What differences do you see from the Deployed on BIG-IP section and on BIG-1Q?
Do you see the new rules you created in BIG-IQ? Ya should. ..

Click Cancel.

Deploy your changes by checking the box next to your evaluation deploy_afm1.
With the box checked, click the Deploy button.

Your evaluation should move to the Deployments section.

After deploying, the status should change to Deployment Complete.

» This will take a moment to complete. Once completed, log in to the BIG-IP and verify that the
changes have been deployed to the AFM configuration.

Congratulations, you just deployed your first AFM policy via BIG-1Q!

Review the configuration deployed to the BIG-IP units.
On bigip2.dnstest.lab: (hitps://192.168.1.150)

1.
2.

Navigate to Security > Network Firewall > Policies.
Click on rd_0_policy and expand the rule lists

Are the two rules you created in BIG-1Q listed for this newly deployed firewall policy?
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|\D ‘ ‘Name State Protacol Source Destination Astions Logging
1 B application_rule_list Enabled Any
allow_htia Enabled TR Any Addresses Accent-Decishvely Yes
10.40.0.50
Forts
60
allow_ssh Enabled TP Addresses Addresses Accept-Decishiely Yes
10200200 10.40.0.50
Forts.
2
2 B web_rule_list Enabled Any
allow_htia Enabled TP Any fddresses Accept-Decishvely Yes
10.300.50
Forts
60
allow_ssh Enabled TP ddrasses Addresses AcceptDecisively ves
10.20.0.200 10.30.0.50
Forts
2
3 reject 10,20 0 0 Enabled Any Addresses any Reject Yes
102000124

HNetwork :+ Route Domains :: 0

1+ + | Properies Security
I

Policy Settings: | Basic v

Route Domain 1D 0

WLAMNS external, hitp-tunnel, internal, socks-tunnel

etwork ol Enforcament | Enabled... ¥ |Policy:| Poliey_Farward [+]
Staging: Disabled ¥

MNetwork Address Translation Mone ¥

IF Intelligence Maone v

Sermvice Policy ﬂ

Update

Test Access:
1. Open a new Web browser and access http://10.30.0.50
2. Open Putty and access 10.30.0.50

Task 4 — Packet Tracer (continued)

#. Navigate to the Monitoring tab Reports Security Network Security Packet Tracers

1. Highlight the previous trace (ssh_trace) and click on the “Clone” button

Packet Traces

Create Compare Clane Delete Selected 1 of 1
¥ @ Name~ Devices Date Created v Status Protocol Source IP Source Port DestIP Dest Port
| ssh_trace bigip2 dnstest.lab Jul 09, 2018 04:50:54(EDT) FINISHED tep 10.20.0.200 9999 1030050 22

You'll notice all the previously entered values are pre-populated, you now can make any changes if
necessary (maybe the application team realized the source port of the flow is not random).

2. Click “Run Trace”
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» Packet Parameters

» Devices

Trace Results

Device Name: bigip2 dnstestlab  Source VLAN: /Common/OUTSIDE

Device IP Intelligence Device Dos Device Rules

SUCCESS!

Route Domain IP Intelligence  Route Damain Rules Wirtual Server P Intelligence Wirtual Server Do Virtual Server Rules Device Default

NAT(Network Addry " renslatian)

Route Domain Rules

Result Deisive Alloi
Policy Marme fcommonird_0policy

Policy type Enforced

Policy Staged No

Rule Name FCommon/web_rule_list allow_ssh
Route Damain Name fCampmon/0

Source FQDN unknown

Source Ges Location No-lookup

Source User D

Sourte User Group

Destination FQDN unknown
Destination Geo Lacation e lokup
Redirected Virtual None

Log Config Enatied

The history within the tool makes Root Cause Analysis (RCA) reports very easy, this allows the security
team to show a denied flow and subsequent permitted flow.

1.6.2 Workflow 2: Configure Network Security and DoS Event Logging

Task 1 — Configure Network Security an

d DoS Event Logging

You enable Network Security event logging using the virtual servers displayed in the context list

1. Navigate to the Configuration Security Network Security Contexts
2. Check the box next to the IPV4_TCP VIP
3. Select “Configure Logging” from the top buttons

Contexts
Deploy Configure Logging Disable Logging

& Name= Partition

0 Common

0 Cammon
APP-10.40.0.150 Cammon
DMZ-10.30.0.150 Comman

Zlobal Common

Zlobal Common
inside-10.10.0.11 Cammon

1P _AMY Common

< IPv4_TCP Common

Selected 1 of 19

Firewall Type IP Address Device Enforced Policy
route-domain higip1.dnstest.lab

route-domain higip2.dnstest.lab Commondrd_0_policy
self-ip 10.40.0.150/24 bigipz dnstest lab

self-ip 10.30.0.150/24 bigipZ.dnstest.lab

global higip2. dnstest.lab Cornmaon/Global
global bigip1.dnstest.lab

self-ip 1090011724 bigipT.dnstest.lab

vip 0.0.0.0:0 bigip2.dnstest.lab

vip 0.0.0.0:0 higipZ.dnstest.lab

4. You will receive a configuration message alerting you to the changes about to be made to the device,

click Continue
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hetwork Security Logging Configuration

This will create logging configuration objects needed to send Metwork Security logging events from the BIG-
IR s) associated with these Shared Security Virtual Serven si to BIG-IQ Data Collection Devices. Events
received on the DCDs can then be viewed on this BIG-1Q. These objects will be shared among these Shared
Security Wirtual Serveris) and should not be modified, because it could affect the BIG-1P's ability to send
events.

The following will be created (if needed):
COrne or more Logging Profiles

Log Publisher

Log Destination

Pool for each device

Pool Mermbers

Pool Maonitor

Continue Cancel

This will now configure a logging profile, associated pools, monitors and all necessary configuration to send
logs to the Data Collection Device (DCD).

In the spirit of central management, we’re also going to configure the DoS event logging, so we only must
perform one deployment on both devices.

1. Navigate to Configuration Security Shared Security DoS Protection Device DoS Configurations

2. Highlight bigip1.dnstest.lab and click the “Configure DoS Logging” button from the top.

Device DoS Configurations

Configure DosS Logging Disable DoS Logging Copy Selected 1 of 2
Device = Partition BIG-IP Version Last Updated
s Cornrnon 13.1.01 |ul 06, 2018 16:15:45(EDT)
Cornrnon 13.1.01 |ul 06, 2016 15:123:4HEDT)

DoS Logging Configuration

This will create logging configuration objects needed to send DoS logging events from the BIG-1R(s)
assocdiated with these Device DoS Config] s) ta BIG-1Q) Data Collection Devices. Events received on the DCDs
can then be viewed on this BIG-10. These objects will be shared among these Device DoS Configis) and
should net be modified, because it could affect the BIG-IP's ability to send events.

The following will be created iif needed):
+ One or more Logging Profiles

+ LogPublisher

* Log Destination

* Pool for each device

= Pool Members

* Poal Monitor

Cancel

3. Once again you will receive a configuration message, click continue
4. Once completed navigate to the Deployments tab
As most of the configuration is “LTM” related you will first need to deploy the LTM configuration.
5. Navigate to Evaluate & Deploy
6. Select Local Traffic & Network Traffic

7. Create an evaluation named “logging_configuration”, leave all other defaults and select both devices,
once finished, create the evaluation.

82 Chapter 1. Class 1: AFM — The Data Center Firewall



F5 Firewall Solutions Documentation

Feel free to examine the changes in the evaluation, when satisfied deploy the changes.

8. Once the LTM configuration is deployed, you'll need to also deploy the Network Security portion of the
changes.

Navigate to Deployment Evaluate & Deploy Network Security.

Again, create an evaluation and subsequent deployment for both devices.

Task 2 — Evaluate Network Firewall Events

1. Browse to http://10.30.0.50 once again (or refresh in your tabs).
2. Within BIG-1Q, navigate to Monitoring Network Security Firewall

3. Click on a line item for enriched information in the window below as shown

Network Security: Firewall Events

All Devices v Ssecondrefiesh v Selected 10 77 ¥ v | siter.
Time Host Context Narme Policy Type Policy Name Rule SFCSUDSCrIbe L. SFC S Src Geo SrcFQDN SrcAddress srcport SrCVLAN/Tunnel  Dest Geo Dest FQDN Dest A... Dest Port
Jul 06, 2018 16:49:46( . bigip2.dnstestlab  Virtual Server 1PV4_UDP Enforced (Default) Unknown unknown 10200.200 52778 QUTSIDE Unknown unknown 2392.. 1900

Jul 06, 2018 1649:44(. bigip2.dnstestlab  Virtual Server 1PV4_UDP. Enforced (Defaut) Unknown unknown 10.20.0.200 52778 OUTSIDE Unknown unknown 2392.. 1900

Jul 06,2018 1649:43(_. bigip2.dnstestlab  Virtual Server 1PV4_UDP. Enforced (Defaut) Unknown unknown 10200200 52778 OUTSIDE Unknown unknown 2392.. 1900

Jul 06, 2018 1649:43(_. bigip2.dnstestlab  Virtual Server 1PV4_UDP. Enforced (Defaut) Unknown unknown 10.20.0.200 52778 OUTSIDE Unknown unknown 2392.. 1900

Jul 06,2018 1649:16(. bigip2.dnstestlab  Virtual Server 1PVa_TCP. - Unknown 10200200 58249 OUTSIDE Unknown 1040... 80

Jul 06,2018 1649:12(. bigip2.dnstestlab  Virtual Server 1PVa_TCP. - Unknown 10.20.0.200 58250 OUTSIDE Unknown 1040... 80

Jul 06,2018 1649:09( . bigip2.dnstestlab  Virtual Server 1PVa_TCP - Unknown 10200200 58254 OUTSIDE Unknown 1030... 80

Jul 06, 2018 1649:05(. bigip2.dnstestlab  Virtual Server 1PVa_TCP. - Unknown 10.20.0.200 58249 OUTSIDE Unknown 1040... 80

Jul 06, 2018 1649:05(.. bigip2.dnstestlab  Virtal Server 1PVa_TCP. Enforced rd_0_policy JCommon/applicati. Unknown unknown 10.20.0.200 58249 OUTSIDE Unknown unknown 1040... 80

Jul 06,2018 1649:03( . bigip2.dnstestlab  Virtual Server 1PVa_TCP Enforced rd_0_policy JCommonsweb._rul Unknown unknown 10.20.0.200 58254 OUTSIDE Unknown unknown 1020... 80

Jul 06, 2018 1649:03(. bigip2.dnstestlab  Virtual Server 1PVa_TCP - Unknown 10.20.0.200 58254 OUTSIDE Unknown 1030... 80

1

Date: Jul 06, 2012 16:43.05(EDT) Type: Newiork Event
Context Type: Virtual Server Severity: 8

o Msg Number: 23003137
Adion: Accept dedsively

leName: /C;
stname: bigip2 dnstestlab
Host IP: 192.168.1.150
Vendor: F5

Product: Advanced Firewall Module

Ru on_rule_lstallow_hitp.
Ho:

eeeeee 13101008
LAN: OUTSIDE
Transiated VLAN: /CommoniARP
Route Domain: 0

v
v

s3oeeosgyrruny |€

Translated Rout
Flow ID: 00D156565759051a Transiated Pratacal: TCP

Feel free to view other logs to see the data presented.

Task 3 — Evaluate DoS Events

1. Open a few separate windows to the attack host. We will launch a few attacks at once to see the
value of consolidated reporting within BIG-IQ (there is a text document on the jumbox desktop which
contains all of the attack commands).

2. Launch a few attacks at once and navigate to Monitoring Events —-DoS DoS Summary
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v AllDOS AttackEvents v All Devices

DoS Attacks Summary
Last2 hours v or
i 1530 1540
5o
s
= an
e
s
a0
AtackiD  Severly Protected Object
1450982048 4 bigpt nstestlab
2320130250 4 bigpt nstestlab
1162212690 4 bigpt nstestlan
2571724973 4 bigpt nstestlab
1459982048 4 bigpt nstestian
2320130250 4 bigpt nstestlab
1162212690 4 bigpt nstestlan
2571724973 4 bigpt nstestlab

15550

Host

bigipt dnstestlab

bigipt dnstestlab

bigipt dnstestlab

bigipt dnstestlab

bigipt dnstestlab

bigipt dnstestlab

bigipt dnstestlab

bigipt dnstestlab

16100 . 16410

Top Protected Gbjects

bigip? dnstest lab

Detection Mode ~ Attack Name

Flood attack

Sweep attack

Flood attack

Sweep attack

Flood attack

Sweep attack

Flood attack

Sweep attack

Eps

16120

Incoming/Dropped

11,046/10,371 packets
86.8% dropped

15,824/13,543 packets
85.6% dropped

21,646/17,196 packets
79.4% dropped

17,509/11,894 packets
67.6% dropped

11,046/10,371 packets
86.8% dropped

15,824/13,543 packets
85.6% dropped

21,646/17,196 packets
79.4% dropped

17,509/11,894 packets
67.6% dropped

1630 1640 1650 ' 1700 1720 il

Top Attacks Attacks Mitigated
Longest Duration Highest Attack Severity

Status Start/End

Attack Ended Jul 06, 2018 17:23:S3(EDTHul 06, 2018 17:24:41(EDT)

Mitigated

Attack Ended Jul 06, 2018 17:23:S3(EDTHJul 06, 2018 17:24:14(EDT)

Mitigated

Attack Ended Jul 06, 2018 16:29:00(EDTHJul 06, 2018 16:29:36(EDT)

Mitigated (35 secs)

Attack Ended Jul 06, 2018 16:2843(EDTHJul 06, 2018 16:29:00(EDT)

Mitigated (17 secs)

Attack Ended Jul 06, 2018 17:23:5HEDTHul 06, 2018 17:24:41(EDT)

Mitigated (48 secs)

Attack Ended Jul 06, 2018 17:23:S3(EDTHJul 06, 2018 17:24:14(EDT)

Mitigated

Attack Ended Jul 06, 2018 16:29:00(EDTHJul 06, 2018 16:29:36(EDT)

Mitigated

Attack Ended Jul 06, 2018 16:2843(EDTHJul 06, 2018 16:29:00(EDT)

Mitigated

From here you have a consolidated view of all your devices and attacks.

Click on one of the attack ID’s for enriched information about the attack

< ../ DoS Attack 1459982048

Atack Type
Artack Started Date: Jul 06, 2018 17.2353EDT)
Attack Duration: 48 secs

Attack Last Updated: Jul 06, 2018 17:25:16EDT)
Attaek Ended Date: Jul 06, 2018 1724:41(EDT)

Severty. Last: 4
Type: Network DoS Event
Attack Name: Flond attack
Attack ID: 1459962048

All Devices v

Time -

Jul 06, 2018 17:24:41(EDT)
Jul 06, 2018 17:24:24(EDT)
Jul 06, 2018 17:24:22(EDT)
Jul 06, 2018 17:24:22(EDT)
Jul 08, 2018 17:24:21(EDT)
Jul 06, 2018 17:24:21(EDT)
Jul 06, 2018 17:24:19(EDT)
Jul 06, 2018 17:24:19(EDT)
Jul 06, 2018 17:24:19(EDT)

Jul 06, 2018 17:24:19(EDT)

Mind Max:d

Top Source IPs

off

Attack Event

Attack Ended
Attack Sampled
Atack Sampled
Attack Sampled
Atack Sampled
Atack Sampled
Atack Sampled
Atack sampled
Atack sampled

Attack Sampled

Wiitigation Action

Mitigation

Dos Mode: Enforced
Mitigation Has Occurred: tn
Adion: None

Source

ue

Protected Object

Cortext:  bigipl.dnstest lab
Hostname:  bigip1 dnstest lab
Host IP: 192,168,100

Flows ID: - 0000000000000000

Vengor; (T Advanced Firswal Modle, 131.01.608

Dos Source: Volumetiic, Aggregated across all SrelP's, Device Wide attack, matnzPPS

SourcelP: 1020.050

Destination

Destination IF: 10.200.10

Mitigation Reason Action

Hone
Drop
Drop
Drop
Drop
Drop
Drop
Drop
Drop

Drop

Top Destination IPs

Incoming/Drop... EPS

0/0 packets
749/699 packets
749/609 packets
749/699 packets
715/665 packets
7495609 packets
7154665 packets
715665 packets
5174467 packets

715/665 packets

Selected 1 of 36

Detedtion Thre... Mitigate to Thr... Baseline EPS

11946

Packets Dropped

10371

Baseline Laten... AttackLatency

Throughput

PackersDropped: Total:10371
Packets Received: Total 11946

T v A

This concludes the lab. You have had quite the eventful first week at Initech! You have successfully allowed
communication to a new webserver, you tuned and defended against several DoS attacks, you then con-
figured BIG-IQ for central device management and monitoring and lastly, you're now managing AFM within
BIG-1Q. | think you deserve Friday off!!

Written for TMOS 13.1.0.1/BIG-1Q 6.0
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« IT agility. Your way.

1.7 Lab 6 - iControl REST API

1.7.1 Lab 6 Overview

It's Friday, you’ve made it through week one, but its not over yet. After another meeting with the Bob’s they’ve
decided they want to explore the SecOps world and configure devices through the REST API. Before we
proceed let’s learn a little about what REST is and how to interact with the F5 API, also known as iControl.

1.7.2 About Representational State Transfer

Representational State Transfer (REST) describes an architectural style of web services where clients and
servers exchange representations of resources. The REST model defines a resource as a source of infor-
mation and defines a representation as the data that describes the state of a resource. REST web services
use the HTTP protocol to communicate between a client and a server, specifically by means of the POST,
GET, PUT, and DELETE methods to create, read, update, and delete elements or collections. In general
terms, REST queries resources for the configuration objects of a BIG-IP® system, and creates, deletes, or
modifies the representations of those configuration objects. The iControl® REST implementation follows
the REST model by:

» Using REST as a resource-based interface, and creating APl methods based on nouns.

— Employing a stateless protocol and MIME data types, as well as taking advantage of the authen-
tication mechanisms and caching built into the HTTP protocol.

 Supporting the JSON format for document encoding.

— Representing the hierarchy of resources and collections with a Uniform Resource Identifier (URI)
structure.

— Returning HTTP response codes to indicate success or failure of an operation.

* Including links in resource references to accommodate discovery.

1.7.3 About URI format

The iControl® REST API enables the management of a BIG-IP® device by using web service requests.
A principle of the REST architecture describes the identification of a resource by means of a Uniform
Resource Identifier (URI). You can specify a URI with a web service request to create, read, update, or
delete some component or module of a BIG-IP system configuration. In the context of REST architecture,
the system configuration is the representation of a resource. A URI identifies the name of a web resource;
in this case, the URI also represents the tree structure of modules and components in TMSH.

In iControl REST, the URI structure for all requests includes the string /mgmt/tm/ to identify the namespace
for traffic management. Any identifiers that follow the endpoint are resource collections.
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Tip: Use the default administrative account, admin, for requests to iControl REST. Once you are familiar
with the API, you can create user accounts for iControl REST users with various permissions.

https://management-ip/mgmt/tm/module

The URI in the previous example designates all of the TMSH subordinate modules and components in the
specified module. iControl REST refers to this entity as an organizing collection. An organizing collection
contains links to other resources. The management-ip component of the URI is the fully qualified domain
name (FQDN) or IP address of a BIG-IP device.

Important: iControl REST only supports secure access through HTTPS, so you must include credentials
with each REST call. Use the same credentials you use for the BIG-IP device manager interface.

For example, use the following URI to access all the components and subordinate modules in the LTM
module:

https://management-ip/mgmt/tm/Itm

The URI in the following example designates all of the subordinate modules and components in the specified
sub-module. iControl REST refers to this entity as a collection; a collection contains resources.

https://management-ip/mgmt/tm/module/sub-module

The URI in the following example designates the details of the specified component. The Traffic Manage-
ment Shell (TMSH) Reference documents the hierarchy of modules and components, and identifies details
of each component. iControl REST refers to this entity as a resource. A resource may contain links to
sub-collections.

https://management-ip/mgmt/tm/module/{[}sub-module{]}/component

1.7.4 About reserved ASCII characters

To accommodate the BIG-IP® configuration objects that use characters, which are not part of the unre-
served ASCII character set, use a percent sign (%) and two hexadecimal digits to represent them in a URI.
The unreserved character set consists of: [A - Z] [a - z] [0 - 9] dash (-), underscore (_), period (.), and tilde
(~)-

You must encode any characters that are not part of the unreserved character set for inclusion in a URI
scheme. For example, an IP address in a non-default route domain that contains a percent sign to indi-
cate an address in a specific route domain, such as 192.168.25.90%3, should be encoded to replace the
Y%character with %25.

1.7.5 About REST resource identifiers

A URI is the representation of a resource that consists of a protocol, an address, and a path structure
to identify a resource and optional query parameters. Because the representation of folder and partition
names in TMSH often includes a forward slash (/), URI encoding of folder and partition names must use a
different character to represent a forward slash in iControl®

To accommodate the forward slash in a resource name, iControl REST maps the forward slash to a tilde
(~) character. When a resource name includes a forward slash (/) in its name, substitute a tilde (~) for the
forward slash in the path. For example, a resource name, such as /Common/plist1, should be modified to
the format shown here:

https://management-ip/mgmt/tm/security/firewall/port-list/~Common~plist1
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1.7.6 About Postman — REST Client

Postman helps you be more efficient while working with APIs. Postman is a scratch-your-own-itch project.
The need for it arose while one of the developers was creating an API for his project. After looking around
for a number of tools, nothing felt just right. The primary features added initially were a history of sent
requests and collections. You can find Postman here - www.getpostman.com.

1.7.7 Simulating and defeating a Christmas Tree Packet Attack

Now that we understand what REST is let’s use it to defeat Joanna one last time. Joanna was feeling festive
for her final attack. In this example, we'll set the BIG-IP to detect and mitigate Joanna’s attack where all
flags on a TCP packet are set. This is commonly referred to as a Christmas tree packet and is intended to
increase processing on in-path network devices and end hosts to the target.

To interact with the REST API, we’ll be using POSTMan. We’ll then use the hping utility to send 25,000
packets to our server, with random source IPs to simulate a DDoS attack where multiple hosts are attacking
our server. We'll set the SYN, ACK, FIN, RST, URG, PUSH, Xmas and Ymas TCP flags.

1. POSTMan is installed as an application and can be accessed from the desktop of the Jumpbox

2. Once you launch POSTMan You'll then want to import the API calls for the lab as well as the environ-
ment variables

» There is a notepad on the desktop labeled “Postman Links”

« Within POSTman and click on the “Import” link near the top and then select “Import from Link”
» Copy and paste the collection link from within the notepad and select “Import”

» Copy and paste the environment link from within the notepad and select “Import”

2 Postman E=3 [EoR (=%

File Edit ‘iew Help

IMPORT

Import a Postman Collection, Environment, data dump, curl command, or a RAML /
WADL # Swaggerv1/v2}/ Runscope file.

ImportFile  Import Folder  ImportFrom Link  Paste Raw Text

Agitity-2018/master/Agilin 20201 8%20Lab% 205 postman_callection jsen
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3. Before proceeding verify the Agility 2018 environment is selected from the drop down in the top right
of POSTman

x v | © £k
Mo Erwiranment

wples (0] -
Agility 2018

Cookies Code

4. In the bigip01.dnstest.lab (https://192.168.1.100) web Ul, navigate to Security > DoS Protection >
Device Configuration > Network Security.

5. Expand the Bad-Header-TCP category in the vectors list.

6. Click on the Bad TCP Flags (All Flags Set) vector name and take note of the current settings
7. Within POSTman open the collection “Agility 2018 Lab 5”

File Edit “iew Help

Collections

0o

v B Apility 2018 Lakb 5
B requests

GET  Step 1:Get Original Device DOS Pro..,
PUT  Step 2: Modify Device DOS Profile
GET  Step 3 Get Modified Dewvice DOS Pr..,
Step & Create Address List
Step Si Create Mew Rule
Step G: Create Mew Rule List
Step 8 Create Mew Policy Rule List ..
Step 9: Create Drop Rule in Policy

Step 10: Deploy Policy to bigip02

8. Run step 1 by clicking on the send button to the right
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lity 2018
Step 1: Get Qriginal L X + e Agility

b Step 1: Get Original Device DOS Profile

GET ~+ herps:f{{big Jrngrnttrmisecuringdosidevice -configl~Cormmon~dos-device-config Params

Authorization @

9. The output from the GET request can be reviewed, this is showing you all the device-dos configuration
options and settings. Search for “bad-tcp-flags-all-set” by clicking ‘ctrl +f*. Note the values as they are
currently configured. We are now going to modify the Bad TCP Flags (All Flags Set) attack vector. To
do so run step 2 of the collection by highlighting the collection and click “Send”.

10. You can now execute step 3 in the collection and verify the changes, you can also verify the changes
in the BIG-IP web UI.

Bad TCP Flags (All Flags Set)

State

I Mitigate :

Threshold Mode

@ Fully Manual

Detection Threshold EFS
Specify 50

Detection Threshold Percent
Specify 200

Mitigation Threshold EPS

Specify 100
Cancel Update
11. Open the BIG-IP SSH session and scroll the Itm log in real time with the following command: tail -f
/var/log/Itm

12. On the attack host, launch the attack by issuing the following command on the BASH prompt:

sudo hping3 10.20.0.10 --flood —--rand-source --destport 80 -c 25000 --syn
-—-ack -—-fin --rst —--push --urg —--xmas —--ymas

IrCE ——destport ol

= + 0 data b

100% packet loss

15. Navigate to Security > DoS Protection> DoS Overview (you may need to refresh or set the auto
refresh to 10 seconds). You'll notice from here you can see all the details of the active attacks. You
can also modify an attack vector right from this screen by clicking on the attack vector and modifying
the fly out.
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Security » DoS Protectios
Eviction Policy List (=)

View Fitter

Filter Type DoS Atlack ¥
Auta Refresh Disabled ¥ | Reffesh

Enter Vector Name v | Attack Status || average Aggregate EPS | | Current Dropped EPS | [ Detection Threshold EPS

Profile |Ana:we:tm = ‘mam = ‘ Family = ‘Leammg = ‘ Context & ‘ [~ Aggregate = ‘ [~] Bad Actor & ‘ [~ Attacked Destination & ‘ current ‘1 min ‘1 hour |Aggregate ‘ Bad Actor ‘ Attacked Destination ‘ Threshold iode ‘Aggregam ‘ Bad A:tnr|A||a:ken Destination
dos-device-confiy Had TCP fags (all fags se) Mitgate ([ENEME @ Ready Device Deterted @) None © nNone 0 1280 0 0 0 FullyManual 50 ik A

16. Return to the BIG-IP web Ul. Navigate to Security > Event Logs > DoS > Network > Events.
Observe the log entries showing the details surrounding the attack detection and mitigation.

Security » Event Logs : DoS : Network : Events

£ ~ | Frotoco

| Destination |
Cuntex‘t| < Address i = Fort . = Event I = Type i = Action i = Aftack D ! = Packets Inf sec | = Dropp
Evice Aftack Stopped  Bad TCP flags {all flags sety  Mone 41123876591 0 0
evice 1020010 80 Aftack Sampled Bad TCP flags {all flags sety Crop 4112387681 597 5497
evice 10200010 80 Aftack Sampled Bad TCF flags {all flags sefy Drop 4112387691 5493 593
Bvice 10.20010 &0 Aftack Sampled Bad TCP flags {all lags sety Drop 41123876591 601 601

17. Navigate to Security > Reporting > DoS > Analysis. Single-click on the attack ID in the filter list to
the right of the charts and observe the various statistics around the attack.

18. The same attacks can also be seen in BIG-IQ as demonstrated in the previous lab.

Congratulations, you have successfully defeated Joanna’s festive attack using only the REST API
to configure the device!

Since it’s the end of the week and Joanna is using the same IP address continually, lets block her IP address
and her subnet using BIG-IQ. We'll use the REST API to accomplish this as well, as BIG-IQ also has an
available REST API.

1. Using POSTman run step 4, this will create an address-list within BIG-1Q, the advantage to address-
lists is they allow you to group similar objects into a group. In this instance we’re going to create
an address-list named API_Naughty Address_List with a host and a network. Once you run the
command you'll receive output below. You will need to copy the value returned in the ‘ID” field as
shown below:

Eody (10) Status: 2000K  Time: 713ms  Size: 7508
Pretry Jsan w = @ Q  SaveResponse

1~q

2~ "addresses": [

5o

4 "address": "10.28.0.8/24",

5 "description”: "Joanna Netowrk"

i T

I i

L "address": "10.28.0.20",

a "description’: "Joanna Host"

12 T

11 1

12 "partition": "Comman",

13 "name": "API_Naughty_address_List",

14 rid" 25e56d-6430-3b7c-8ae5-1322bdB7d1E8",

15 "generation": 1,

16 "lastUpdateMicros": 1531882898616851,

17 "kind": "cm:adc-core:working-configinet:ip-address-lists:adcaddressliststate”,

18 "selflink": "https:/slocalhostsmgnt/ensade-core/working-configsnet sfip-address-1ists/2aaSeSed-6430-3b7c-8ae5-1322bd87d158"
19 3}

2. Take the copied text and paste it into the environment variable for AFM_Adddress_ID. The variables
are accessed by clicking on the “eye” icon next to where you selected the Agility 2018 Environment:
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Agility 2018 ~ |© £

Uiy U Environrment quick look fdic

bigip01  192.168.1.100

bigig01-mgmt  192.168.1.50
AFM_Address_|D
AFM_Rule_ID
AFM_Policy_ID
bigip02-machineid

Globels Edit

Mo globel verishles

Global variables are a set of variables that are always available in a
workspace,
Learn more about globals

3. Click edit and enter the value returned in step 1, when completed click update
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MAMAGE EMNVIROMMENTS

Edit Environment

Agility 2018
Key Walue Bulk Edit
bigip01 192.168.1.100
bigiq01-mgmt 102.168.1.50
=M ARV _Address D ?aa5e56d-6430-3b7c-Bae5-1322bd87d158 X
AFR_Rule_|D
AFR_Policy D
bigip02-rnachineid

4. We will now create a rule list name first, to accomplish this send the call found in step 5. You will need
to also capture the “ID” in this step as well. This value will be updated in the AFM_Rule_ID field

1+ 9

2 "rulesCollectionReference": {

3 "link": “"https:s/localhost/mgmt/sem/Firewallsworking-configirule-lists s765F87el-9b26-3142-8a63-95aa6c4232cf /rules”,
4 "isSubcollection": true

El ts

] "partition": "Common",

7 "mame": "API_Naughty_Rule_List",

] "id": "F65'F8?e1—9b96—3142—8a63—95aa6c4232C'F",

9 "generation": 1,

i@ "lastUpdateMicros": 15318634284595874,

11 "kind": "cm:firewall:working-config:rule-lists:ruleliststate”,

12 "selfLlink": "https:sslocalhostsmgmtsom/Firewall sworking-configi/rule-1ists 765F87el-9b96-3142-8a63-95aa6cd232cF"
13 3

5. Take the copied text and paste it into the environment variable for AFM_Rule_ID
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MAMAGE EMNVIROMMENTS

Edit Environment

Agility 2018

Key Walue Bulk Edit
bigip01 192.168.1.100
bigiq01-mgmt 102.168.1.50
AFM_Address_|D ?aa5e56d-6430-3b7c-Bae5-1322bd87d158
AFM_Rule_ID 765f8721-9096-3142-8a63-95 45604232 cf
AFR_Policy D
bigip02-rnachineid

6. At this stage we have created an address-list with objects and saved the ID, we have also created a

rule name and saved the ID. The next step is to add an actual rule to the newly created rule named
“Naughty_Rule_List”. Before you send the call-in step 6, take a moment to examine the body of the
request. You'll notice in the URI we're referencing the variable of AFM_Rule_ID and in the body of the
JSON request we're linking the AFM_Address_ID to the rule. Once sent you'll receive confirmation
similar to the below output.
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¥ Step 6: Create New Rule List Exarnples (0]
POST ~ https:f{{bigigl -megmi i mgmticmffirevsal fwarking-configirule-lists AR _Rule_ID}Hrules Params Save v
(21 Body @ Cockies Code
farm-data s-wnanar-form-urlencoded ® raw binary  JSOM (applicationfjsan) ¥
-]
"action': “drop",

"evalOrder': 10@@,

"log": true,

"protocol®: “any",

"source": {
"addressListReferences': [

"link": "https://localhost/memtfem/Firewall /working-configsaddress-1lists/{{AFH_Address_ID}}"

1

ste": "ensbled”,
"name": "#PI_Naughty Rule List"

(10) Status: 200 0K Time: 182ms  Size: 107 KB

@ Q SaveResponse

dl

JSoM v

"action”: "drop",

"evalOrder': 102@,|

"log": true,

"protocol®: "any",

"source": {
"addresslistReferences': [

{
: "23aSe56d-643@-3b7c-Bae5-1322bd87d158",
"API_Naughty_ddress_List",
Firewall:working-config: address-1ists:addressliststate”,
"partition": "Common",
"link": "https://localhost/mgmtfem/Firewall /uorking-config/address -1ists /2aa5e56d-643@-3h7c-8ae5-1322hd87d158"
¥

state": "enabled”,
" BRORRERR-BRER - 2PAE -200A-160b3996ddsh ",

-8071755514252@7 8893,

HPT_Haughty_Rule List®,

ded526-Bc78-33F3-bF26-B22BFclRecTI",

"generation”: 1,

"lastUpdateMicros": 1531863799985423,

"kind": "cm:firewall:working-config:rule-lists:rules:rulestate®,

"selflink": "https://localhost/mgnt/em/Firewsll/working-config/rule-1ists/765F87el-9b96-3142-8a63 -35aa6cA232cF /rules /61ded526-0c78-33F3-bF28 -8228Fc1@dc 73"

7. Since this is an existing environment, we're going to first need to obtain the policy ID before we can
assign the value to this variable. To obtain the policy ID of the existing policy we created in lab 1 and
imported in the prior lab, run step 7.

1~

2w "items": [

g i

4 - "rulesCollectionReference": {

5 "link": “"https:s/localhostsmgmtsems/Firewallfworking-configspolicies fodfd45@c-128f-33c@-a361-5b8c8baedbdS/rules”,
g "issubcollection": true

7 ts

8 "partition”: "Common",

9 "Global”,

i@ "FofddS@c-128F-353c@-a361-5b&cdbaesbds”,

11 "generation": 1,

12 "lastUpdateMicros": 1531499362848442,

13 "kind": "cm:firewall:working-config:policies:policystate”,

14 "selflink": "https:/slocalhost/mgmt/em/Firewall/working-config/policies /fdfddS@c-128f-33c@-a361-5b8c8baelbds”
15 ts

16 = I

17 -~ "rulesCollectionReference": {

18 "link": “"https:s/localhostsmgmtsemsFirewallfworking-configspoliciese3603dle-be2c-3@0b-58ac?-2a0a2d4@953c/rules”,
13 "issubcollection": true

22 ts

21 "partition": "Common",

22 "rd_@ policy",

23 "e36@3dle-bc2c-3@0b-8ach-2a%a2dd@983c",

24 "generation": 1,

25 "lastUpdateMicros": 1531499362847606,

26 "kind": "cm:firewall:working-config:policies:policystate”,

27 "selflink": "https:/slocalhost/mgmt/em/Firewall/working-config/policies/e36@3dle-bc2c-308b-8acy-2a%a9d4@383c"
28 +

29 1,

3@ "generation": 1,

31 "kind": "cm:firewsll:working-config:policies:policycollectionstate”,

32 "lastUpdateMicros": 1528386995229533,

33 | "selflink": "https:/slocalhost/mgmtiem/Firewall /working-config/policies"

EER

8. You will notice there are two policies, Global and rd_0_policy, we’ll need to copy the ID for the
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rd_0_policy which is located directly under its name and paste it into the variable for AFM_Policy_ID.

MANAGE ENVIRAMMENTS

(IS

Edit Environment

Agility 2018

ey YValue Bulk Edit
bigip01 182.168.1.100
bigiq01-rnermt 182.168.1.50

AFM_Address D 23a0e56d-6430-3b7 c-Bae5-1322bd87 4158

AFM_Rule_ID 765f87e1-0b86-3142-8a63-05aa004232cf
AFM_Palicy_ID e36023d1e-be2e-200b-Bac?-2a0a9d40083

bigip02-machineid

9. Finally run step 8 to add the new rule list to the existing policy, when completed you’ll receive output
similar as seen below.

Body

Prety

k|

"ewalOrder":
“state":
"ruleListReference":

T

(10) Stetus: 2000K  Time: 528ms Sizer 1.01 KB

1SOM = @ Q  SaveResponse

@,

"enabled”,

1

"7E5F87e1-9h96-3142-8a63-95a36c4232cF",

: "API_Naughty_Rule List",

cm:Firewall:uorking-configirule-1ists:ruleliststate",

"partition”: "Common®,

"link": "https://localhost/mgmtsen/Firewallfworking-config/rule-1ists 765F87el-9095-3142-8a63-55aa6c4232cF"

“iges

"ruidiaster': "@020002Q-2002-2020-2002-162b297bb7d9",
"ruidSeed":
"name":
widns

-64491@1841774298381,
"Reference_To_APT_Naughty Rule List",
" B8 dFbbab -@8eS5 - 3754 -8855 -4 14F37a638cd ",

"generation’: 1,

"lastUpdateMicros":
"kind":
"selflink":

1531865050230663,
"en:firewall:working-config:policies:rules:rulestate”,
"https:/flocalhost mgmt/cm/Firewall /working-config/policies /e3603d1e-be2e -308h -8aco -2a9290409583¢/ rules /@S dFbbab -@8es -3F54 -8855 -d14F37a630cd "

10. Before we deploy the policy. Log into the BIG-1Q web Ul (https://192.168.1.50) and navigate to Config-
uration Security Network Security Firewall Policies. Click on the link for the rd_0_policy, expand all the
rules to verify your new API created rule list is first in the list and all objects are created as expected.

Qm 2
| wonitoring | contguration | vepioyment | pevices | sysiem | ppiications
<) ... /rd_0_polic
v Access -O-polcy
Acesss Groups Genenuie || Agaruetia || GotoRue + |fiter.
> LOGAL TRAFFIC PROPERTIES 10 Name Address Port waN Subscriber hddress Port Adion iRule Protocol
1 Reference_To APLNaughty_Rule List
» NETWORK v
v secuRTY 11 APLNaughyRulelist  AddressLists Any ny Any ny any drop any
API_Naughty_Address_List
2 _Common_applcation rule s
21 allowhup Ay Ay Any Any Addresses Forts accept-decisively 1
— 22 alowssn  Addresses Any ny any Adresses Forts accepr-decisvely wp
10200200 1040050 2
AddressLiss 3 _Common.web e ist
Port Liss M
31 allowhup ny Ay Any Any Addresses Ports accept-decisively o
Rule Schedues 1030050 50
e n——— 32 allowssh Adresses Any. Any Any Adresses Ports accept-decisvely =3
10200200 1040050 2
seni 4 rejea102000 Addresses Any Any any Ay any reject any
102000124

Timer Palicies

11. The final step is to deploy the policy to the BIG-IP.

Before we can do this, we have one last variable

we’ll need to acquire, the machine ID of bigip02.dnslab.test. To obtain the machine ID run the call in
step 9, once the call is run, you will look for the machineld key and copy the value to the environment
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variable bigip02-machined as shown below and click update.

é “items": [ machinelD < = Al x
g 19 results

4 "firewallType": "wip",

s "firewallIpAddress": "::.@",

B "rulesCollectionReference”: {

7 "1ink": "https:/flocalhost/mgmtsen/Firewallfworking-config/firenalls /deccedfs-8114-354c-ac5e-718d315a274f /rules",

8 "issubcollection®: true

9 ,

i) "partition": "Common®,

11~ "deviceReference": {

12 "id "g4682ec? -e2@5-4cla-9746-bchTadd2b32h ",

13 "name": "bigip2.dnstest.lab",

14 "kind": “"shared:resolver:device-groups:restdeviceresolverdevicestate",

15 "machineld": "b45822c772236*4cla*9746*b:b7add2b32b",

16 "link": "https://localhost/mgmt/shared/resolver/device-groups/em-firewall-allFirewallDevices /devices /64AB2ecT-e206-dcla-374A-bchTadd2b32b"
17 1

FANAGE EMNYIROMMEMTS

Edit Environment

Agility 2018

Key

bigip01
bigig1-rngrmt
AFM_Address_|D
AFMN_Rule_ID

AFK_Palicy_ID

(IS S

bigip02-rnachineid

Value Bulk Edit
192,1688.1.100

192.168.1.50
2aa5e56d-6430-3b7c-8a5-1322bd87d158
765f87e1-0b96-3142-8a63-05aa0c4 232 cf
e3603d1e-bc2c-300b-8acl-2a9a9d40583c

64682ecy-e206-4c1a-9746-bcb7add2b32b

12. Finally, you will run step 10, this will initiate a deployment on BIG-1Q to deploy the changes to BIG-
IP. Within BIG-1Q navigate to Deployment Evaluate & Deploy Network Security. At the bottom in the
deployments section you'll notice an API Policy Deploy task. Feel free to click on the task to investigate
the changes. Once the policy has deployed, log into the web Ul of bigip02.dnstest.lab and navigate
to Security network Firewall Active Rules. Change the context to Route Domain and select 0. Expand
all of the rules to verify the rules have been deployed as expected. Your final screen should look

something like the screen capture below.
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Security »» Network Firewal

Context Fitter
Paliy Type Enforced v
Context Route Domain... v |0 i
[Fnter #ctive Rutes List | Add Rule List » | | Add Rule v
‘ D ‘ 8 ‘ Name ‘ State ‘ Frotocol Source Destination Action Logging Count Latest Match
£ Global with policy Global
@ 1 Fing Enabled 1CHE Any Any AcceptDecisively Yes 3 Jul17 2018 16:02:24-0700
) Route Domain 0 with policy rd_0_policy
@ 1 @ 4P| Naughty Rule List Enabled Any
API_Naughty_Rule_List Enabled Any Addresses Any Drop Yes 44 Jul17 2018 17:10:01-0700
API_Naughty_address_List
@ © anplication_ule_list Enabled ny
allow_hip Enabled Tep Any Addresses AcceptDecisively Ves 0 Never
10.40.0.50
Ports
&0
allow_ssh Enabled Top ddresses Addresses AcceptDecisively Yes 0 Never
10.20.0.200 10.40.0.50
Ports
2
@ 3 © web_rule_list Enabled Any
allow_htin Enabled TeR Any Addresses AccepkDecisively Yes 1 Jul17 2018 15:02:33-0700
10.30.0.50
Ports
&0
allow_ssh Enabled ToP #ddrasses fddrassas AcceptDecisively Yes 0 Never
(confiety 10.20.0.200 10.40.0.50
Ports
n
(S reject 1020 00 Enabled Any Addresses Any Reject Yes 58 Jul 17 2018 17:07:13-0700
{confict 102000024
(Defaulty Enabled Any Any Any Rejoct o 0 Never

Lastly, in your web browser, verify you can no longer access the web pages http://10.30.0.50 and http:
//10.40.0.50 as well as no longer being able to SSH to any of the devices.

Written for TMOS 13.1.0.1/BIG-1Q 6.0

« IT agility. Your way.
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Firewall 320 — Advanced Multi-Layer Firewall Protection
Participant Hands-on Lab Guide
Last Updated: January 2 2020

©2018 F5 Networks, Inc. All rights reserved. F5, F5 Networks, and the F5 logo are trademarks of F5
Networks, Inc. in the U.S. and in certain other countries. Other F5 trademarks are identified at f5.com.

Any other products, services, or company names referenced herein may be trademarks of their respective
owners with no endorsement or affiliation, express or implied, claimed by F5.

Welcome to the F5 Agility 2018 Multilayer Firewall Implementations setup and hands-on exercise series.

The purpose of the Lab Setup and Configuration Guide is to walk you through the setup of F5 BIGIP to
protect applications at multiple layers of the OSI stack hence providing Application Security Control. This in
effect allows F5 BIG-IP to be multiple firewalls within a single platform.

*Assumptions/Prerequisites*: You have attended the AFM 101 lab sessions either this year or in previous
years. Additionally this lab guide assumes that you understand LTM/TMOS basics and are comfortable with
the process of creating Nodes, Pools, Virtual Servers, Profiles and Setting up logging and reporting.

There are three modules detailed in this document.
Module 1: F5 Multi-layer Firewall
Module 2: F5 Dynamic Firewall Rules With iRules LX
Module 3: AFM Protocol Inspection IPS
Lab Requirements:
» Remote Desktop Protocol (RDP) client utility
— Windows: Built-in

— Mac  (Microsoft  Client): https://itunes.apple.com/us/app/microsoft-remote-desktop/
id715768417?mt=12

— Mac (Open Source Client): http://sourceforge.net/projects/cord/files/cord/0.5.7/CoRD_0.5.7.zip/
download

— Unix/Linux (Source — Requires Compiling): http://www.rdesktop.org/
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Note: You may use your webbrowser for console access if necessary but screen sizing may be affected.

Note: [P Filtering locks down connectivity to to the remote labs. If you are required to VPN into your cor-
porate office to get Internet access, please determine your external IP address via https://www.whatismyip.
com and provide an instructor with that information for your pod.

+ Connectivity to the facility provided Internet service

+ Unique destination IP address for RDP to your lab

2.1 Module 1: F5 Multi-layer Firewall

This module has seven labs in configuring an Advanced Multi-layer firewall applicable to many data center
environments.

In this module, you will build a perimeter firewall with advanced Layer 7 security mitigations.
Estimated completion time: 1 hour
Objective:

+ Inspect multiple internal pools and virtual servers for different applications within your data center. e.g.
www, API, /downloads

* Inspect external hosted virtual server that allows the same IP address to be shared with multiple SSL
enabled applications.

* Inspect and understand LTM policy to direct traffic to appropriate virtual server
« Configure local logging; test
+ Create a network firewall policy to protect the internal application virtual servers; test

+ Configure the external virtual server to tranform traffic coming through CDN networks so that firewall
policies can be applied to specific clients; test

» Modify the network firewall policy to block based on XFF; test

 Apply Layer 7 responses (403 Denied) for CDN clients to firewall drop rules
» Configure HTTP protocol security; test

» Configure SSL Visibility to external security devices e.g. IDS; test

Labs 1 & 2 highlight the flexibility of leveraging an application proxy such as the BIG-IP for your perimeter
security utilizing common traffic management techniques and some additional features unique to the BIG-IP
as an Application Delivery Controller.

Labs 3 & 4 Breaks out applying differing security policies to the multi-tiered application deployment.
Lab 5 Highlights the flexibility of the Multi-Layered Firewall to solve common problems for hosting providers.
Lab 6 Applies Layer 7 protocol validation and security for HTTP to the existing applications.

Lab 7 Provides a solution for sending decrypted traffic to other security devices.
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Warning: [P addresses in screenshots are examples only. Please read the step-by-step lab instructions
to ensure that you use the correct IP addresses.

2.1.1 Lab 1: Pre-configured pools and virtual servers

A virtual server is used by BIG-IP to identify specific types of traffic. Other objects such as profiles, policies,
pools and iRules are applied to the virtual server to add features and functionality. In the context of security,
since BIG-IP is a default-deny device, a virtual server is necessary to accept specific types of traffic.

The pool is a logical group of hosts that is applied to and will receive traffic from a virtual server.
On your personal device
Look at the supplemental login instructions for:

» External Hostnames

» External IP addressing diagram

* Login IDs and Passwords are subject to change as well.

‘:-_‘.._.‘
a
S
BIG-IP
Client Management 10.1.1.4 WeB Servers
IP10.1.10.199 Client Met Self-1P 10.1.10.245/24 sitel.com 10.1.20.11
Server Net Self-IP 10.1.20.245/24 siteZ.com 10.1.20.12

site3.com 10.1.20.13
sited.com 10.1.20.14
site5.com 10.1.20.15
swwa.com 10.1.20.17

Note: Use the Chrome Browser to Connect to BIG-IPO1— https://10.1.1.4 Credentials are displayed in the
login screen

Inspect Application Pools

On BIG-IP
Verify the following pools using the following tabel of pool information.

Navigation: Local Traffic > Pools > Pool List

Name Health Monitor | Members | Service Port
pool_www.site1.com | thttp 10.1.20.11 | 80
pool_www.site2.com | http 10.1.20.12 | 80
pool_www.site3.com | http 10.1.20.13 | 80
pool_www.site4.com | http 10.1.20.14 | 80
pool_www.site5.com | http 10.1.20.15 | 80
pool_www.dvwa.com | tcp_half_open 10.1.20.17 | 80

2.1. Module 1: F5 Multi-layer Firewall 101
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Local Traffic » Pools : Pool List

15 - Pool List Statistics

3 | Search| | Create.. |
| [~] status ‘A Name + Description |+ Application | IMembers ‘ = Partition / Path
[+] IDS_Pool 1 Commen
@ pool_dvwa.com 1 Common
Q@ pool_ext_ssh 1 Common
[¢] pool_site1.com 1 Common
[+] pool_site2.com 1 Commen
@ pool_site3.com 1 Commen
@ pool_sited.com 1 Common
[#] pool_site5.com 1 Common

Delete...

Inspect Application Virtual Servers

By using the term ‘internal’ we are creating the virtual servers on what is essentially a loopback VLAN
which prevents them from being exposed. The EXT_VIP in this exercise is used to forward traffic with
specific characteristics to the internal VIP’s. This is accomplished by assigning a traffic policy to the VIP.
The traffic policy is described and inspected in the next section. For this class, the Wildcard Virtual servers
(Blue Square status indicator) are not used.

Navigation: Local Traffic > Virtual Servers > Virtual Server List

Local Traffic » Virtual Servers : Virtual Server List

Viriual Server List | Virlual Address

- ist Statistics

Ir Search Create..
| [~] Status ‘ + Name N i + Appiication||& + Service Port | + Type | Resources |¢ Partition / Path

[#] EXT_SSH_10_1_10_30 10.1.10.30 22 (SSH) Performance (Layer 4) Edit. Common

_VIP_10_1_10_ .1.10. ny andar i ommon

EXT_VIP_10_1_10_30 10.1.10.30 0 (Any) Standard Edit Ci

@ IPV4_ANY Any IPv4 0 (Any) Forwarding (IP) Edit Common

@ IPV4_TCP Any IPvd 0 (Any) Forwarding (IP) Edit Common

@ IPV4_UDP Any IPv4 0 (Any) Forwarding (IP) Edit Common

@ IPV6_ANY Any IPv6 0 (Any) Forwarding (IP) Edit Common

@ IPVE_TCP Any IPv8 0 (Any) Forwarding (IP) Edit Common

a IPV6_UDP Any IPV6 0 (Any) Forwarding (IP) Edit Common

@ inf_vip_www. dvwa.com_6.6.6.17 6.6.6.17 80 (HTTP) Standard Edit Common

@ int_vip_www.site1.com_1.1.1.1 1111 80 (HTTF) Standard Edit Common

@ site2.com_2222 2222 80 (HTTP) Standard Edit Common

Q ww.site3.com_3.3.3.3 3333 80 (HTTP) Standard Edit. Commen

@ www sited com_4.4.4 4 4444 80 (HTTP) Standard Edit Common

Q int_vip_www.site5.com_5.5.5.5 5555 80 (HTTP) Standard Edit. Common

Enable || Disable || Delete

Inspect the Local Traffic Network Map

Navigation: Local Traffic > Network Map
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5

Partition: Common v Sortby: Status v Filer. ADVANCED FILTER
Last Update: Feb 7, 2020 8:32 AM (PST)

w:Loading...
Common
@ PVAANY @ Pv4TCP @ Pv4UDP @ PVE_ANY
@ PVE_TCP B Pvs_UDP @ EXT_SSH_10.1.10_30 @ EXT_VIP_10_1_10_30
@ rpool_ext_ssh O XFF-SNAT
® 101201122 @ pool_site.com
@ 10.1.20.11:80

@ int_vip_www.dvwa.com 66617 @ int_vip_www.sitel.com_1.1.1.1 @ int_vip_wwwsite2.com 2222 @ int_vip_www.site3.com_33.3.3

@ pool_dvwa.com @ pool sitel.com @ npool site2.com @ pool sited.com
@ 10.12017:80 @ 10.1.20.11:80 @ 10.12012:80 @ 101201380

@ int_vip_wwwsited com 4444 @ int_vip_www siteb com 5555

@ pool_sited.com @ pool_sited.com
@ 10.1.20.14:30 @ 10.1.20.15:80

Note: The virtual servers should show a green circle for status.

Note: This completes Module 1 - Lab 1

2.1.2 Lab 2: Leverage LTM Policies To Direct SSL Terminated Applications To Sec-
ondary Virtual Servers

What is SNI? Introduced in TLS 1.0 as a TLS extension, Server Name Indication (SNI) allows the client to
send the hostname they are trying to connect to in the SSL handshake. This allows the Application Delivery
Controllers (ADC) such as the BIG-IP and the Application servers to identify the appropriate application the
client is trying to connect to. From this information, the ADC can respond with the proper SSL certificate
to the client allowing the ADC to provide SSL enabled services for multiple applications from a single IP
address.

LTM policies are another way to programatically modify traffic as it is flowing through the data plane of the
BIG-IP. This functionality can also be accomplished with F5 iRules. The advantage this has over iRules is
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that LTM policies can be modified and appended to the existing configuration without replacing the entire
application configuration. This lends itself to being updated through the CLI or via the REST API easily.

If you make a single change to an iRule, the entire iRule needs to be re-uploaded and applied.

The LTM policy is what directs application traffic to flow from the external virtual server to the internal virtual
servers based on the Layer 7 request. In this case, since we are using SNI to terminate multiple applica-
tions (mysite,yoursite,theirsite, api, downloads) we need to be able to direct that traffic to the appropriate
application pools. Some can even come back to the same application pool.

Whether it is based on the hostname or the URI path, the request can be forwarded to a different virtual
server or an application pool of servers.

Inspect the LTM Policies

Take a few minutes to open the draft policy and review the iptions. Policy is a very flexible tool to direct
traffic based on the packet content. In this use case we distribute traffic to a subset of internal VIP’s, Policy
can be configured to forward traffic directly to pools or nodes based on the packet content and many other
attributes

Note: As shown in this diagram, there is an external VIP and internal VIPs. The external VIP has the local
traffic policies on it.

L]

T .

Lm‘?;g":f& r‘fl;"‘es Host Int_vip sitel.com Pool sitel.com

ext_vi | e SiteLcom 1111:80 10.12011:80 |
10.1.10.30:443 e

Host - Int_vip site2.com | Pool site2.com |

SiteZ.com T 2.2.2.2:80 | 10.1.20.12:80
Host B Int_vip site3.com Pool site 3.com |

Site3.com ~ 3.3.3.3:80 | 10.1.20.13:80
Host - Int_vip sited.com | Pool sited.com |

Sited.com 4.4.4.4:80 10.1.20.14:80

Host . Int_vip siteS.com | Pool siteS.com

Site5.com - 5.5.5,5:80 10.1.20.15:80

Hast - Int_vip dvwa.com | Pool dvwa.com

dvwa.com e 6661780 | 10.1.20.17:80

Connect

Navigation: Local Traffic > Policies : Policy List

Navigation: Select HTTPS_Virtual_Targeting_Policy_L7V3 from the published policies
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Local Traffic » Policies ; Policy List » HTTPS Virtual Targeting_Policy LTV3

4 - Published Policy

General Properties

Policy Name HTTPS Virtual_Targeting_Policy_L7V3

Partition / Path Comman

Description

Strategy Execute | Dest v | matching rule using the best-match v strateqy
Type Traffic Palicy

Cancel  Create Drat ~ Clone

Rules

| Q

4D |+ Name +Descripfion~—~ Condtions Actions
R W site?.com HTTP Host host s 'site1.com' &t request fime. Forward fraffic to virtugl server 'Common/ini_vip_www site1.com_1.1.1.1' at request time.
0?2 Vrww.site2.com HTTP Host host is 'site2.com' at request fime. Forward fraffic to virtugl server 'Common/ini_vip_www site2.com_2.2.2.2' at request fime.
03 Vi site3.com HTTP Host host s 'site3.com’ &t request fime. Forward fraffic to virtugl server 'Common/ini_vip_www site3.com_3.3.3.3' at request time.
4 Vi sited. com HTTP Host host is 'sited.com’ at request fime. Forward fraffic to virtugl server 'Common/ini_vip_www sited.com_4.4.4.4' at request fime.
b Vi site5.com HTTP Host host is 'site5.com’ at request fime. Forward trafic to virtual server ‘Commaon/ini_vip_wwiisite5.com_5.5.5.5' at requesi time.
6 Vi, dvwa.com HTTP Host host s ‘dvwa.com’ at request time. Forward fraffic to virtugl server 'Common/ini_vip_www dvwa.com_6.6.6.17" at request time.

Verify that the Policy is assigned To The External Virtual Server

Navigation: Local Traffic > Virtual Servers : Virtual Server List
Navigation: Click the EXT_VIP_10_1_10_30

Navigation: Click the Resources Tab
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Local Traffic » Virtual Servers : Virtual Server List » EXT_VIP_10_1_10_30

4 - | Properties Resources Security v | Stafistics
|

Load Balancing

Default Pool pool_sitet.com v
Default Persistence Profile None \

Fallback Persistence Profile None v

Update

iRules

Mame

[Common/XFF-SNAT

Policies

Mame

{Common/HTTPS_Virtual_Targating_Palicy_L7V3

Note: there is a policy and an iRule is assigned to the VIP:

Create An ACL to allow web traffic and SSH
The rules created in this section allow basic connectivity to the resources. We will add enforcement rules
at the Virtual server level to demostrate functionality

On bigip01.f5demo.com (10.1.1.4) create a rule list to allow traffic. A logical container will be created before
the individual rules can be added. You will create a list with rules to allow port 80 (HTTP), 443 (HTTPS),
and 22 (SSH) to servers 10.1.20.11 through 10.1.20.17 We will also create a rules which allows HTTPS
and SSH traffic to access 10.1.10.30

Create a container for the rules by going to:

Navigation: Security > Network Firewall > Rule Lists

Navigation: select Create

For the Name enter web_rule_list, provide an optional description

Navigation click Finished
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Security » MNetwork Firewall : Rule Lists » New Rule List...

General Properties

Name web_rule_list

Description

Cancel | Repeat || Finished |

Security » Metwork Firewall ; Rule Lists

£+ | Active Rules Pulicies Rule Lists Schedules P Inteligence =

¥ | & Name

[ _sys_saif allow

[ _sys seff allow defaults

(] _sys_saif allow management
[ geo_restict ruke fist

[ web rule list

Delete...

Navigation Select the web_rule_list by clicking on it in the Rule Lists table
Navigation click the Add button in the Rules section.
Add a rules into the list to allow HTTP, HTTPS, and SSH traffic as described in the next steps
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Security » Network Firewall ; Rule Lists » web rule list

# - Properties
1

(eneral Properties

Name We_rule_list
Parition / Path Common
Descripton ‘ |

Update | Delete

' Search Source H Desfination ‘ Rerder || Add
Name UUID | Description | State | Schedule | Address/Region | Port | Subscriner | VLAN/Tunnel Zone  Address/Reqion  Port | Zong | Protocal | Virtual Sever | iRule | Action | Logging | Service Palicy

Mo recards to display.

' Remave |
Name allow_http_and_https
Protocol TCP
Source Leave at Default of Any
Destination Address | Specify Address Range 10.1.20.11 to 10.1.20.17, then click Add
Destination Port Specify... Port 80, then click Add Specify... Port 443, then click Add
Action Accept
Logging Enabled

Navigation: Click Repeat
Add a rule into the list to allow HTTPS to Virtual Server 10_1_10_30.

Navigation: Click Finished
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* vl S lidin

Navigation: Click Finished

Assign the Rule List to a Policy

Navigation: Security > Network Firewall > Policies
Navigation Click Create
For the Name enter rd_0_policy, provide an optional description

Navigation click Finished.

2.1. Module 1: F5 Multi-layer Firewall
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(Note: We commonly use “RD” in our rules to help reference the “Route Domain”, default is 0)**

_static/class2/image273.png

Navigation Edit the rd_0_policy by clicking on it in the Policy Lists table,
Navigation click the Add Rule List button.
Navigation For the Name, start typing web_rule_list, you will notice the name will auto complete,

Navigation select the rule list /Common/web_rule_list, provide an optional description

Navigation click Done Editing.

Security » Network Firewall : Policies » /Commonird_0_policy

Policies Rule Lists Schedules

IPInfeligence =

#% ~ Active Rules

Unsaved changes to the policy!
One or more policy rules have been modified but not commifted to the system. Changes must be committed to the system before taking effect
Commit Changes to Sysl«ﬂ Cancel Changes

General Properties

Name: rd_0_policy

Partiion Common

Description

‘ Filter Active Rules List T Add Rule List | * | | AddRule | =
| ID | ‘ Name | State Protacol Source Destination ‘ Aclions | Logging
i ICommoniweb_rule_list Enabled ¥

Descripion

Done Edifing | | Cancel

You will notice the changes are unsaved and need to be committed to the system. This is a nice feature to
have enabled to verify you want to commit the changes you’ve just made without a change automatically
being implemented.

Navigation click “Commit Changes to System
Assign the rd_0_policy to Route Domain 0

Navigation: Network > Route Domains

Navigation: Click on the “0” to select Route Domain 0
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Navigation: Select the Security Tab
Set Enforcement to Enable and select the rd_0_policy

Navigation Click Update

Network » Route Domains » 0
o 308 Security

Properiies

T

Policy Settings: | B3sic

Route Domain 1D 0
VLANS extemnal, hitp-tunnel, internal, socks-lunnel

. | rd_0_palicy [~
Network Firewal Enforcement: | Enabled... ¥ |Policy:

Staging: Disabled ¥
MNetwork Address Translation Mone ¥

Packet Filter Mone ¥

IP Intelligence MHone v
Maximum Bandwidth Infinite ¥

Service Policy Mone I "|
Eviction Policy Mone r
Update

Configure BIG-IP Firewall in ADC Mode
By default, AFM firewall is configured in ADC mode, which is a default allow configuration. In Firewall mode,
all traffic is blocked at the firewall, and any traffic you want to allow must be explicitly specified.

In deployments where there are a large number of VIP’s, deploying in Firewall mode would require significant
preperation. Firewall functionality is easier to introduce in ADC mode.

Navigation: Security > Options > Network Firewall

| Virtual Server & Self IP Contexts | Accept |

Navigation Click **Update*
limage251|
Open the Firewall Options tab

Validate Lab 2 Configuration

Note: Open a tab on the Chrome Browser to test access to the URLs below

Validation: This lab is using self-signed certificates. You can either open a web browser on the test client
or run CURL from the CLI to validate your configuration.

You will need to accept the certificate to proceed to the application sites

2.1. Module 1: F5 Multi-layer Firewall 111



F5 Firewall Solutions Documentation

URL: https://sitel.com
URL: https://site2.com
URL: https://site3.com
URL: https://sited.com
URL: https://site5.com

URL: https://dvwa.com Username: admin Password: password

With curl you need to use the -k option to ignore certificate validation

Note: From a terminal window (use Cygwin on Win7 Client Desktop). Curl will let us do some of the
additional testing in later sections. If you scroll up to the text immediately following the command you will
see the IP address of the pool member you connected to.

curl -k https://10.1.10.30 -H Host:sitel.com
curl -k https://10.1.10.30 —-H Host:site2.com
curl -k https://10.1.10.30 —-H Host:site3.com

curl -k https://10.1.10.30 -H Host:sited.com

curl -k https://10.1.10.30 —-H Host:site5.com

C. MEIE

rl -k h :
Tatal g : ; Time Time Time
Total Left

100

ALHTTP");

Note: for site 1 connected to 10.1.20.11, site 2 10.1.20.12 etc:
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Note: This completes Module 1 - Lab 2:

2.1.3 Lab 3: Configure Local Logging For Firewall Events

Security logging needs to be configured separately from LTM logging.

High Speed Logging for modules such as the firewall module requires three componenets.
* A Log Publisher
» A Log Destination (local-db for this lab)
* A Log Profile

For more detailed information on logging please consult the BIG-IP documentation.

https://askf5.f5.com/kb/en-us/products/big-ip_ltm/manuals/product/bigip-external-monitoring-implementations-13-0-0/
3.html

In this lab, we will configure a local log publisher and log profile. The log profile will then be applied to the
virtual server and tested.

Create A Log Publisher

This will send the firewall logs to a local database
Create the log publisher using the following information:

Navigation: System > Logs > Configuration > Log Publishers, then click Create

Name firewall_log_publisher
Destinations (Selected) | local-db

System » Logs : Configuration : Log Publishers

General Properties

I Mame firewall_log_publisher

Description ‘

Log Destinations

Selected Available
ICommon ICommon

Destinations local-db alertd

local-syslog

| Cancel || Repeat || Finished |

Note: Leave all other fields using the default values.
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Navigation: Click Finished

Create A Log Profile

Create the log profile using the following information:
Navigation: Security > Event Logs > Logging Profiles, then click Create

Name firewall_log_profile
Protocol Security | Checked
Network Firewall | Checked

Modify The Log Profile To Collect Protocol Security Events

Edit log profile protocol security tab using the following information:
Navigation: Click on the Protocol Security tab and select the firewall_log_publisher

| firewall_log_publisher |

Security »» Event Logs : Logging Profiles :» Create New Logging Profile...

Logging Profile Properties Cancel || Finished |

I Profile Name firewall_log_profile

Protocol Security ¥| Enabled

MNetwork Firewall ¥| Enabled

DoS Protection Enabled

Protocol Security l Network Firewall

HTTP, FTP, and SMTP Security

Publisher | firewall_log_publisher v |

Note: Leave all other fields using the default values.

Modify The Log Profile To Collect Firewall Security Events

Edit log profile network firewall tab using the following information:

Navigation: Click on the Network Firewall tab
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Network Firewall Publisher

firewall_log_profile

Log Rule Matches

Check Accept Check Drop Check Reject

Log IP Errors Checked
Log TCP Errors Checked
Log TCP Events Checked
Log Translation Fields Checked

Storage Format

Field-List (Move all to Selected ltems)

Security » Event Logs : Logging Profiles »: Create New Logging Profile...

Logging Profile Properties

Cancel || Finished

Prafile Name
Protocol Security
Network Firewall

DoS Protection

firewall_log_profile
¥/ Enabled

¥| Enabled

Enabled

Protocol SecuritvINetwork Firgwall I

Network Firewall

Publisher

Aggregate Rate Limit

Log Rule Matches

Log IP Errors

Log TCP Errors

Log TCP Events

Log Translation Fields

Always Log Region

Storage Format

firewall_log_publisher v
Indefinite ¥

¥ Accept
Rate Limit| Indefinite v

¥ Drop
Rate Limit| Indefinite v

#| Reject
Rate Limit| Indefinite v

¥/ Enabled
Rate Limit| Indefinite

¥/ Enabled
Rate Limit| Indefinite

¥/ Enabled
Rate Limit| Indefinite v

¥| Enabled
—

Enabled

Field-List v |Delimiter| ,
Selected ltems:

acl_policy_name
acl_paolicy_type
acl_rule_name
bigip_hostname
context_name
context_type
date_time
dest_geo

[Up |[Down

action -

dest_ip <

Available ltems:

|<_=|
Iil

Note: Leave all other fields using the default values.

Navigation: Click Create

Apply The Logging Configuration

Apply the newly created log profile to the external virtual server created in the previous lab.

Navigation: Local Traffic > Virtual Servers > Virtual Server List
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Navigation: Click on EXT_VIP_10.1.10.30

Navigation: Security tab > Policies

| Log Profile | firewall_log_profile |

Local Traffic » Virtual Servers : Virtual Server List »» EXT_VIP_10.10.99.30

% + Properties Resources Security ~ | Statistics =
N

Policy Settings: | Basic s
Destination 10.10.99.30:443
Service HTTPS
Application Security Policy Disabled 4%
Protocol Security Disabled %
. Enforcement:| Disabled %
Network Firewall
Staging: Disabled %
~ Use Device Policy
Network Address Translation ~ Use Route Domain Policy
Policy| None §
IP Intelligence Disabled 4%
DoS Protection Profile Disabled %
Anti-Fraud Profile Disabled %
Enabled... %
Selected Available
—
ICommon ICommon
Log Profile firewall_log_profile << Log all requests
Log illegal requests
>> global-network
local-dos
Update
* Search
fRolicylTyps]l Enforced i Source || Destination

\E|| Name ‘ [=| ‘ Rule List ‘ Description | State | Schedule ‘ Address/Region ‘ Port ‘ VLAN / Tunnel |Addresisegion ‘ Port | Protocol ‘ iRule ‘ Action ‘ Logging ‘

(Default) Enabled Any Any Any Any Any Any Accept

Delete... = Search Logs... Reset Count

Note: Leave all other fields using the default values.

Navigation: Click Update
View network firewall logs.

Navigation: Security > Event Logs > Network > Firewall
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Security » Event Logs : Network : Firewall
E - 0

Protocol T | Network

- | Logging Profiles

H | Last Hour ¥ ||Search| Custom Search.. | e Destinati |
| + Time |¢ Context ‘ + Name |¢ Palicy Type |¢ Policy Name |¢ Rule |¢ User ‘ + Region ‘% Address ‘ + Port ‘ + VLAN /Tunnel ‘ + Region | + Address | + Port ‘ + Route Domain ‘% Protocol ‘% Action | + Drop Reason

No records to display.

Create Rule

Validate Lab 3 Configuration

Open a new web browser tab and access the virtual server or repeat the curl statements from the previous
sections.

URL: https://site1.com

Note: This test generates traffic that creates network firewall log entries.

Navigation: Security > Event Logs > Network > Firewall

Security » Event Logs : Network : Firewall

v | Protocol ~ | Network Address Translation v | DoS

# -+ | Application ~ | Logging Profiles

"|7 *\ Last2 Hours v ||Search| Custom Search Source Destination
|v|| ¢ Time } ¢ Context i: Name i: Policy Type | ¢ Policy Name ¢ Rule ¢ User ¢ Region | FQDN ¢ Address ‘ ¢ Port ‘ “ VLAN/Tunnel |+ Region & FQDN | ¢ Address ‘: Port
2016-07-17 18:12:39 Virtual Server /Common/EXT_VIP_10.10.99.30 - No-lookup 10.10.99.222 49528 /Common/outside No-lookup 10109930 443
10.10.99.222 49528 _loopback 3 ¥ Vi P | 80
2016-07-17 18:09:21 Virtual Server /Common/EXT_VIP_10.10.99.30 - No-lookup 10.10.99.222 49478 /Common/outside No-lookup 10.10.99.30 443
10.10.99.222 49478 _loopback 1111 80
2016-07-17 18:08:32 Virtual Server /Common/EXT_VIP_10.10.99.30 - No-lookup 10.10.99.10 56453 /Common/outside No-lookup 10.10.99.30 443
10.10.99.10 56453 _loopback 1112 80
2016-07-17 18:08:32 Virtual Server /Common/EXT_VIP_10.10.99.30 - No-lookup 10.10.99.10 56453 /Common/outside No-lookup 10.10.9930 443
10.10.99.10 56453 _loopback 11192, 80
2016-07-17 18:07:38 Virtual Server /Common/EXT_VIP_10.10.99.30 - No-lookup 10.10.99.222 49478 /Common/outside No-lookup 10.10.99.30 443

Note: View new network firewall log entries. Examine the data collected there.

Note: This completes Module 1 - Lab 3

2.1.4 Lab 4: Configure A Firewall Policy and Firewall Rules For Each Application

A network firewall policy is a collection of network firewall rules that can be applied to a virtual server. In
our lab, we will create two policies, each of which includes two rules. This policy will then be applied to the
appropriate virtual servers and tested.

Create The geo_restrict Firewall Rule List and Firewall Policy.

This example provides a firewall policy to the www.site1.com portion of the application. A real world exam-
ple of this would be with companies hosting cryptographic software which is subject to export restrictions.
In this case we will use the Geolocation feature to block access from a couple countries only and only on
the site1.com application.

Navigation: Security > Network Firewall > Policies, then click Create
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| Name | site1_policy |

Security » MNetwork Firewall : Policies :» New Policy...

General Properties

Name | site1_policy

Description |

| Cancel || Repeat || Finished |

Note: Leave all other fields using the default values.

Navigation: Click Finished
Create an IP Drop Network Firewall Rule List

Note: we could have created a rule directly in the policy. Using Rule lists allows us to re-use this in multiple
policies

Navigation: Security > Network Firewall > Rule Lists then click Create

| Name | geo_restrict_rule_list |

Security » Metwork Firewall : Rule Lists » New Rule List...

General Properties

MName | geo_resirict_rule_list

Description |

| Cancel || Repeat || Finished |

Navigation: Click Finished
Navigation: Click the geo_restrict_rule_list you just created
Navigation: Click Add

Name block_AF_CN_CA

Order First

Protocol | Any

Source Country/Region: AF,CN,CA
Action Drop

Logging | Enabled

Note: Leave all other fields using the default values.
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Navigation: Click repeat
Navigation: Click Add

Name permit_log
Order Last
Action Accept
Logging | Enabled

Create Permit Log Network Firewall Rule.

Note: Leave all other fields using the default values.

Navigation: Click Finished

Security » Network Firewall : Rule Lists » geo_restrict_rule_list

2 + | Properties
General Properties
Name: geo_restrict_rule_list
Partition f Path Common
Description
Update || Delete
. [[Searcn] I So 1l inati ] [Aad
| Name ‘ uuio | Description ‘ State ‘ Schedule ‘ Address/Region | Port ‘ Subscriver ‘ 'VLAN / Tunnel ‘ Zone ‘ ‘Address/Region ‘ Port ‘ Zone ‘ FProtocel ‘ Virual Server | iRule | Action ‘ Logging ‘ Service Policy
[ block_AF_CN_CA Enabled Alghanistan (AF) Any Any Any Any  Any Any Any  Any Drop Enabled
Canada (CA)
China (CN)
O pemit_log Enabled Any Any  Any Any Any  Any Any Any  Any Accept Enabled
Remove

Assign the geo_restrict_rule_list to the site1_policy

Navigation: Security > Network Firewall > Policies

Navigation: Click on site1_policy then click Add Rule List

In the name field start typing geo in the rule listfield. Select geo_restrict_rule_list
Navigation: Click Done Editing

Navigation: Click Commit Changes to System

Note: We want to validate the site is available before and after applying the Network Firewall Policy

From client machine try to connect again to the application site.
URL: https://site1.com

We will use Cywin Terminal for more controlled testing in

curl -k https://10.1.10.30/ —-H 'Host: sitel.com'
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sitel.com'
ed  Time i i Time Curremnt
D UpToad  Total
0 11954

sing wirt er sitel.com and pool member 10.1,20.11 (h
a http-equ ontent ‘htmly charset=us-ascii
kieLink'"7;

a http-equiv="pragma" content
cript language cript"” t

na

function ToadInfofl) {

SMLHTTR" )

Note: We want to validate the site is available before and after applying the Network Firewall Policy

Assign The Policy To The Virtual Server

A unique feature of the BIG-IP Firewall Module allows L3-4 security policies to be assigned specifically to
an application i.e. Virtual Server. So each application can have its own firewall policy separate from other
application virtual servers.

Apply the Network Firewall Policy to Virtual Server
Navigation: Local Traffic > Virtual Servers then click int_vip_www.site1.com_1.1.1.1
Navigation: Click on the Security Tab and select Policies

Edit the Network Firewall section of the screen

Virtual Server | int_vip_www.site1l.com_1.1.1.1
Enforcement | Enabled

Policy site1_policy
Log Profile enabled
Log Profile firewall_log_profile
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Local Traffic » Virtual Servers : Virtual Server List »» int_vip_www.site1.com_1.1.1.1

Security ~ | Statisfics (2]

Resources

# - | Properties

Policy Settings:

Log Profile

Firewall_log_profile

v o
W A,

global-network

Log all requests
Log illegal requests

- local-bot-defense

-

Destination 1.1.1.1:80
Service HTTP
Frotocol Security Disahled ¥
Enforcement: | Enabled.. ¥ |Foli :| site_palicy +]
Netwark Firewall [Enabied... ¥ |Policy
Staging: Disabled
' Use Device Policy
Metwork Address Translation ! Use Route Domain Policy
Polcy  Nore v
Maximum Bandwidth
Service Policy | None 4
Eviction Policy None \
IP Intelligence Disahled
DoS Protection Profile Disabled ¥
Application Cloud Security .
P Disabled ¥
Frotocol Inspection Profile Disahled ¥
Enabled... v
Selected Available
[Common i {Common -

Note: Leave all other fields using the default values.

Navigation: Click Update

From client machine validate the behavior of the Policy and the associated Rule List
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Many enterprise sites have some or all of their content served up by Content Delivery Networks (CDN).
This common use case leverages proxies to provide static content closer to the end client machines for
performance. Because of this there may only be one or two IP addresses connecting to the origin website.
The original IP address of the client in this case is often mapped to a common HTTP header X-Forwarded-
For or some variation. In this deployment, the BIG-IP can translate the original source of the request in the
XFF to the source IP address.

Use Cywin Terminal to allow us to specify the X-Forwarded-For header. . There is an iRule applied to
EXT_VIP_10_1 _10_30 which SNAT’s the source IP to match the X-Forwarded-For header

XFF-SNAT iRule

when HITP_REQUEST {
if {[HTTP::header exists "X-Forwarded-For"]} {
snat [HTTP::header X-Forwarded-For]
log localO. '[HTTP::header X-Forwarded-For]'
}
}

curl -k https://10.1.10.30/ -H 'Host: sitel.com'

Note: Since we did not define the header, the firewall will see the RFC-1918 address of the jimp host
(10.1.10.199)

URL.: https://site1.com

Use the -H option in curl to define the X-Forwarded-For Header. This will trigger the iRule addigned to the
External VIP to simulate specific IP addresses in the header

curl -k https://10.1.10.30/ —-H 'Host:sitel.com' -H 'X-Forwarded-For: 172.16.99.5"

Review the logs. each connection will log events from the external and internal virtual server
Navigation: Security > Event Logs > Network > Firewall

Next we will simulate a connection an IP address in Bejing, China

The BIG-IP Geolocation database is supplied by Digital Element

URL: http://www.digitalelement.com/

URL.: https://whatismyipaddress.com/ip/1.202.2.1 shows that this address is in Beijing , China

Note: You can check the geo classification of an address from the BIG-IP CLI using the command
geoip_lookup 1.202.2.1

curl -k https://10.1.10.30/ -H 'Host: sitel.com' -H 'X-Forwarded-For: 1.202.2.1'

This connection attempt will fail. Return to the BIG-IP GUI and refresh the firewall event log.

Note: you may need to zoom the browser to see the “Action” collumn at the right sie of the screen
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Create A Separate Policy For The site2 Virtual Server

Now we want to create a second policy for access to site2
Create Network Firewall Policy

Navigation: Security > Network Firewall > Policies, then click Create

Security » Network Firewall : Policies »» Mew Policy...

General Properties

Mame | siteZ_policy

Description |

| Cancel || Repeat || Finished |

Note: Leave all other fields using the default values.

Navigation: Click Finished

Modify the policy with rules to Allow TCP Port 80 From Host 172.16.99.5 Network Firewall Rule and deny
all other adresses . This time we will build the rules directly into the policy instead of using a Rule List

Navigation: Click on the site2_policy you just created
Navigation: Click Add Rule pull down on the upper right - Add rule at beginning

Name allow_site 172.16.99.5
Protocol | TCP (6)

Source Address: 172.16.99.5
Action Accept

Logging | Enabled

Security » Network Firewall : Policies »» /Common/site2_policy

5 + Aclive Rules Policies. Rule Lists Schedules IP Intelligence -

Unsaved changes to the policy!
One or more policy rules have been modified but not committed to the system. Changes must be committed to the system before taking effect
‘ Commit Changes to System ‘ ‘ Cancel Changes

General Properties

Name site2_policy
Partion Common
Description
[ Fiter Active Rules List M| Add Rule List j Add Rule j
Dane Editing [ Cancel |S13te ‘ Protocol ‘ Source ‘ Destination ‘Al:hms ‘ Logging
1 allow_site2_172.16.99.5 [Enabled [Tce v (Any) (Any) Action Logging
[Jauto Generate UUID 17216995 add new destination Add
iRule:
Descripfion None -
Send to Virtual
Service Policy:
None ~

Protocol Inspection Profile:
jone
Classification Policy

=z

<

=
]
2

<
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Note: Leave all other fields using the default values.

Navigation: Click Done Editing
Create Deny Log Network Firewall Rule
Navigation: Click Add Rule pull down on the upper right - Add rule at end

Note: As we are deployed in “ADC Mode” where the default action on a virtual server is ‘Accept’, we must
also create a default deny rule.

For further discussion of Firewall vs ADC modes, please consult the F5 BIG-IP documentation.

URL: https://support.f5.com/kb/en-us/products/big-ip-afm/manuals/product/
network-firewall-policies-implementations-13-0-0/8.html

Name deny_log
Action Drop
Logging | Enabled

Note: Leave all other fields using the default values.

Navigation: Click Done Editing

Security » Network Firewall : Policies » /Common/site2_policy

£ v | Actiy Policies Rule Lists Schedules IPInteligence
—
Unsaved changes to the policy!
QOne or more policy rules have been modified but not committed to the system. Changes must be committed to the system before taking effect.
‘ Commit Changes to System ‘ | Cancel Changes
General Properties
Name site2_policy
Partition Common
Description
[ Fiter Active Rules Lis T Add Ruie s | +| AddRue | < |
| D ‘ | Name |Slale ‘ Protocol ‘ Source | Desfination ‘ Actions ‘ Logging
—l 2.16.99.5 Enabled TCcP An An Accept Yes
Done Editing 1 Cancel J g &
2 deny_log Enabled v Any w (Any) (Any) Action: Logging
[ Auto Generate LUID add new source ‘ Add ‘ add new destination ‘ Add
Rule:
Description None ”
Send to Virtual:
Service Policy:
Protocol Inspection Profile
None v
Classification Policy.

Navigation Click Commit Changes To System
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Security » Network Firewall : Policies »» /Common/site2 policy

4 v Active Rules Policies Rule Lists Schedules [Pintgligence =

Unsaved changes to the policy!
(e or more policy rules have been modied but not commited fo the system. Changes must be commited o the system before taking effect

‘ Commit Changes to System | ‘ Cancel Changes ‘

General Properties

Name 52 policy

Partion Common

Destrpton ‘

e e s 1 AR Lt | iR
‘ID ‘ ‘Narne ‘State Profocal Source Destinafion ‘Adiuns ‘Logging

0t allow site? 172.16.99.5 Enabled TP Any Any Accept Ve

2 deny_log Enabled Any Any Any Drop Yes

Navigation: Click Finished

Apply the Network Firewall Policy to Virtual Server

Navigation: Local Traffic > Virtual Servers
Navigation: Click on int_vip_www.site2.com_2.2.2.2

Navigation: Select the Security Tab and select Policies

Virtual Server int_vip_www.site2.com_2.2.2.2
Network Firewall | Enabled

Policy site2_policy

Log Profile enabled

Log Profile firewall_log_profile

Note: Leave all other fields using the default values.

Navigation: Click Update
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Local Traffic » Virtual Servers : Virtual Server List :: int_vip_www.site2.com_2.2.2.2

Properties Resources Security = | Stafistics (=

E o JE

Policy Settings:

Destination 222280
Senvice HTTP
Protocol Security Dizabled -~

) Enforcement:| Enabled... - |Polic :| site2_policy Ivl
Network Firewall .
Staging: Dizabled ™~

[ ] use Device Policy
Metwork Address Translation [ | Use Route Domain Policy

Polcy[None '

Maximum Bandwidth
Service Policy | Mone | v|
Eviction Policy | None |
IF Intelligence Dizabled -~
DoS Protection Profile Disabled ~~
Application Cloud Security
R Dizabled =~
FProtocol Inspection Profile Dizabled -~
Enabled... ~
Selected Available
(Common -~ {Common o~
Log Profile Firewall_log_publisher Log all requests
Loqg illegal requests
global-network
r local-bot-defense

Note: Leave all other fields using the default values.

Navigation: Click Update

From client machine
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From client machine validate the behavior of the Policy and the associated Rule List

We will use Cywin Terminal to allow us to specify the source IP address. This is done by leveraging
an iRule which SNAT’s the source IP to match the X-Forwarded-For header. This iRule is applied to
EXT_VIP_10_1_10_30

’curl -k https://10.1.10.30/ -H 'Host:site2.com' -H 'X-Forwarded-For: 172.16.99.5"'

’curl -k https://10.1.10.30/ -H 'Host:site2.com' -H 'X-Forwarded-For: 172.16.99.7"'

Note: This is expected to fail

Note: This concludes Module 1 - Lab 4

2.1.5 Lab 5: Provide Firewall Security Policies For CDN Enabled Applications

Many enterprise sites have some or all of their content served up by Content Delivery Networks (CDN).
This common use case leverages proxies to provide static content closer to the end client machines for
performance. Because of this there may only be one or two IP addresses connecting to the origin website.
The original IP address of the client in this case is often mapped to a common HTTP header X-Forwarded-
For or some variation. In this deployment, the BIG-IP can translate the original source of the request in the
XFF to the source IP address.

In this case we are going to leverage iRules to modify the traffic coming from the CDN networks so we can
apply a firewall policy to it. The iRule to accomplish this is already installed on your BIG-IP and applied to
EXT_VIP_10_1_10_30. We have been leveraging it to run the tests in previous exercises

when HTTP_REQUEST {
if { [HTTP::header exists "X-Forwarded-For"] } {
snat [HTTP::header X-Forwarded-For]
log localO. [HTTP::header X-Forwarded-For]

}

Examminig the iRule we find that it is called when an HTTP request happens. It then checks to see if the
X-Forwarded-For header exists (We wouldn’'t want to SNAT to a non-existent IP address) and if it does
it modifies the source IP address of the request to the IP address provided in the header.

Verify that the iRule is assigned to the Virtual Server

Navigation: Local Traffic > Virtual Servers
Navigation: Click on the EXT_vIP_10.1.10.30 virtual server

Navigation: Click on the Resources tab
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Local Traffic » Virtual Servers : Virtual Server List »» EXT_VIP_10_1_10_30

#% ~ | Properties Resources Security « | Statistics @
1

Load Balancing

Default Pool pool_sitel.com v
Default Persistence Profile None v
Falloack Persistence Profile None v

Update
iRules Manage...

Name

fCommon/XFF-SNAT
Policies Manage...
Name

fCommon/HTTPS_Virtual_Targeting_Policy_L7V3

Navigation: Click on the Manage button

This is where you assign iRules

Navigation: Click on the Cancel button since the iRule is already assigned

Local Traffic » Virtual Servers : Virtual Server List » EXT _VIP_10.10.89.30

Properties Resources Security * | Statistics EJ|

o~

Resource Management

Enabled Available
ICommon Common
KXFF-SMAT _sys APM_ExchangeSupport_OA_BasicAuth
_sys APM_ExchangeSupport QA MtimAuth
_sys APM_ExchangeSupport_helper
_sys APM_ExchangeSupport_main

Cancel Finished

Validate SNAT Function

We tested functionality in prior exercises with the commands below. Leverage curl from the Cygwin Terminal
to insert the X-Forwarded-For header in to the request.
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curl -k https://10.1.10.30 -H 'Host: sitel.com' -H 'X-Forwarded-For: 1.202.2.1'

Expected Result: The site should be blocked by the geo_restrict_rule_list and generate a 403 Forbidden
response

Note: Optionally you can log into the CLI on the BIG-IP. Putty BIGIP_A —Uersname: root Password:
f5DEMOs4u Then tail -f /var/log/ltm. The iRule logs the SIP

Validate that requests sourced from the X-Forwarded-For IP address of 172.16.99.5 allowed.

curl -k https://10.1.10.30 -H 'Host:sitel.com' -H 'X-Forwarded-For: 172.16.99.5"'

Expected Result: Page will work

{

"web-app": {
"servlet": [
{
"servlet-name": "cofaxCDS",
"servlet—-class": "org.cofax.cds.CDSServlet",

Solve For TCP Issues With CDN Networks

The next step is to solve for the TCP connection issue with CDN providers. While we are provided the
originating client IP address, dropping or reseting the connection can be problematic for other users of the
application. This solution is accomplished via AFM iRules. The iRule is already provided for you. We need
to apply it to the Network Firewall downloads_policy Policy. It still is logged as a drop or reset in the firewall
logs. We allow it to be processed slightly further so that a Layer 7 response can be provided.

Navigation: Security > Network Firewall > Rule Lists
Navigation: Select geo_restrict_rule_list

Navigation: Select block_ AF_CN_CA

Navigation: Add the AFM_403_Downloads iRule to the rule list
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Security » Network Firewall : Rule Lists » geo_resirict_rule_list : block_ AF_CN_CA

Rule Properties

Mame
uuID
Partition / Path

Description
State

Protocol

Source

Destination

iRule

iRule Sampling

Action

Send to Virtual

Logging

Semvice FPolicy

Protocol Inspection Profile

Classification Policy

block_AF_CMN_CA

Auto Generate UUID

Commeon
Enabled v
Any v
Subscriber: Any v
Address/Region:| Specify... v
® Address ' Address List' ' Address Range
Afghanistan (AF)
Canada (CA)
China (CN)
Edit| Delete
VLAN / Tunnel: | Any T
Zone: Any T

Address/Region:| Any T
Zone: Any v

| AFM_403_Downloads v

Disahled »

Drop r

Mone A
Enabled »

Mone v

Mone v

Mone »

Blacklist Categories

Ci

. Update || Delete
Navigation Click Update

Validate that denied requests are now responded with a Layer 7 403 Error Page.

curl -k https://10.1.10.30/ —-H 'Host:sitel.com' -H 'X-Forwarded-For: 1.202.2.1"

Expected Result: Instead of the traffic getting dropped, a 403 error should be returned.

<html>
<head>
<title>403 Forbidden</title>
</head>
<body>

(continues on next page)
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(continued from previous page)

403 Forbidden Download of Cryptographic Software Is Restricted
</body>
</html>

Attention: Since a TCP solution could cause users to be blocked without explanation , the HTML error
response will traverse the CDN network back only to the originating client. Using a unique error code
such as 418 (I Am A Teapot) would allow you to determine that the webserver is likely not the source of
the response. It would also allow the CDN network providers to track these error codes. Try to find one
that has a sense of humor.

Note: This concludes Module 1 - Lab 5

2.1.6 Lab 6: Configure HTTP security

HTTP security profiles are used to apply basic HTTP security to a virtual server. Significantly more ad-
vanced HTTP security is available by adding ASM (Application Security Manager).

Configure An HTTP Security Profile And Apply It To The External Virtual Server.

On the BIG-IP:

Navigation: Security > Protocol Security > Security Profiles > HTTP, then click Create.

Profile Name demo_http_security
Custom Checked
Profile is case sensitive | Checked
HTTP Protocol Checks Check All
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Security » Protocol Security : Security Profiles : HTTP :» New HTTP Security Profile...

Profile Properties Custom L/
Profile Name demo_http_security I
Partition / Path Comman
FParent Profile ‘ http_security v
Prafile Description ‘
4
Profile is case sensitive | ¥ Enabled =
HTTF Protocol Checks | Request Checks Blocking Page
¥/ Header name with no header value %]
#| Several Content-Length headers 5]
#| Chunked request with Content-Length header 2]
#! Null in request headers 53]
#/ Null in request body 53]
#| POST request with Content-Length: 0 2]
¥ Body in GET or HEAD requests %2}
LTTP Protocal Ghecks #| Content length should be a positive number 5]
¥ Bad HTTP version «
1#! High ASCIl characters in headers 53]
¥ Host header contains IP address ]
|#| Unparsable request content 2]
¥/ Bad host header value %]
¥/ Check maximum number of headers | 20 %]
¥ Alarm v
I Block (%4}
Evasion Techniques Checks :f: ’;:ELT :::

Note: Leave all other fields using the default values.

Navigation: Click Request Checks Tab.

Note: Leave the defaut Methods. Changing Methods is a powerful way to protect your web sites

| File Types | Select All |
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Security » Protocol Security : Security Profiles : HTTP :: New HTTP Security Profile...

Profile Properties

Profile Name
Partition / Path

Parent Profile

Profile Description

Profile is case sensitive

HTTP Protocol Checks Ierquest Checksl Blocking Page

Length Checks

Methods

File Types

Mandatory Headers

Custom |
| demo_http_security |
Common
hitp_security v
2
¥ Enabled 5]
Custom ¥
URL length U Any '® Length;| 1024 bytes 4]
Query String length ') Any '®' Length:| 1024 bytes ¥
Request length ® Any O Length:| 0 bytes ]
POST data length '® any ' Length:| 0 bytes 4
1« Alarm 7]
) Block 74
Allowed: Available: %]
GET " ACL "
HEAD BCOPY |:|
POST BEDELETE
BMOVE
A BFROPFIND -
Method
#| Alarm 1«
) Block 73]
Define Disallowed v vl
Selected: Available:
asp - -
aspx
bmp D
cgi
£ss - v
File Type
I# Alarm ]
) Block [74]
Mandatary: Available: %]
- authorization "
cookie
referer
Mandatory Header Add
#| Alarm l#
) Block 73]

Navigation: Click Blocking Page Tab.

Response Type

Custom Response

Response Body

Insert “Please contact the helpdesk at x1234” as noted below
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ke S0

Security » Protocol Security : Security Profiles : HTTP :» HTTP Profile Properties
HTTP Profile Properties

Profile Properties

I Profile Name
Partition / Path

Parent Profile
Frofile Description

Profile is case sensitive

demo_http_security

Common

http_security v

Yes

HTTP Protocol Checks Request Checks

Response Type

Response Headers

Response Body

Custom

Blocking Page

Custom Response ¥

HITP/1.1 200 O
Cache-Controcl: no-cache
Pragma: no-cache
Connecticn: close

|Paste Default Response Header|

Upload File:| Choose File | Mo file chosen Upload

<html ><head><title>*Bequeat Rejected</titlex</head><bodvy>The requested URL

ig: «<3T5.request.ID{] > body>{ html>

Paste Default Response Body||Show.. |

| Cancel || Finished |

Note: Leave all other fields using the default values.

Navigation: Click Create

Note: We did not put the policy in Blocking mode. We will do that after we verify functionality

Apply the HTTP security profile to the external virtual server.

Navigation: Local Traffic > Virtual Servers > Virtual Server List >
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Navigation: Select EXT_VIP_10.1.10.30
Navigation: Select the Security tab

| Protocol Security | Enabled | demo_http_security |

Local Traffic » Virtual Servers : Virtual Server List » EXT VIP_10.10.89.30

7+ - | Properties Resources Security ~ | Statistics

.

Policy Settings: | Basic v

Destination 10.10.99.30:443
Service HTTPS
Application Security Palicy | Disabled %
i Enforcement:| Disabled &/
Metwork Firewall ——
Staging: | Disabled %
~ | Use Device Policy
Metwork Address Translation "~ | Use Route Domain Policy
Policy | Mone & |
IP Intelligence | Disabled &
CoS Protection Profile | Disabled &
Anti-Fraud Profile | Disabled 2|
| Enabled... &
Selected Available
ICommon ICommon
Log Profile firewall log profile e Log all requests
Log illegal requests
> global-netwark
local-dos
Update

Note: Leave all other fields using the default values.

Navigation: Click Update.
Open a new web browser tab, access the virtual server and log into the application.
URL: https://dvwa.com

Credentials: admin/password
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DVWA

Username

Password i
Logir

Note: This application is accessible, even though there are policy violations, because the “Block” option in
the HTTP security policy is not selected.

Browse the application.
Navigation: Click on various links on the sidebar.

o)

Welcome to Damn Vulnerable Web App!

Damn Vulnerable Web App (DVWA) is a PHP/MySQL web application that is damn vulnerable. Its main goals
are o be an aid for securily professionals to test thelr skills and tools in a legal envircnment, help web
Setup pers better the of securing web applications and aid teachers/students to
teach/leam web application security in a class roem environment

Instructions

Brute Force WARNING!
Crmmend Bt Damn Vuineable Vi App iscarmn winerabe! Do nof upoad 1 fo v hsiing providrs publ i oder o
CSRF any intemet facing web server as it il be ding and installing

onte a local machine inside your LAN which is used solely fDHEs\mg
Insecure CAPTCHA

" ’ Disclaimer
File Inclusion

SQL Injection We do nl take responsibilly for the way in which any one usss tis appication. We have mad the purposes of
clear and it should not be used maliciously. We have given wamings and taken measures to
SQL Injection (Blind) prevem users from installing DVWA on to live web servers. If your web server is compromised via an installation
of DVWA: it is not our responsibility it is the respensibility of the person/s who uploaded and installed it

Upload )

XSS reflected General Instructions

XSS stored The help button allews you te view hits/tips for each vulnerability and for each security level on their respective
page.

DVWA Security

PHP Info
You have logged in as "admin’

About

Logout

Username: admin
Security Level: low
PHPIDS: disabled

Note: This traffic will generate network firewall log entries because the Alarm option in the HTTP security
policy is selected.

On BIG-IP
Review the log entries created in the previous step.

Navigation: Security > Event Logs > Protocol > HTTP
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Security » Event Loy

£ - | Protocol - Des ~ | Logging Profiles

ul LastHour v |[Search| Custom Search... | Source I inati ]

< Time ‘ + Virtual Server ‘ + Profile Name ‘ + Address ‘ < Port ‘ + Gealocation ‘ < Address ‘ < Port ‘ + Route Domain ‘ + Description | + SupportID ‘ + Violation ‘ + Protocol ‘ + Request URI ‘ + Action
2015-07-11 163744 /Common/demo_htip_vs  /Commonidemo_htip_security ~ 192.166.1.10 49679 NA 192.468150 60 0 Host header contains IP address  315007152190128134  HTTP protocol compliance failed HTTP Jdwwalulnerabilities/sqli_blind/ ALARM
2015-07-1118:37:43  /Commonidemo_http_vs  /Commonidemo_http_security ~ 192.168.1.10 49878 NA 192.168150 80 O Host header contains IP address  315007152190128136 HTTP protocol compliance failed HTTP Jdwwalvulnerabilities/sali/ ALARM
2015-07-1116:3743  /Common/demo_http_vs  /Common/demo_http_security ~ 192.168.1.10 49677 NA 192.188.150 80 O Host header contains IP address  315007152190128137 HTTP protocol compliance failed HTTP Jdvwalvulnerabilities/captchal  ALARM
2015-07-1116:37:42  /Commonidemo_http_vs  /Commonidemo_htt_sacurity  192.168.1.10 49674 NA 192168150 80 0 Host header contains IP addrass  315007152190128134 HTTP protocol compliance falled HTTP Javwaivulnerabilifies i/ ALARM
2015-07-1116:37:42  /Common/demo_htp_vs  /Common/demo_htto_security  192.168.1.10 49671 NA 192168150 80 O Hostheader contains IP addrass  315007152190128135 HTTP protocol compliance falled HTTP Javwaivulnerabilities/csrt/ ALARM
201507-111637:41  /Common/demo_http_vs  /Common/demo_htip_security ~ 192.168.1.10 49670 NA 192168150 80 0 Host header contains IP address  315007152190128132 HTTP protocol compliance failed HTTP Javwalvulnerabilities/exec! ALARM
2016-07-1116:37:41  /Common/demo_htip_vs  /Common/demo_hito_security ~ 192.168.1.10 49669 NA 192188150 80 0 Hostheader contains IP address  315007152190128133 HTTP protocol compliance failed HTTP /dwwaiulnerabiliiesbrute/  ALARM
201507-1116:37:40  /Common/demo_htip_vs  /Commonidemo_http_security ~ 192.168.1.10 49668 NA 102168150 80 0 NA 315007152190128130llegal file type HTTP Jdwwaisetup php ALARM
201507-1116:37:40  /Commonidemo_htip_vs  /Common/demo_http_security ~ 102.168.1.10 49667 NA 102168150 80 0 Host header contains IP address  315007152190128131 HTTP protocol compliance failed HTTP Jdwwal ALARM
2015-07-11 16:37:40  [Common/demo_htip_vs  /Commonidemo_http_security ~ 182.168.1.10 49665 NA 192.468150 80 O Host header contains IP address  315007152190128430  HTTP protocol compliance failed HTTP Idwwalsetup php ALARM

Note:
same.

Your log entries may be different than the example shown above but the concept should be the

Edit the demo_http_security HTTP security profile.

Navigation: Security > Protocol Security > Security Profiles > HTTP

Navigation: Select the demo_http_security profile

Navigation: Select the Request Checks Tab

%~

Profile Properties

HTTP Profile Properties

Security » Protocol Security : Security Profiles : HTTP »; HTTP Profile

Properties

Profile Name
Partition / Path

Parent Profile

Profile Description

Profile is case sensitive

demo_hitp_security

Common

http_security ¥

Yes

HTTP Protocol Checks | Request Checks | Blocking Page

Custom

Methods

Length Checks

URL length

Query String length
Request length
POST data length

Any
Any
* Any
*) Any

#| Alarm

Block

Allowed:

GET
HEAD

Method|

¥ Alarm
¥/ Block

Define Disallowed ¥

Selected

® Length: | 1024
® Length: | 1024 bytes
Length: ID— bytes
Lengtn:[0 bytes

bytes

Available
- POST
OFTIONS
==
PUT
== | |DELETE
< TRACE

Available

LYRNCYRRC VALY

LAY

Y

asp
aspx
bmp
cgi
35

File Types

File Type

= I

Note: Leave all other fields using the default values.

Navigation: Click Finished.
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On Windows jumpbox

Close the Browser window to dvwa.com

Open a new web browser tab and access the virtual server.
URL: https://dvwa.com

Credentials: admin/password

Request Rejected > 4+

< (& 4 Mot secure dwera.com Sqaulnerabilities fexe c

255 Apps i bigip0Z (10.1.1.5) g biglo
The requested TTEL was rejected. Please contact the help deslk at 3123,

Feour supieort T is: FEFOTFER 150587686564

Attention: This action requires a “POST” action and will be blocked because this is not allowed.

Note: This is the end of Module 1 - Lab 6

2.1.7 Lab 7: Configure A Clone Pool For SSL Visibility To IDS Sensors Or Other
Security Tools

SSL encrypted traffic poses a problem for most security devices. The performance of those devices is
significantly impacted when trying to decrypt SSL traffic. Since the BIG-IP is designed to handle SSL traffic
with specialized hardware and optimized software libraries, it is in the unique position to ‘hand-off’ a copy
of the decrypted traffic to other devices.

In this solution, since the BIG-IP is terminating SSL on the external virtual server, when we forward the
traffic to the secondary virtual server in clear-text we have an opportunity to make an unencrypted copy of
the application traffic and send it to an external sensor such as an IDS for further security assessment.

On BIG-IP
Inspect the preconfigured IDS_Pool.
Navigation: Local Traffic > Pools > Pool List >

Navigation: Click on the Members Tab

Note: Unencrypted traffic will be forwarded to this IP address

Attach the IDS_Pool as a clone pool to the server side of the external virtual server
Navigation: Local Traffic > Virtual Servers > Virtual Server List > EXT_VIP_10_1_10_30.
Navigation: Select Advanced from the pulldown at the top of the Configuration section
Navigation: Scroll to the configuration for Clone Pool (Client) and select None

Navigation: Scroll to the configuration for Clone Pool (Server) and select IDS_pool
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Source Port Preserve
Clone Pool (Client) None
1
Clone Pool (Server) + None I
fCommon

Auto Last Hop

pool_www.mysite.com

Last Hop Poal pool_www.mysite.com-api |
pool_www.theirsite.com
HTTP Analytics Profile pool_www.yoursite.com \pplication

Navigation: Click on update at the bottom of the page.

Note: Leave all other fields using the default values.

Select the Putty application from the desktop on the jump host
Load Lamp Server from the sessions list

Open Lamp Server

Accept the certificate warning

login as 5

Attention: It will take about 30 seconds for the certificate login process- No password required

Input the TCPDUMP command to start capturing traffic

sudo tcpdump -i ethl -c 200 port 8081

Initiate another attempt to connect to the website via curl using the Cygwin application on the desktop.
Position windows on the desktop so that you can see both the Putty session and the Cygwin session

curl -k https://10.1.10.30:8081 -H 'Host:sitel.com' -H 'X-Forwarded-For: 172.16.99.5'

curl -k https://10.1.10.30:8081 -H 'Host:site3.com' -H 'X-Forwarded-For: 172.16.99.5'

Initiate another attempt to connect to the websites using the browser

https://site2.com:8081

https://sited.com:8081

View the tcpdump output on the syslog-webserver.

Attention: It will take about 20 seconds after the transaction to appear in the tcpdump session. This is
a performance problem on the lamp server
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tcpdump: verbose output suppressed, use -v or -vv for full protocol decode

listening on eth2, link-type EN1OMB (Ethernet), capture size 262144 bytes
17:25:42.585675 IP 10.10.99.222.50924 > 1.1.1.1.http: Flags [S], seqg 912073522, win_
—~4380, options [mss 1460, sackOK,eol], length 0

17:25:42.585905 IP 1.1.1.1.http > 10.10.99.222.50924: Flags [S.], seq 1263282834, ack,
912073523, win 4380, options [mss 1460,sackOK,eol], length O

17:25:42.585918 IP 10.10.99.222.50924 > 1.1.1.1.http: Flags [.], ack 1, win 4380,
—~length 0

17:25:42.585926 IP 10.10.99.222.50924 > 1.1.1.1.http: Flags [P.], seq 1:79, ack 1,
—win 4380, length 78

17:25:42.586750 IP 1.1.1.1.http > 10.10.99.222.50924: Flags [.], ack 79, win 4458,
—~length 0

17:25:42.673178 IP 1.1.1.1.http > 10.10.99.222.50924: Flags [P.], seq 1:252, ack 79,
—win 4458, length 251

17:25:42.673231 IP 10.10.99.222.50924 > 1.1.1.1.http: Flags [.], ack 252, win 4631,
—length 0

17:25:42.676360 IP 10.10.99.222.50924 > 1.1.1.1.http: Flags [F.], seq 79, ack 252,
—win 4631, length O

17:25:42.676972 IP 1.1.1.1.http > 10.10.99.222.50924: Flags [.], ack 80, win 4458,
—~length 0

17:25:42.688028 IP 1.1.1.1.http > 10.10.99.222.50924: Flags [F.], seq 252, ack 80,
—win 4458, length 0

17:25:42.688057 IP 10.10.99.222.50924 > 1.1.1.1.http: Flags [.], ack 253, win 4631,
—~length O

Note: Inspect the source and destination addresses. This traffic is cloned from the EXT_VIP

Note: This is the end of Module 1 - Lab 7.

2.2 Module 2: F5 Dynamic Firewall Rules With iRules LX

This lab introduces iRules Language eXtensions (LX) or iRulesLX which enables node.js on the BIG-IP
platform. The lab uses Tcl iRules and JavaScript code to make a MySQL call to look up a client IP address
providing access control in the Multi-Layered Firewall.

This could be useful in developer driven / devops environments where the development team can modify
firewall policies simply by updating a database.

Warning: IP addresses in screenshots are examples only. Please read the step-by-step lab instructions
to ensure that you use the correct IP addresses.

2.2.1 AFM with iRules LX

Estimated completion time: 15 minutes

Beginning in TMOS 12.1 BIGIP offers iRules LX which is a node.js extension to iRules IRules LX does not
replace iRules, rather allows iRules to offer additional functionality. In this lab you see how iRules LX can
be used to look up client ip addresses that should be disallowed by AFM.
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Note: You do not need skills or knowledge of iRules LX to do this lab. This lab will not go into detail on
iRules LX nor will it go into detail on Node.JS, rather, this lab shows an application of this with AFM.

Note: We are using a different set of IP subnets just for this module, as shown in this network diagram:

Win7 Client: \S: 192.168.1.51
192.168.1.10 ot 80 BIG-P
IRules LX { node.JS )

Pool
172.1.1.10: 80

MySQL Server:
host :'172.1.1.10',
user :'root|
password : ‘Agility’,
database : ‘afmsourceip’

Note: You should be comfortable creating pools and virtual servers by now. Therefore, the following steps
to create pools, virtual servers, and AFM policies are kept brief and to the point.

Create the Pool and VS

1. Create a pool named afmmysql_pool with one pool member ip address 172.1.1.10 and port 80, and

a tcp half-open monitor. Leave all other values default.

2. Create a TCP VS named afmmysql_vs with a destination address of 192.168.1.51, port 80, snat
Automap, and set it to use the afmmysql_pool pool. Leave all other values default.

Test the Virtual Server

On the Win7 client, use curl in the cygwin cli ( or from the c:\curl directory in a windows command line shell

) to test the Virtual Server.
curl http://192.168.1.51 —-—-connect-timeout 5

You will notice that you connect, and web page is shown.

= Command Prompt

ncurlicurl hitp:r-192_168.1.51 ——connect—timeout 5

=

m|»

$DOCTYPE html PUBLIC “---W3C//DID EHTHL 1.8 TransitionalrssEN" “http:/swuww.uwd . org/TR/xhtmll-DTD/xhtmli-transitional.dtd">

html xmlns="http:/~wuw._wl org,1999 xhtml">
[
Modified from the Debian original for Ubuntu
Lagt updated: 2014-03-19
See: https://launchpad.net/bugs-1288698
<head>
{meta http-equiv="Content-Type" content="text html; charset=UTF-8'" />

<{title>Apache2 Ubuntu Default Page: It works<{/title’
{ztyle type="textrsces" media=""screen">
= {
margin: Bpx Bpx Bpx Bpx;
padding: Bpx Bpx Bpx Bpx;

2.2. Module 2: F5 Dynamic Firewall Rules With iRules LX
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Copy & Paste LX Code

Note: Dont’ worry, you're not doing any coding here today. Just a little copy and paste excersize. You are
going to copy two files from the Windows desktop and paste them into the iRules LX workspace.

1.

o o

8.

Navigate: In the BIG-IP webgui, navigate to Local Traffic->iRules-> LX Workspaces-> ir-
ules_Ix_mysql_workspace

Open the mysql_iRulesLx.txt file in Notepad ( located on the Windows Desktop) and copy ( Ctrl-C or
use Mouse ) the entire contents

In the Big-IP webgui, Click on rules->mysql_irulelx
Replace the contents of this with the text you just copied from the mysql_irulesLx.txt file.
Click “Save File”

In Windows, open the index.js file located on the Desktop ( it should open in NotePad ), select all, and
copy ( Ctrl-C or use Mouse ) its entire contents.

In the Big-IP gui, click on mysqgl_extension/index.js. Replace the contents of mysql_extension/index.js
with the contents of the index.js that you just copied.

Click “Save File”

Local Traffic » iRules: LX Workspaces » irules_lx_mysql_workspace

General Properties

MNarmne irules_lx_mysgl_wiorkspace
Fartition / Fath Commaon

Mode js Yersion B.9.1 (default] v
Workspace Files «| Editor

4 —rules

Over-write with contents of

1 mysgl_irulelk
— mysgl_iRuleslyx.txt

4 —mysgl_extension

[@index.js

Jnode modules contents of index.js
0 package json

Over-write with

Create LX Plug-In

1.

2.

Navigate: to Local Traffic->iRules-> LX Plugins and create a new LX Plugin named “afmmysqlplug”
using the workspace (From Workspace dropdown) irules_Ix_mysql_workspace.

Click “Finished”
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Local Traffic » iRules :LX Plugins » Mew Plugin...

General Properties

MNarme | afmmysglplug
Description
‘ Log Publisher Mone v
I From YWarkspace MNone M
— Mone
| Cancel || Hepeat || Finished ICommon

irules k< mysgl workspace

Create a new AFM Policy to use this LX Rule

Note: You are assumed to be pretty familiar with creating AFM policies by now, hence the following steps
are kept brief and to the point.

1. Create a new AFM policy named afmmysql_pol
2. Add a rule named afmmysql_rule and click iRule to assign the “mysql_lIrulelx” iRule.
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Security »» Network Firewall : Policies »» afmmysqgl_pol : afmmysqgl_rule

Rule Properties
MName afmmysqgl_rule

Partition / Path Common

Description |

Type [Rue_[v]

State [Enabled  [v]

Protocal [Any v

Address/Hegion |.'!-.n,-' K |
VLAN / Tunnel I.l"'J'I]-' W |

Destinabion Address/Fegion |.-!-.n y i |

Source

IHule | mysql_iruled: ﬂ
iRule Sampling [Disabled|v]

Action |Accept [v]
Logging | Disabled | v |
senice Policy |h-'ur:r:! *-'I

' Update || Delete |

3. Click “Finished”

4. Assign this rule to the afmmysql_vs virtual server.

Test the VS with the LX Rule in Place

On the Win7 client, use curl in the cygwin cli ( or from c:\curl directory in a windows command line shell ) to
test that the client is being blocked, as the Win7 client’s ip is in the mysql database.

curl http://192.168.1.51 —--connect-timeout 5

If everything went successfull, this should now timeout.
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Attention: Ensure that the iRule is working properly, by going back to the AFM rule and setting the

iRule back to None. Also examine the log files at /var/1og/1tm on the BIG-Ip ( or look in the GUI Log
as shown here )

System » Logs : Local Traffic

Packet Filter Lacal Traffic

rity | Audit « | Configuration -

Rl ]
~ Timestamp < Log Level ‘ + Host + Service + Status Code | = Event
Mon Jul 16 12:09:12 PDT 2018 infa afrn-advanced  trm2[12766] Rule iCommondafrmysalplug/mysol_irulel: <FLOW_INIT=: Equal
Mon Jul 16 16:08:12 PDT 2018 info afm-advanced  trnm2[12766] Rule fCommondafmmysglplug/mysgl_irulebc <FLOWY_INIT=: Looked up: 192.168.1.10
Mon Jul 16 16:08:12 PDT 2018 info afm-advanced  trnm2[12766] Rule fCommonfafmmysglplug/mysgl_irulebc <FLOW_INT=: $rpc_response: 182.168.1.10
Mon Jul 16 15:09:12 PDT 2018 info afm-advanced  sdmd[B013] 018e0017 ‘;31\3[24323]1;3\:[3\;[anmmnn/afmmysqlplug mysgl_extension] First row from MySQL is: RowDataPacket { id: 1, ip!
Maon Jul 16 15:08:12 PDT 2018 info afrn-advanced  sdmd[B013] 018e0017 pid[4354] plugin[fCornmantafrmmysdlplug mysol_extension] Connected to MySQL as 1D 3
Mon Jul 16 12:09:12 PDT 2018 info afrm-advanced sdmd[B013] 018e0017 pid[4354] pluginfCommon/afmmysglplug. mysgl_extension] [ '192.168.1.10']
Mon Jul 16 16:08:12 PDT 2018 info afm-advanced tm2[12766] Rule fCommonafmmysglplug/mysgl_iruleks <FLOW_INT=: $RFC_HANDLE: /Cormmanfafmmysglplug:mysgl_extension

Note: This completes Module 3 - Lab 1

2.3 Module 3: AFM Protocol Inspection IPS

In this lab you will explore the new Intrusion Prevention System feature in 13.1.X, which is called Protocol
Inspection.

Protocol Inspection includes Compliance Checks and Signatures. This lab will introduce both, including a
section on writing custom Signatures.

2.3.1 Lab 1: Preconditions

Estimated completion time: 15 minutes

Diagram for Module 4:
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Management Subnet

192.168.3.0/24

Windows Box ) BIG-IP Q Linux Box
° T ® s
o a
10.10.99.0/24 10.10.121.0/24
Client Subnet Server Subnet
10.10.99.222 Self-IP: 10.10.99.10 Self-IP: 10.10.121.10 10.10.121.131-140

There are some steps we need to complete to get the system to work as expected. We're going to get more
feedback if we enable logging.

Task 1: Enable Logging for Inspections

1. Navigate to Security > Event Logs > Logging Profiles > global-network
2. Enable Protocol Inspection

3. Click the Protocol Inspection tab and select Publisher ‘local-db-publisher’
4. Click ‘Update’
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Security »» Event Logs - Logging Profiles
¥ - Edit Logging Profile

»» Edit Logging Profile

Logging Profile Properties

Profile Name global-network
Partition / Path Common
Description Default logging profile for network events
Application Security Enabled
Protocol Security + Enabled
Network Firewall “ Enabled
Network Address Translation Enabled
DoS Protection Enabled

Bot Defense E

[ Protocol Inspection ' Enabled

~Classimication ~"Enabled
Protocol Security MNetwork Firewall | Protocol Inspection
Protocol Inspection

Publisher local-db-publisher v
Log Packet Payload " Enabled

Note: This completes Module 4 - Lab 1

2.3.2 Lab 2: Protocol Inspection - Compliance Checks

Estimated completion time: Thirty Five 35 minutes

Compliance Checks model protocols and applications and flag deviations from the model. End users can’t
add compliance checks, but some of them have parameters the user can modify. We’ll look at a couple of
these checks and modify one. Have fun!

Task 1: The Inspection Profile

You will create an Inspection Profile containing compliance checks.
1. Navigate to Security > Protocol Security > Inspection Profiles and click ‘Add’, select ‘New’
2. Name the profile ‘my-inspection-profile’

3. Disable Signatures
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4. Make sure Compliance is enabled.
5. Under Services, Select HTTP.

Note: You have to wait a few seconds after selecting HTTP

Security »» Protocol Security : Inspection Profiles .. New Profile_..

g Unsaved changes to the Profile!
Profile has been modified but not committed to the system. Changes must be committed to the system before taking effect.

| Commit Changes to System | Cancel

General Properties
Profile Name

Disabled w

[Enabled ¥ |
Enabled w

1k

DHCP OTHER
DIAMETER POP3
_DMS RADIUS
FTP | 1P

SMTFP

HTTP | sNMP
T imar SSH

IRC S5

MaTT SUNRPC
— MYSQL TELNET

NETBIOS_NS | TFTP

NETBIOS_SSN WINS

NNTP

6. When the HTTP Service appears, click to open the Inspection list for HTTP, and select Inspection
Type ‘compliance’
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T N

Services 1 selected =
Service Protocol
Description, IE) References, Attack Type w - - - -
Inspection Type State Risk Accuracy Performace Impact
1 selected = —= = -— = -— = -— =
-~ signature
| compliance
- ar All x )
HITE
[+#] ‘ < ID ‘ < Description = Type I < Attack Type < State
#| 11011 Bad Http Version compliance Disable
[« 11000 Contains Colon compliance Disable
« 11003 Content-Length And Transfer Encoding Headers compliance Disable
I« 11017 Disallowed Methods compliance Disable
«| 11002 Duplicate Header Name compliance Disable
I« 11015 Empty Value compliance Disable
# 11014 Invalid Method compliance Disable
I« 11019 Maiformed Header Value Contents compliance Disable
- 11016 Malformed Hitp Pdu compliance Disable
I« 11013 Max Allowed Headers Request compliance Disable
«| 11007 Mo Host Header compliance Disable
#/ 11018 Non CRLF Line Break compliance Disable
«| 11009 PostWith Zero Content Length compliance Disable
I« 11008 Post Without Content-Length or Transfer-Encoding.. compliance Disable
~| 11004 Recursive Url Encoding compliance Disable
I« 11020 Response With No Content-Length And Transfer Enc... compliance Disable
4 >
7. Click the checkbox to select all the HTTP compliance checks.
8. In the edit window in the upper-right of the F5 GUI, make the following selections:
» Enable the selected inspections
» Set the ‘Action’ to ‘Accept’
» Enable logging
Note: These should be the default actions, so they most likely are already set for you.
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Edet Inspectons

Edit Selected Enable w

Inspections
Action:
Accept v

— Log:.
Yes v

« Click ‘Apply’
9. Click ‘Commit Changes to Systenm’

You should now have an Inspection Policy.

Task 2: Apply the Profile to the Global Policy

Navigate to Security > Network Firewall > Active Rules
Change Context to ‘Global’

Click ‘Add Rule’

Make a new policy named ‘global-fw-policy’

Make a new rule named fw-global-http-inspection’

o 0 bk 0wp o~

Configure the new rule:
 Protocol ‘TCP’
» Set the Destination port to 80
* Action ‘Accept’
* Protocol Inspection Profile: ‘my-inspection-profile’
» Enable logging
7. Click Save
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General Properties

Context

Folicy Type

I Falicy

Rule Properties

I Marrme

Description
Order

Type

State

Protocol

Source

Destination

iRule

Action

=end to Virtual
Logging
Serice Policy

Frotocal Inspection Profile

Glohal ¥

Enforced *

ey ¥ | Mame: | global-fw-palicy

fwe-global-http-inspection

Last r
Fule r
Enabled v

TCF Y| b

subscriber: Any v
Address/Region: | Any ¥
Faort: Any v
WLAMN S Tunnel: | Any v

Address/Region: | Any v

Fort: Specify.. ¥
& Port * ' Port Range
| Add
a0
Edit| |Delete

Mone

Accept v

Mone

Enabled -

Mone ¥

my-inspection-prafile v

Port List

2.3. Module 3: AFM Protocol Inspection IPS

151



F5 Firewall Solutions Documentation

Task 2.5: Create testing Virtual server on port 80

To get an understanding of how the IPS function works, we need the manual commands we can issue via
Telnet. Because Telnet does not work very well with SSL, we need to create a virtual server on port 80
instead of the one on 443 that we have been using so far. Remember this is only for testing, and the IPS
functionality can work perfectly well on encrypted traffic ( as long as we terminate the SSL )

1. Check if the pool “pool_www.mysite.com” exists. Does it already exist? Only if it does not exist, please
create it as follows:

Name Health Monitor | Members Service Port
pool_www.mysite.com | tcp_half_open 10.10.121.129 | 80

2. Create a virtual server with no HTTP profile. Use the following settings, leave everything else default.

Parameter Value

name IPS_VS

IP Address 10.10.99.40

Service Port | 80

SNAT automap

Pool pool_www.mysite.com

Note: Note that we neither applied an Inspection Policy to this VS, nor did you apply a Firewall Policy to
this VS. And yet, the IPS is now functional on this VS. Can you think why this is? This is because the global
firewall policy is in affect, and the Inspection Policy will be invoked by the Global Firewall Policy.

Task 3: Test the Inspection Profile

1. From the Cygwin session, or from the DOS prompt, enter this command:

telnet 10.10.99.40 80

The expected output is:

Trying 10.10.99.40...
Connected to 10.10.99.40
Escape character is '"7]'.

Enter the following ( Suggestion: copy and paste ):

GET /index.html HTTP/5

(hit Enter key two times)

The expected HTTP response is:

HTTP/1.1 200 OK
( and lots more HTTP headers, etc.)

2. Check the results.
» Navigate to Security > Protocol Security > Inspection Profiles > my-inspectionprofile

« Filter for Inspection Type ‘compliance’
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* Look at the Total Hit Count for HTTP Compliance Check ID 11011 “Bad HTTP Version.” We expect to
see a hit count of at least 1, and a missing host header count of at least 1.

* Look at the protocol inspection logs. Go to Security > Protocol Security > Inspection Logs. You can
see the incoming ip address and port, among other things.

General Properties

| Profiepame my-inspection-profie
Deseription
Signatures Disabled ¥
Compliance Enabled ¥
AVR Stats Collect Enabled v
Serices Toelesied &
Senvice Pratacal Inspection Type State Risk Accuracy Performace Impact  Add Filter
Description, D, References, AtackType V| | - ¢ [ :  foelected ® — s |- s |- s [ + .
Inspection Type:
“compliance % | ( ClearAll % ) signature
1| @ compliance
HTTR
vl [+ Description Tioe Altack Type State Risk Accuracy Action Log Protocol User Defined Total Hit Count
101 Bad Hitp Version compliance Enable medium low accept yes tep no 1
11000 contais Colon compliance Enable  medum  low accent ves e no 0
11003 GontentLengih And Transfer Encoding Headers compliance Enable  medum  low accent ves te no 0
017 Disallowed Wethods compliance Enable  medum  low accept yes top no o
11002 Duplieate Header Name compliance Enable  medum  low acrent vee e no 0
1015 Emptyvalus compliance Enable  medum  low accent ves tt no 0
014 Invalid Method compliance Enable  medum  low accent ves ten no o
11019 Malformed Header Value Contents compliance Enable medium low accept yes tep no 0
1016 Malformed Hito Pdu compliance Enable  medum  low acrent vee e no 0
1013 MaxAllowed Headers Request compliance Enable  medum  low aceept ves ten no 0
007 No Host Header compliance Enable  medum  low accept yes top no 1

Security » Protocol Security : Inspection Logs

it~

F LastHour ¥ ||Search| Custom Search

|Search] Inspection
Time Action D+ Name Risk | + Acsuracy | + Service ACL Palicy AGL Ruls Name Virtual Server Inspection Profil P Port
2018-06-13 14:42:10 accept 11007 NoHostHeader  medium low ic i pol lobal-htip-inspection (Commankvs_IPS_10.10.99.40 fCommonimy-inspection-profile 10.10.98.22% 50423
2016-08-13 14:42:10 accept 1011 Bad Hitp Version  medium low i K pol lohal-htip-inspestion Commankvs_IPS_10.10.89.40 /Commonims-inspection-profile 101098222 50423
2016-06-13 14:41:04 accept 11016 Malformed Hitp Pdu medium low ic i JCommenis_IPS_10.10.99.40 fCommonimy-inspection-profile 10.10.89.227 50383
2016-06-13 14:26:25 accept 11007 NoHostHeader  medium low ic i pol lobal-htip-inspection (Commanks_IPS_10.10.99.40 /Commonimy-inspection-profile 101099222 50153
2016-08-13 14:26:24 accept 1011 Bad Hitp Version  medium low i K pol lohal-htip-inspestion Commanks_IPS_10.10.89.40 fCommonims-inspection-profile 10.1098.222 50153

Task 4: Modify a Compliance Check

1. Select Compliance Check 11017 ‘Disallowed Methods’
2. Enter the value “Head” and click ‘Add’
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Properties

11017 Enahle ¥

Description:
Disallowed Methods

Documentation:

Disallowed Methods. The compliance violation
will be raised if method (case insensitive) is one
of configured methods.

Action:
Feject ¥

Lodg:
Yeg ¥

Yalue;
Head

Enter String Add

| Zlose |

3. Click ‘Commit Changes to Systen’

Task 5: Test the Modified Compliance Check

1. From the Cygwin session, enter (or copy and paste) this command:

telnet 10.10.99.40 80

The expected output is:

Trying 10.10.99.40...
Connected to 10.10.99.40
Escape character is '"*]'.

Enter the following ( Suggestion: copy and paste ):

HEAD /index.html HTTP/1.1

Expected output:
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HTTP/1.1 400 Bad Request

2. Check the results.

Note: Just an interesting point to make again, this is the IPS code checking HTTP, not the HTTP Profile (
This VS does not have an HTTP Profile )

Navigate to Security > Protocol Security > Inspection Profiles > my-inspection-profile

Filter for Inspection Type ‘compliance’

Look at the Total Hit Count for HTTP Compliance Check ID 11017 “Disallowed Methods.” You may
have to refresh the page.

» We expect to see a hit count of 1.

4. Look at the stats. Enter the following command on the Big-IP command line:

tmsh show sec proto profile my-inspection-profile

We expect to see a Hit Count of at least 1 (more if you've done it multiple times).

rofile my-in

11011
11016
11017

alone] config # I

Note: This completes Module 4 - Lab 2

2.3.3 Lab 3: Protocol Inspection - Signatures

Estimated completion time: Five 5 minutes

Signature Checks can be written by the user, unlike Compliance Checks which are programmatic inspec-
tions provided only by F5. We'll start with a lab procedure that explores the use of the provided signatures.

Task 1: Enabling Signatures

1. Navigate to Security > Protocol Security > Inspection Profiles > my-inspection-profile

2. Enable Signatures
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Security » Protocol Security : Inspection Profiles »» /Common/my-inspection-profile

General Properties
I Profile Name my-inspection-profile
Description ‘
Signaturss Disabled v
Compliance Enabled k
AVR Stats Collect
Dicabled
Services evieeen | ®

3. Click ‘Commit Changes to Systen’
4. Now enable an individual signature
5. Filter on Service ‘HTTP’, Inspection Type ‘signature’

6. Sort the filtered signatures in reverse order of ID. Click the ID column twice.
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Service Protocol Inspection Type State
Description, 1D, References, Aftack Type T 1selected = == = 1celected = -
Service: Inspection Type:
HTTP % ) ( signature % ( Clear All % )
HTTP
[]
v v m@ = Descripti + Type < Aftack Type
1000015 Curl connedgion signature
- 100025 checks if qubtes can be used for content signature
100015 custom Morfeus signature
100005 distance check signature
100004 Hemant 2 signature
100003 emailed 10/26 16:17 signature
100001 stops fraffic on tcp port 80 signature  tcp
100000 checks for requests for cat gif signature  cat gifs
2590 MALWARE-CNC Win Trojan Locky variant outbound co.. signature  frojan-activity
2589 MALWARE-CNC Win.Trojan Dridex dropper variant ou... signature  trojan-activity
2588 MALWARE-CNC Win.Trojan.Vawtrak variant outbound ... signature  trojan-activity

c¢. Scroll down to 2538 and click to edit.
d. Configure the signature:

i. Enable

ii. Action: Reject

ii. Log: Yes

iv. Click ‘Close’

v. Click ‘Commit Changes to System’

You should now have an enabled HTTP signature. We don’t know exactly what it’s checking for, but
we’ll get to that in the next Procedure.

Task 2: Reviewing the actual pattern check
The Ul currently doesn’t give you the exact pattern being checked for in a Signature. We will search the file
where the default signatures are defined and review the one with signature id 2538.
1. From the BIG-IP command line, enter the following command:
grep 2538 /defaults/ips_snort_signatures.txt
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The expected output is:

alert tcp any any -> any any (content:”’User-Agent|3A 20|Vitruvian”; fast_pattern:only; http_header;
sig_id:2538;)

The Signature is looking for TCP traffic with http_header contents “User-Agent: Vitruvian”

Task 3: Test the Signature

1. From the Desktop terminal, issue the following command:
curl -A Vitruvian http://10.10.99.40/cat.gif
This uses curl which you area already familiar with, and specifies the USER-AGENT = “Vitruvian”
The expected output is:
curl: (56) Recyv failure: Connection reset by peer

2. Check the results: refresh the Inspection Profiles page, filter as needed, sort as needed, and review
the Total Hit Count for Signature 1D 2538.

3. Since that is a pain, use the BIG-IP command line:
tmsh show sec proto profile my-inspection-profile
We expect to see a Hit Count of 1 for Inspection ID 2538.

This was a simple test of a simple pattern match. There are some tricks to testing signatures with more
elaborate patterns, which we’ll explore in the final lab.

Note: This completes Module 4 - Lab 3

2.3.4 Lab 4: Protocol Inspection - Custom Signatures

Estimated completion time: 15 minutes

You can write custom signatures using a subset of the Snort® rules language. We'll walk through a couple
of examples, but the intent is not to make you an expert. At most we can give you a head start in developing
expertise. We’'ll start with a scenario: we want to detect sessions requesting a particular URI, /images/cat.gif
where the User-Agent is “Attack-Bot-2000” When working with signatures, keep in mind there are just under
1600 signatures shipping with 13.1.0. It will be easier to work with custom signatures if you add a filter for
them.

Task 1: Set Filter

1. Edit the Inspection Profile ‘my-inspection-profile’ Click ‘Add Filter’ and select ‘User Defined’

2. When the User Defined filter is added, select ‘yes’
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Security » Protcol Security : Inspection Profiles . \Comman/my-Inspaction-profile

General Proparties
I Prafiie Hame my-inspection-pecfile

Deescriglion

Signatures Enabled v
Compliance Enabled
AVR Stats Collect Enabled v

Services 1selecled  #

Sarvice Protocsl Inspection Type State Risk Accuracy Porformace impac!  Add Filter

T & & ) & & ) )

o Service # Accuracy

# Protocol # Perfermace Impact
# Inspection Type . Liser Defined
# State Nf\:.cn

Coraction Log
! Risk

Task 2: Cargo Cult Signature Authoring - finding an example to copy

It's often more pragmatic to modify an example that is close to what we want than to start from scratch.
Let’s start with a very simple example.

From the BIG-IP command line, issue the following command:

grep 1189 /defaults/ips_snort_signatures.txt

Expected output:

alert tcp any any -> any any (content:”/rksh”; fast_pattern:only; http_uri; sig_id:1189;)

Parsing this, there is a Header section and an Options section. The Header is the stuff outside the paren-
thesis:

alert means “match” or “do something.” The BIG-IP/AFM Inspection Policy will actually determine what is
done with a packet that matches a signature, so it doesn’t matter which action you choose. For the greatest
clarity, standardize on “alert” so you don’t confuse others or yourself.

tcp is the L4 protocol. The Signature has a Protocol setting outside the signature definition. They should
probably agree, don’t you think?

any any -> any any means “FROM any source IP+port TO any destination IP+port.” We will tighten this up
in a later lab procedure. Note that the signature has its own direction outside the signature definition. We
probably want to avoid a conflict between these direction settings.

The Options are the elements inside the parenthesis. Each option is a Type: value pair, separated by a
colon. Each Option is separated by a semicolon. The options in this example are:

» content - This is the pattern to match, in this case “/rksh.”

» fast_pattern - applies to the previous content definition. It's intended to be used to prequalify a rule
for further processing. If you have a bunch of expensive content checks, you can look for one char-
acteristic string to see if you need to bother with the others. In this example the effective meaning is
“If you see this, look into the other content to see if we match” but there’s no other content! The key
takeaway is that the rules provided are not optimized. We'll try to do better when we create our own.

* http_uri - also applies to the previous content definition. It restricts the search to the HTTP Uniform
Resource Identifier.

* sig_id - the signature id
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Task 3: Adapting our example in creating a custom signature

We're going to run into a problem that stems from MCPD parsing the contents of /de-
faults/ips_snort_signatures.txt differently than the Ul parses custom signatures.

1. Create a new custom signature. Navigate to Security > Protocol Security > Inspection List and click
“New Signature”

Security : Inspechion List

= | Profiles Assignment =  Inspection Profles | Inspeclion List nspecion Logs

Servica Fratcal Inspecton Type  Risk Accuracy Ferformace Impact  Add Filter
— s

Description, 1D, References, Attack Type T — 8 — 0 — % — & — & s

ARE] o] ¢ Description ° Senice & Type o Aftack Type & Rigk o ACCUIECY © Acon | ¢ Lag | ¢ Protd

Mew Signaturs iz Deing craghed

distance check HTTF signature oo herm accepl WES any
Hemarit 2 HTTF signature lows o accept yes any
Curl connaction HTTP signaturg - high accepd b any
ehecks actions OTHER signafure Iewie ke accepl yes any

2. Enter the following:

a.Name - this is an odd field in that it doesn’t show up in the Signatures page but it is the object name in the
config.

Enter “no cat gif”

b. Description - this does show up in the Signatures page, Event Logs, tmsh show output, etc. Make it
descriptive, systematic, and concise. Enter “HTTP cat.gif request”

c. Signature Definition - here’s the big one. Based on our example, enter:
alert tcp any any -> any 80 (content:cat.gif;http_uri; sig_id:100000;)
This simply swaps the content URI string to match and provides a new signature ID.
d. Click “Create.” We expect configuration validation to succeed.
From the Signatures page, open your new signature up for editing to add the rest of the signature elements.
e. Direction: to Server (agreeing with our signature definition)
f. Protocol: TCP (agreeing with our signature definition)
g. Attack type - “cat gifs”
h. Service - select HTTP
i. Click “Save”
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Properties

Marme®:
not cat gif

Description™®:

Signature Definition™:

alerttcp any any -= any 80 (content.cat.gifhttp_uri;
Sig_id:100000:)

Action:
accept ¥

Log:
yves ¥

ACcuracy:
Oty ¥

Direction:
to-server ¥

FPerformance Impact:
[ oty v

Frotocol:
fcp r

Risk:
[ ¥

Cocumentation:
Enter Documentation
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3. Add this signature to the Inspection Profile my-inspection-profile
» Navigate to Security > Protocol Security > Inspection Profiles > my-inspectionprofile

+ Select your new signature, 100000, and when the “Edit Inspections” window pops open, set “Action”
to “Reject” and click “Apply” (“Enable” and Log: Yes are selected by default.)

General Properties

I Profile Mame fry-inspection-prafile

Description

Signatures Enabled

caompliance Enabled

AR Stats Collect Enabled ¥

Services 1 selected =

Sefrvice F

loooo L =

Propertie=

100000 Enahle ¥

Description:
no cat gif

Action:
Feject ¥

Log:
fes ¥

| Close |

c. Click “Commit Changes to Profile”
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4. Test it out.

a. From the Desktop terminal, use the following command:
curl -A test http://10.10.99.40/cat.qgif

b. Check stats. From the BIG-IP command line:
tmsh show sec proto profile my-inspection-profile

We expect to see a Hit Count of 1 for Inspection ID 100000.

Hit Time

Note: This completes Module 4 - Lab 4
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Class - F5 BIG-IP DDoS and DNS DoS Protections

This class covers the following topics:
+ Detecting and Preventing DNS DoS Attacks on a Virtual Server
» Detecting and Preventing System DoS and DDoS Attacks

Expected time to complete: 2 hours

3.1 Module 1 — Detecting and Preventing DNS DoS Attacks on a Vir-
tual Server

In this section of the lab, we’ll configure the steps necessary to ensure that the BIG-IP can forward traffic to
the back-end server that is hosting our DNS service. We will then attack the resources behind the virtual
server, mitigate the attack, and finally review the reports and logs generated by the BIG-IP.

3.1.1 Base BIG-IP Configuration

In this lab, the VE has been configured with the basic system settings and the VLAN/self-IP configurations
required for the BIG-IP to communicate and pass traffic on the network. We’ll now need to configure the
BIG-IP to listen for traffic and pass it to the back end server.

1. Launch the Firefox shortcut titled Launch BIG-IP Web Ul on the desktop of your lab jump server.
The credentials for the BIG-IP are conveniently displayed in the login banner. Just in case: admin /
401elliottw!

2. Navigate to Local Traffic > Nodes and create a new node with the following settings, leaving unspec-
ified fields at their default value:

a. Name: lab-server-10.10.0.50
b. Address: 10.10.0.50
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Local Traffic » Nodes: Node List »» New Hode...

General Properties

Name | 1ab-server-10.10.0.50

Description |

@ address ) FQDN

Address
| 10.10.0.50
Configuration
Health Monitars I Mode Default :
Ratio [ 1
Connection Limit |0
Connection Rate Limit I 0

[ Cancel ][ Repeat ][ Finished]

3. Click Finished to add the new node.

4. Navigate to Local Traffic > Pools and create a new pool with the following settings, leaving unspeci-
fied attributes at their default value:

a. Name: lab-server-pool
b. Health Monitors: gateway_icmp
c. New Members: Node List - Address: lab-server-10.10.0.50 - Service Port: * (All Ports)

d. Click Add to add the new member to the member list.
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Local Traffic » Pools : Pool List »» New Pool...

Configuration: I Basic :
Mame | lab-senver-pool
Description [
Active Ayailable
‘Common - ‘Common o
Health Monitors http El
http_head_f5
https
- https_443 -
Resources
Load Balancing Method [ Round Robin [=]

Priority Group Activation

Mew Members

IDisabIed :

) Mew Node ) New FQDN Node @ Node List

Address: | lab-server-10.10.0.50 (10.10.0.50) ||

Semvice Port:| ¥ * All Services | x|
Add

v
Mode Mame ‘ Address/FQDMN | Semvice Port ‘ Auto Populate | Priority
lab-server-10.10.0.50 10.10.0.50 * 0

[ Cancel ][ Repeat ][ Finished]

5. Click Finished to create the new pool.

6. Because the attack server will be sending a huge amount of traffic, we’ll need a fairly large SNAT
pool. Navigate to Local Traffic > Address Translation > SNAT Pool List and create a new SNAT

pool with the following attributes:

a. Name: inside_snat_pool
b. Member List: 10.10.0.125, 10.10.0.126, 10.10.0.127, 10.10.0.128, 10.10.0.129, 10.10.0.130
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Local Traffic » Address Translation : SHAT Pool List :» New SHAT Pool...

General Properties

I Mame inside_snat_pool

Configuration

|P Address: I 10.10.0.130|
Add

10.10.0.125
Member List 10.10.0126
10100127
10.10.0.128
10.10.0.129

lat [ »

1

| Cancel || Repeat | | Finished |

7. Click Finished to commit your changes.

8. Navigate to Local Traffic > Virtual Servers and create a new virtual server with the following settings,
leaving unspecified fields at their default value:

a. Name: udp_dns_VS
b. Destination Address/Mask: 10.20.0.10
c. Service Port: 53

d. Protocol: UDP

e. Source Address Translation: SNAT

f. SNAT Pool: inside_snat_pool

g. Default Pool: lab-server-pool
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Local Traffic » Virtual Servers : Virtual Server List »

udp_dns_V5

Properties Resources Security ~ | Statistics =

o~

General Properties

Name udp_dns_W5S

Partition / Path Commaon

Description |

Type | standard =
Source Address [0.0000

Destination Address/Mask [10.20.0.10

Service Port E2 [ Cther: =]
Metify Status to Virual

Address

Awailability () Avsilable (Enabled) - The virtual server is available
Syncookie Status Off

State Ensabled :
Configuration: | Basic :

Protocol UoP
Protocol Profile {Client) udp
Frotocol Profile (Senver) | {Use Client Profile) E|
Selected Available

- ‘Common -

SSL Frofile [Client) clientss| E
clientssk-insecure-compatible [=
clientssl-secure
i crypto-server-default-clientssl =
Selected Available

- ‘Common -

SSL Profile (Server) spm-default-serverss| a
crypto-client-default-serverss|
pooip-default-serverss|

b serverssl =
SMTPS Profile Mone
Client LDAP Profile Mone
Server LDAP Profile Maone
SMTP Profile Maone
MNetflow Profile None
VLAN and Tunnel Traffic | [ All VLANs and Tunnels [« |

Source Address Translation SHAT
SMNAT Pool inside_snat_pool :

Content Rewrite

Rewrite Profile | Mone El
HTML Profile None
Acceleration

Rate Class | Mone :

9. Click Finished.

10. We’'ll now test the new DNS virtual server. SSH into the attack host by clicking the “Attack Host
(Ubuntu)” icon on the jump host desktop.
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11. Issue the dig @10.20.0.10 www.example.com +short command on the BASH CLI of the attack host.
You should see output similar to:

This verifies that DNS traffic is passing through the BIG-IP.

12. Return to the BIG-IP and navigate to Local Traffic > Virtual Servers and create a new virtual server
with the following settings, leaving unspecified fields at their default value:

a.
b. Destination Address/Mask: 10.20.0.10
c. Service Port: * (All Ports)

d.

e. Any IP Profile: ipother

Q .

Name: other_protocols_VS

Protocol: * All Protocols

Source Address Translation: SNAT
SNAT Pool: inside_snat_pool

Default Pool: lab-server-pool
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Local Traffic » Virtual Servers : Virtual Server List »: New Virtual Server...

General Properties

Mame I other_protocols_V3
Description I
Type | Standard E
Source Address I
Destination Address/Mask I 10.20.0.10
Senvice Port E [*aiPots |~
Motify Status to Virtual Address
State I Enabled :
Configuration: m
Pratocol [+ A Protocals [+
HTTP Praxy Connect Prafile [ Nane |~
Any IP Profile [ipotner  [+]
SSH Proxy Profile [Nore <]
VLAM and Tunnel Traffic [ Al VLANS and Tunnels [ |
Source Address Translation | [SNAT [+
SNAT Pool [inside_snat_pool [+]
Resources
Enabled Available
E ‘Common -
_sys_APM_ExchangeSupport_OA_BasicAuth| |
iRules _sys_APM_ExchanaeSupport_OA_NtimAuth
A _sys_APM_ExchangeSupport_helper
_sys_APM_ExchangeSupport_main -
Default Poal WE’

13. Return to the Attack Host SSH session and attempt to SSH to the server using SSH 10.20.0.10.
Simply verify that you are prompted for credentials and press CTRL+C to cancel the session. This
verifies that non-DNS traffic is now flowing through the BIG-IP.

3.1.2 Detecting and Preventing DNS DoS Attacks on a Virtual Server

Establishing a DNS server baseline

Before we can attack our DNS server, we should establish a baseline for how many QPS our DNS server
can handle. For this lab, let’s find the magic number of QPS that causes 50% CPU utilization on the BIND
process.

1. Connect to the Victim Server SSH session by double-clicking the Victim Server (Ubuntu) shortcut
on the jump host desktop.

2. From the BASH prompt, enter top and press Enter to start the top utility.
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3. You will see a list of running processes sorted by CPU utilization, like the output below:

ubuntu@wvictimserser: ~ iﬂ@

0 used.

FID USER SHRE S %CPU 3MEM
1475 ubuntu 2 0 fi== =] 31 ! .7 0.2
1351 r 0 .30,

1r 1 2245 o1z 5a . 0.3
- |

4
G u]
i
7
=1
=]

[ury
[}
-}

4. Connect to the Attack Host SSH session by double-clicking the Attack Host (Ubuntu) shortcut on the
jump host desktop.

5. Start by sending 500 DNS QPS for 30 seconds to the host using the following syntax:
dnsperf -s 10.20.0.10 -d queryfile-example-current -¢c 20 -T 20 -1 30 -g 10000 -Q 500

Hint: There is a text file on the desktop of the jump host with all of the CLI commands used in the lab for
cut/paste use.

6. Observe CPU utilization over the 30 second window for the named process. If the CPU utilization
is below 45%, increase the QPS by increasing the -Q value. If the CPU utilization is above 55%,
decrease the QPS.

7. Record the QPS required to achieve a sustained CPU utilization of approximately 50%. Consider this
the QPS that the server can safely sustain for demonstration purposes.

8. Now, attack the DNS server with 10,000 QPS using the following syntax:
dnsperf -s 10.20.0.10 -d queryfile-example-current -¢c 20 -T 20 -1 30 -g 10000 -Q 10000

9. You'll notice that the CPU utilization on the victim server skyrockets, as well as DNS query timeout
errors appearing on the attack server’s SSH session. This shows your DNS server is overwhelmed.

Configuring a DoS Logging Profile

We’ll create a DoS logging profile so that we can see event logs in the BIG-IP Ul during attack mitigation.

1. On the BIG-IP web Ul, navigate to Security > Event Logs > Logging Profiles and create a new
profile with the following values, leaving unspecified attributes at their default value:

a. Profile Name: dns-dos-profile-logging
b. DoS Protection: Enabled
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c. DNS DoS Protection Publisher: local-db-publisher

Security » Event Logs : Logging Profiles :: Create New Logging Profile...

Logaoing Profile Properties

I Profile Mame | dns-dos-profile-logging
Description |
Protocol Security [ Enabled
Metwork Firewall [CIEnabled
Metwork Address Translation [l Enabled
DoS Protection Enabled
Protocol Inspection [l Enabled
Classification [C| Enabled
DoS Protection
DNS DoS Protection
Publisher | local-db-publisher I~
SIP Do % Protection
Publisher | none |Z|
Hetwork Do 5 Protection
Publisher | none |Z|

| Cancel | | Finished |

Configuring a DoS Profile

We'll now create a DoS profile with manually configured thresholds to limit the attack’s effect on our server.

1. Navigate to Security > DoS Protection > DoS Profiles and create a new DoS profile with the name
dns-dos-profile.
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o M 0D

Security » DoS5 Protection : Do5 Profiles :: New Dos Profile

Properties

Mame dns-das-profile

Description

| Cancel || Finished

The Ul will return to the DoS Profiles list. Click the dns-dos-profile name.
Click the Protocol Security tab and select DNS Security from the drop-down.
Click the DNS A Query vector from the Attack Type list.

Modify the DNS A Query vector configuration to match the following values, leaving unspecified at-
tributes with their default value:

a. State: Mitigate

b. Threshold Mode: Fully Manual

c. Detection Threshold EPS: (Set this at 80% of your safe QPS value)
d. Mitigation Threshold EPS: (Set this to your safe QPS value)
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6.

DNS A Query

State

I Mitigate :

Threshold Mode
) Fully Automatic
) Manual Detection / Auto Mitigation

@ Fully Manual

Detection Threshold EPS
| Specify [« | 400 |

Detection Threshold Percent
| Specify [» | | 500 |

Mitigation Threshold EPS
| Specify [» | | 500 |

[ simulate Auto Threshald

["|Bad Actor Detection

[ Cancel ][ Update

Make sure that you click Update to save your changes.

Attaching a DoS Profile

We'll attach the DoS profile to the virtual server that we configured to manage DNS traffic.

1.

Navigate to Local Traffic > Virtual Servers > Virtual Server List.

2. Click on the udp_dns_VS name.

3. Click on the Security tab and select Policies.
4.
5

. In the Log Profile, select Enabled and move the dns-dos-profile-logging profile from Available to

In the DoS Protection Profile field, select Enabled and choose the dns-dos-profile.

Selected.
Click Update.

Simulate a DNS DDoS Attack

1.
2.

3.

Open the SSH session to the victim server and ensure the top utility is running.

Once again, attack your DNS server from the attack host using the following syntax:
dnsperf -s 10.20.0.10 -d queryfile-example-current -c 20 -T 20 -1 30 -q 10000 -Q 10000

On the server SSH session running the top utility, notice the CPU utilization on your server remains in
a range that ensures the DNS server is not overwhelmed.
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4. After the attack, navigate to Security > Event Logs > DoS > DNS Protocol. Observe the logs to
see the mitigation actions taken by the BIG-IP.

(& BIG-IP® - bigipLdnstestlab (1 X ‘ = ==

&« c @ ® & hitps//192.168.1.100 i/ e @ W Q Search N = @0 =
Pairtition: _Common -

I irewall: Consistent
|| OHLINE (ACTIVE)
|| Standalone

Security » Event Logs : Do% : DNS Protocol

[ Statistics % ~ Protocol » | Metwaork islation = | DoS * | Logging Profiles
- ]
E iApps
@ DNS same |¢ Action | = AttackID | = Packets Infsec | = D
:om Drop 3793556962 303 280
) Local Tratfic
Drop 3793556962 369 345
r__,; Traffic Intelligence blogspotecom Dirop 3793556962 139 "7
et Cran 3793556962 365 zhErs

DNS DDoS Mitigations for Continued Service

At this point, you've successfully configured the BIG-IP to limit the amount of resource utilization on the
BIG-IP. Unfortunately, even valid DNS requests can be caught in the mitigation we’ve configured. There are
further steps that can be taken to mitigate the attack that will allow non-malicious DNS queries.

Bad Actor Detection

Bad actor detection and blacklisting allows us to completely block communications from malicious hosts at
the BIG-IP, completely preventing those hosts from reaching the back-end servers. To demonstrate:

Navigate to Security > DoS Protection > DoS Profiles.
Click on the dns-dos-profile profile name.

Click on the Protocol Security tab then select DNS Security.
Click on the DNS A Query attack type name.

o kM N

Modify the vector as follows:

a. Bad Actor Detection: Checked

b. Per Source IP Detection Threshold EPS: 80

c. Per Source IP Mitigation Threshold EPS: 100
d. Add Source Address to Category: Checked
e

. Category Name: denial_of_service

P

Sustained Attack Detection Time: 15 seconds

g. Category Duration Time: 60 seconds
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DNS A Query

State

| Miigate |

Threshold Mode

) Fully Automatic

) Manual Detection / Auto Mitigation
@ Fully Manual

Detection Threshaold EPS

| Specify |~ | | 400 |

Detection Threshold Percent
| Specify [+ || 500 |

Mitigation Threshold EPS
| Specify [+ || 500 |

[“] simulate Auto Threshold
Bad Actor Detection

Per Source IP Detection Threshold EPS
| specity [+ ]| 20 |
Per Source IP Mitigation Threshold EFS
| Specify E | 100 |

Add Source Address to Category

Category Name | denial_of_senice |=]

Sustained Attack Detection Time
| 15 |seconds

Category Duration Time
| &0 |seconds

[C] atlow External Advertisement

6. Make sure you click Update to save your changes.

7. Navigate to Security > Network Firewall > IP Intelligence > Policies and create a new IP Intelli-
gence policy with the following values, leaving unspecified attributes at their default values:

a. Name: dns-bad-actor-blocking
b. Default Log Actions section:

i. Log Blacklist Category Matches: Yes
c. Blacklist Matching Policy

i. Create a new blacklist matching policy:

1. Blacklist Category: denial_of_service
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Security » Network Firewall : IP Intelligence : Policies »» New IP Intelligence Policy...

General Properties

Mame oad-actor-blocking

Description |

IP Intelligence Policy Properties

Selected Available
'Common -
Feed Lisls Global

IP Reputation

Default Action Drop j

Log Whitelist Overrides No j
Default Log Actions

Log Blacklist Category Matches| Yes :

Blacklist Category IWE
Action
Log Blacklist Category Malcneslmm
Log Whitelist Overrides [Use Paiicy Default [«

Match Override Match Source :
Dlackie M OE s Blacklist Category || Action I Log BlacKlist Category Matches 1l Log Whitelist Overrides || Watch Override
denial_of_service Use Palicy Default Use Policy Default Use Policy Default Match Source

2. Click Add to add the policy.
8. Click Finished.
9. Navigate to Local Traffic > Virtual Servers > Virtual Server List.
10. Click on the udp_dns_VS virtual server name.
11. Click on the Security tab and select Policies.

12. Enable IP Intelligence and choose the dns-bad-actor-blocking policy.
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Local Traffic »» Virtual Servers : Virtual Server List ;» udp_dns_V5S

Resources Security w | Stafistics

% + | Properties

Policy Settings: | Basic :
Destination 10.20.0.10:53
Service DMS
Enforcemem:IDisabled :
Metwork Firewall

Staging: IDisabIed :

[[use Device Policy
Metwork Address Translation [[luse Route Domain Policy
F'olicyl Mone :

Maximum Bandwidth I 0 Mbps

Learning Phase End Time(DNS):

Protocal Inspection Profile I Dizsabled :
IEnabIed... :

Service Policy None |+

Eviction Policy [ None =

IP Intelligence [Enabled. [+] F‘olicy:| dns-bad-actor-blacking |= |
Do Protection Profile [Enabled. [+] F'roﬂle:l dns-dos-profile | = |

Auto Threshald

Dynamic Signatures Learning Phase End Time (Metwork):

Selected Available
‘Common a ‘Common .
Log Profile dns-dos-profile-logging Log all requests
Log ilagal requests
globalnetwaork
- local-dos -
Update

13. Make sure you click Update to save your changes.

14. Navigate to Security > Event Logs > Logging Profiles.

15. Click the global-network logging profile name.

16. Under the Network Firewall tab, set the IP Intelligence Publisher to local-db-publisher and check

Log Shun Events.

IP Intelligence
Publisher | local-db-publisher =
Agagregate Rate Limit WEI
Log Translation Fields | Enabled
Log Shun Events Enabled
Log RTBH Events " Enabled
Log Scrubber Events | Enabled

17. Click Update to save your changes.
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18. Click the dns-dos-profile-logging logging profile name.
19. Check Enabled next to Network Firewall.

i+ ~ | Edit Logging Profile

Security » Event Logs : Logging Profiles :: Edit Logging Profile

Logging Profile Properties

Profile Mame

Partition / Path
Description

Protocol Security

Metwork Firewall

Metwork Address Translation

DoS Protection

Protocol Inspection

Classification

dns-dos-profile-logaging

Commaon

[C|Enabled
[¥| Enabled

[C|Enabled

[¥| Enabled

[C| Enabled

[C|Enabled

20. Under the Network Firewall tab, change the Network Firewall and IP Intelligence Publisher to
local-db-publisher and click Update.

Network Firewall

Fublisher

Agaregate Rate Limit

Log Rule Matches

Log IP Errors

Log TCP Errors

Log TCF Events

Log Translation Fields
Always Log Region

Storage Format

IP Intelligence
Publisher
Agaregate Rate Limit
Log Translation Fields
Log Shun Events
Log RTEH Events

Log Scrubher Events

| local-dh-puhlisher

[[accept
[T orop
DReject
[CJEnabled
[ClEnabled
[CEnablad
[CEnablad
[CIEnanbled

| Mane :

[=l

| lacal-db-publisher

| Indefinite :

[CEnablad
[CIEnanbled
[CEnabled
[ClEnablad

21. Bring into view the Victim Server SSH session running the top utility to monitor CPU utilization.

22. On the Attack Server host, launch the DNS attack once again using the following syntax:
dnsperf -s 10.20.0.10 -d queryfile-example-current -c 20 -T 20 -1 30 -q 10000 -Q 10000
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23. You'll notice CPU utilization on the victim server begin to climb, but slowly drop. The attack host will
show that queries are timing out as shown below. This is due to the BIG-IP blacklisting the bad actor.
[Timeout] Q v timed out: msg id 3464
[Timeout timed out: n "

[Timeout timed out: msg
[Timeout timed out: msg

[Timeout] timed out: msg
[Timeout] Q v timed out: msg id 34

24. Navigate to Security > Event Logs > Network > IP Intelligence. Observe the bad actor blocking
mitigation logs.

25. Navigate to Security > Event Logs > Network > Shun. This screen shows the bad actor being
added to (and later deleted from) the shun category.

Security » Event Logs : Network : Shun

o vl Protocal e s etwork Address Translation = I Do

i Last Hour |E| Search| Custom Search..

Time “ Shun P I = Shun Category Shun 'I'I'LI = Shun Action:
:"2018-02-06 08:59:42 .10.20.0.50 .ICommonIdeniaI_of_service . 1] . Delete |
|2U18-U2-06 025842 10.20.0.50 fCommonfdenial_of_service 59 Add
2018-02-06 08483 10200050 JCommonfdenial_of_service 0 Delete
|2018-02-06 0g8:47:30 1020050 iCommonfdenial_of_serice B0 Add

26. Navigate to Security > Reporting > Protocol > DNS. Change the View By drop-down to view
various statistics around the DNS traffic and attacks.

MeasurementITop : Packets : Chart type: | Absolute :

Packets per ¥irtual Server

200k

150k

100k

5ok A \ //\ /\

\ /
fd
g T T T T T 1
08:10 08:20 08130 08140 08:50

Details
[ ] | virtual Server | ¥ packets
.[{j B [Commaoniudp_dns_YS 204,554
|# E Device Level 140,524
[ W overal 435,078

27. Navigate to Security > Reporting > Network > IP Intelligence. The default view may be blank.
Change the View By drop-down to view various statistics around the IP Intelligence handling of the

attack traffic.

28. Navigate to Security > Reporting > DoS > Dashboard to view an overview of the DoS attacks and
timeline. You can select filters in the filter pane to highlight specific attacks.
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Security »» Reporting : DoS : Dashboard

% + | Dashboard Analysis URL Latencies Sweeper Custom Page

Last hour Feb &, 08:05:00 - 09:05:12 5 min. = o Refresh
ﬂ 08 10 0a:20 0830 0340 0850 ng:00 [||
Attack Duration HTTS Jons
Il
[ Network |sip
2"
= Attack IDs g
2 Q - Droppe.
= 127584038 0
£
o 3845487151 0
2 Not attacked 0
@ I I I I I 4052331326 0
08:10 08:20 Da:30 08:40 08:50 09:00 = Virtual Servers 2
Crifical M High ™ Moderate @ Low =l
ICommoniudp_dns_W5S u]
Attacks Device Lewe| 1]

# of Attacks (i}

29. Finally, navigate to Security > Reporting > DoS > Analysis. View detailed statistics around each
attack.

Remote Triggered Black Holing

The BIG-IP supports the advertisement of bad actor(s) to upstream devices via BGP to block malicious
traffic closer to the source. This is accomplished by publishing a blacklist to an external resource. This is
not demonstrated in this lab.

Silverline Mitigation

F5’s cloud-based scrubbing service Silverline offers “always on” and “on demand” DDoS scrubbing that
could assist in this scenario as well. This is not demonstrated in this lab.

3.1.3 Filtering specific DNS operations
The BIG-IP offers the ability to filter DNS query types and header opcodes to act as a DNS firewall. To
demonstrate, we will block MX queries from our DNS server.

1. Open the SSH session to the attack host.

2. Perform an MX record lookup by issuing the following command:
dig @10.20.0.10 MX example.com

3. The server doesn’'t have a record for this domain. This server doesn’'t have MX records, so those
requests should be filtered
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4. Navigate to Security > Protocol Security > Security Profiles > DNS and create a new DNS security
profile with the following values, leaving unspecified attributes at their default value:

a. Name: dns-block-mx-query

b. Query Type Filter: move mx from Available to Active

Security »» Protocol Security : Secunty Profiles : DNS :: New Security Profile...

Properties
I MName

Description

Query Type

Query Type Filter

Header Opcode Exclusion

[ Cancel | [ Repeat | [ Finished |

| dns-block-mx-query

IEchusion :

Active Available
- |7 z
bt
o L
¥25
- afsdb -
Activa Available
- query -

5. Navigate to Local Traffic > Profiles > Services > DNS. NOTE: if you are mousing over the services,
DNS may not show up on the list. Select Services and then use the pulldown menu on services to

select DNS.

6. Create a new DNS services profile with the following values, leaving unspecified values at their default

values:
a. Name: dns-block-mx
b. DNS Traffic

i. DNS Security: Enabled
ii. DNS Security Profile Name: dns-block-mx-query
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Local Traffic »» Profiles : Services : DNS :: New DNS Profile...

General Properties

Mame

Parent Profile

I dns-block-mx
I dns :

Denial of Service Protection

Rapid Response Mode

I Disabled

DME Cache Mame
DMS IPVE to IPvd
Unhandled Query Actions

Use BIND Server on BIG-IP

Rapid Response Last Action Drop
Hardware Acceleration

Protocal Validation Disabled

Response Cache Disabled
DNS Features

DMNSSEC Enabled

GSLB Enabled

DMS Express Enabled

DMS Cache Disabled

Select..

Disabled

Allow

Enabled

DNS Traffic

Zone Transfer
DMS Security
DMS Security Profile Mame

Process Recursion Desired

Disabled

Enabled

CLRLELELELLRLL

dns-block-mx-query |Z|

Enabled

Logging and Reporting

Logging
Logging Profile

AR Statistics Sample Rate

Disabled

Select..

LBt

[ Cancel ] [ Repeat ] [ Finished ]

7. Navigate to Local Traffic > Virtual Servers > Virtual Server List.

8. Click on the udp_dns_VS virtual server name.

9. In the Configuration section, change the view to Advanced.
10. Set the DNS Profile to dns-block-mx.
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SN rume | raune
Netflow Profile [Nome [~
WebSocket Profile [Nome  [-]
SplitSession Client Profile I Mone
SplitSession Server Profile | Mone

DNS Profile [dns-block-mx [« ]
QoE Profile [None -]

GTP Profile [Nome -]
Request Adapt Profile [None  [7]
Response Adapt Profile [None  [¢]

RADNILIS Prafile | Mone

11. Click Update to save your settings.

12. Navigate to Security > Event Logs > Logging Profiles.
13. Click on the dns-dos-profile-logging logging profile name.
14. Check Enabled next to Protocol Security.

15. In the Protocol Security tab, set the DNS Security Publisher to local-db-publisher and check all
five of the request log types.
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Security » Event Logs : Logging Profiles :: Edit Logging Profile

7+ ~ EditLogging Profile

Logging Profile Properties

Profile Mame dns-dos-profile-logging
Fartition / Path Common

Description |

Protocol Security

Metwork Firewall Enabled

Metwork Address Translation [[Enabled

Do$ Protection [¥ Enabled
Protocol Inspection [[Enabled
Classification [[Enabled

Protocal Security | Metwork Firewall DoS Protection

HTTP, FTP, and SMTP Security

Publisher |n0ne I~
DNS Security

Publisher | local-db-publisher =

Log Dropped Requests [¥| Enabled

Log Filtered Dropped Requests Enabled

Log Malformed Requests [¥| Enabled
Log Rejected Requests [¥| Enabled
Log Malicious Requests Enabled

Storage Format |N0ne :

16. Make sure that you click Update to save your settings.

17. Return to the Attack Server SSH session and re-issue the MX query command:
dig @10.20.0.10 MX example.com

18. The query hangs as the BIG-IP is blocking the MX lookup.

19. Navigate to Security > Event Logs > Protocol > DNS. Observer the MX query drops.

Security » Event Logs: Protocol : DNS

» | Logging Profiles

13 ~ | Protocol > | b

Source || Destination |

‘ort © YLAN = Address | < Part = Rowute Domain = DNS Query Type = DNS Query Mame  © Aftack Type | = Action
112 ICommonfoutzide 10.20.010 53 a [LE example com M Drop
112 fCommonfoutside 10.20.010 53 1} [k example.com M Crop
112 ICommaonioutside 1020010 53 o M example.cam MH Drop

Attention: This concludes the DNS portion of the lab. On the victim server, stop the top utility by
pressing CTRL + C.
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3.2 Module 2 — Detecting and Preventing System DoS and DDoS At-
tacks

In this lab, you will launch attacks against the BIG-IP, configure mitigation and finally review the reports and
logs.

3.2.1 Detecting and Preventing System DoS and DDoS Attacks

Configure Logging
Configuring a logging destination will allow you to verify the BIG-IPs detection and mitigation of attacks, in
addition to the built-in reporting.
1. In the BIG-IP web Ul, navigate to Security > DoS Protection > Device Configuration > Properties.
2. Under Log Pubisher, select local-db-publisher.
3. Click the Commit Changes to System button.

Security » DoS Protection : Device Configuration : Properties

% ~ | DoS Overview DoS Profiles Device Configuratio
Properties

Log Publisher | localdb-publisher E

Threshold Sensitivity IMedium :

Eviction Palicy | default-eviction-policy E

Simulating a Christmas Tree Packet Attack

In this example, we’ll set the BIG-IP to detect and mitigate an attack where all flags on a TCP packet are
set. This is commonly referred to as a Christmas tree packet and is intended to increase processing on
in-path network devices and end hosts to the target.

We’'ll use the hping utility to send 25,000 packets to our server, with random source IPs to simulate a DDoS
attack where multiple hosts are attacking our server. We'll set the SYN, ACK, FIN, RST, URG, PUSH, Xmas
and Ymas TCP flags.

1. In the BIG-IP web Ul, navigate to Security > DoS Protection > Device Configuration > Network
Security.

2. Expand the Bad-Header-TCP category in the vectors list.
3. Click on the Bad TCP Flags (All Flags Set) vector name.
4. Configure the vector with the following parameters:

a. State: Mitigate

b. Threshold Mode: Fully Manual
. Detection Threshold EPS: Specify 50

o O

. Detection Threshold Percent: Specify 200
. Mitigation Threshold EPS: Specify 100

(]
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Bad TCP Flags (All Flags Set)

State

I Mitigate :

Threshold Mode

@ Fully Manual

Detection Threshold EPS
Specify 50

Detection Threshold Percent
Specify 200

Mitigation Threshold EPS
Specify 100

Cancel Update

5. Click Update to save your changes.

6. Open the BIG-IP SSH session and scroll the Itm log in real time with the following command: tail -f
/var/log/Itm

7. On the attack host, launch the attack by issuing the following command on the BASH prompt:
sudo hping3 10.20.0.10 —flood —rand-source —destport 80 -¢ 25000 —syn —ack —fin —rst —push —urg
—xmas —ymas

8. You'll see the BIG-IP Itm log show that the attack has been detected:

r

9. After approximately 60 seconds, press CTRL+C to stop the attack.

NG wroe ——-destport ol

10. Return to the BIG-IP web UI. Navigate to Security > Event Logs > DoS > Network > Events.
Observer the log entries showing the details surrounding the attack detection and mitigation.

S Destinatiun S8
Context | = Address | = Port | = Event - Type Action Aftack 1D < Packets Infsec | = Dropp
Bvice . .Attack Stopped . Bad TCF flags (all flags sef) : Maone i 41123876591 0 0
Bvice 1020010 80 Aftack Sampled Bad TCP flags (all lags sety Drop 4112387691 597 297
2iice 1020010 &0 Aftack Sampled Bad TCP flags (all lags sety Crop 4112387691 593 893
Biice 1020010 80 Aftack Sampled Bad TCFP flags {all lags sety Crop 41123876591 601 E01

11. Navigate to Security > Reporting > DoS > Analysis. Single-click on the attack ID in the filter list to
the right of the charts and observe the various statistics around the attack.
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Simulating a TCP SYN DDoS Attack

In the last example, we crafted a packet that is easily identified as malicious, as its invalid. We’ll now
simulate an attack with traffic that could be normal, acceptable traffic. The TCP SYN flood attack will
attempt to DDoS a host by sending valid TCP traffic to a host from multiple source hosts.

1. In the BIG-IP web Ul, navigate to Security > DoS Protection > Device Configuration > Network
Security.

2. Expand the Flood category in the vectors list.
3. Click on TCP Syn Flood vector name.
4. Configure the vector with the following parameters (use the lower values specified):
a. State: Mitigate
b. Threshold Mode: Fully Manual
c. Detection Threshold EPS: 50
d. Detection Threshold Percent: 200

e. Mitigation Threshold EPS: 100

TCP SYN Flood

State

I Mitigate :

Threshold Mode
_! Fully Automatic
_' Manual Detection / Auto Mitigation

@ Fully Manual

Detection Threshold EPS

I Specify : 400

Detection Threshold Percent
I Specify : 500

Mitigation Threshold EPS

| Specify : 500

["] simulate Auto Threshold
["I Bad Actor Detection

[”] Attacked Destination Detection

5. Click Update to save your changes.

6. Open the BIG-IP SSH session and scroll the Itm log in real time with the following command: tail -f
/var/log/Itm

7. On the attack host, launch the attack by issuing the following command on the BASH prompt:
sudo hping3 10.20.0.10 —flood —rand-source —destport 80 —syn -d 120 -w 64

8. After about 60 seconds, stop the flood attack by pressing CTRL + C.

9. Return to the BIG-IP web Ul and navigate to Security > Event Logs > DoS > Network > Events.
Observe the log entries showing the details surrounding the attack detection and mitigation.

10. Navigate to Security > Reporting > DoS > Dashboard to view an overview of the DoS attacks and
timeline. You can select filters in the filter pane to highlight the specific attack.
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11. Finally, navigate to Security > Reporting > DoS > Analysis. View detailed statistics around the
attack.

3.2.2 Preventing Global DoS Sweep and Flood Attacks

In the last section, the focus was on attacks originating from various hosts. In this section, we will focus on
mitigating flood and sweep attacks from a single host.

Single Endpoint Sweep

The single endpoint sweep is an attempt for an attacker to send traffic across a range of ports on the target
server, typically to scan for open ports.

1. In the BIG-IP web Ul, navigate to Security > DoS Protection > Device Configuration > Network
Security.

2. Expand the Single-Endpoint category in the vectors list.

3. Click on Single Endpoint Sweep vector name.

4. Configure the vector with the following parameters:

a.
b. Threshold Mode: Fully Manual
c. Detection Threshold EPS: 150
d.
e
f

> @

State: Mitigate

Mitigation Threshold EPS: 200

. Add Source Address to Category: Checked

. Category Name: denial_of_service

Sustained Attack Detection Time: 10 seconds
Category Duration Time: 60 seconds
Packet Type: Move All IPv4 to Selected
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single Endpoint Sweep

State

I Mitigate :

Threshold Mode

@ Fully Manual

Detection Threshold EPS
|Specifylz|| 150 |

Mitigation Threshold EPS
| Specify [ | 200 |

[¥] Add Source Address to Category

Category Mame | denial_of_sermice |E|

Sustained Attack Detaction Time

| 10 |sec0nds
Category Duration Time
| 60 |seconds

[ Mllow External Advertisement

Packet Type
Selected Available
All P4 - All IPvE

Any ICMP (IPvd)

Any ICMP {IPvE)

Any Other IPv4 Protocol
Any Other IPvE Protocol
Atomic Fragment

== |Bad Packet

—| DNE A Query

||| DMNS AAAA Query

~| DNS AMY Quuery

DMNS AXFR Query
DMS CHNAME Query
DMS IXFR Query
DMS MX Query

e DMNS NS Query

5. Click Update to save your changes.

6. Navigate to Security > Network Firewall > IP Intelligence > Policies.

. In the Global Policy section, change the IP Intelligence Policy to ip-intelligence.

Global Policy

IP Intelligence Palicy |ip—inte|ligence |Z|

Description |

8. Click Update.

9. Click on the ip-intelligence policy in the policy list below.

. Create a new Blacklist Matching Policy in the IP Intelligence Policy Properties section with the following

attributes, leaving unspecified attributes with their default values:

3.2.
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a. Blacklist Category: denial-of-service

b. Action: drop

c. Log Blacklist Category Matches: Yes

11. Click Add to add the new Blacklist Matching Policy.
Security » Network Firewall : IP Intelligence : Policies > ip-intelligence
15 ~ Properties
General Properties
MName ip-intelligence
Partition / Path Commaon
Description |
IP Intelligence Policy Properties
Selected Available
‘Common -
FeedLits IGIJOII;jI utation
eputati
Default Action
T o L
Blacklist Category WB
Action lDrop—E
Log Blacklist Category Malchesl\’es—g
Log Whitelist Overrides m\j
Match Override WB
LRI M IR RS BlacKlist Category Action Log Blacklist Category Matches Log Whitelist Overrides Match Override
No data available in table

12. Click Update to save changes to the ip-intelligence policy.

13. Open the BIG-IP SSH session and scroll the Itm log in real time with the following command: tail -f
/var/log/ltm

14. On the victim server, start a packet capture with an SSH filter by issuing sudo tcpdump -nn not port
22

15. On the attack host, launch the attack by issuing the following command on the BASH prompt:
sudo hping3 10.20.0.10 —flood —scan 1-65535 -d 128 -w 64 —syn

16. You will see the scan find a few open ports on the server, and the server will show the inbound sweep
traffic. However, you will notice that the traffic to the server stops after a short time (10 seconds, the
configured sustained attack detection time.) Leave the test running.

17. After approximately 60 seconds, sweep traffic will return to the host. This is because the IP Intelligence
categorization of the attack host has expired. After 10 seconds of traffic, the bad actor is again
blacklisted for another 60 seconds.

18. Stop the sweep attack on the attack host by pressing CTRL + C.

19. Return to the BIG-IP web Ul and navigate to Security > Event Logs > DoS > Network > Events.
Observe the log entries showing the details surrounding the attack detection and mitigation.

20. Navigate to Security > Event Logs > Network > IP Intelligence. Observe the log entries showing
the mitigation of the sweep attack via the ip-intelligence policy.
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21. Navigate to Security > Event Logs > Network > Shun. Observe the log entries showing the blacklist
adds and deletes.

22. Navigate to Security > Reporting > Network > IP Intelligence. Observe the statistics showing the
sweep attack and mitigation. Change the View By drop-down to view the varying statistics.

23. Navigate to Security > Reporting > DoS > Dashboard to view an overview of the DoS attacks and
timeline. You can select filters in the filter pane to highlight the specific attack.

24. Finally, navigate to Security > Reporting > DoS > Analysis. View detailed statistics around the
attack.

Single Endpoint Flood
The single endpoint flood attack is an attempt for an attacker to send a flood of traffic to a host in hopes of
overwhelming a service to a point of failure. In this example, we’ll flood the target server with ICMP packets.

1. In the BIG-IP web Ul, navigate to Security > DoS Protection > Device Configuration > Network
Security.

2. Expand the Single-Endpoint category in the vectors list.
3. Click on Single Endpoint Flood vector name.
4. Configure the vector with the following parameters:
a. State: Mitigate
b. Threshold Mode: Fully Manual
Detection Threshold EPS: 150
Mitigation Threshold EPS: 200
Add Destination Address to Category: Checked

© 2 o

b

Category Name: denial_of_service

Sustained Attack Detection Time: 10 seconds

5 @

Category Duration Time: 60 seconds
Packet Type: Move Any ICMP (IPv4) to Selected
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Single Endpoint Flood

State

I Mitigate :
Threshold Mode

@ Fully Manual

Detection Threshold EPS
| Specify : 150
Mitigation Threshold EPS

ISpecify : 200

[¥] 1dd Destination Address to Category

Category Name|denia|_0f_ser\fice Iz‘

Sustained Attack Detection Time

10 seconds
Category Duration Time
60 seconds

[Z] Allow External Advertisement

Packet Type
Selected Available
Any ICMP (IPvd) e All 1Pvd

All IPvE

Any ICMP (IPvE)

Any Other IPvd Protocol
Any Other IPvE Protocol
Atomic Fragment

=» | Bad Packet

DMNS A Query

== | DNS AAAA Query

DMS ANY Query

DMS AXFR Query

DNS CNAME Query
DNS IXFR Query

DMNS MX Query

- DMNS NS Query

5. Click Update to save your changes.

10.

11.
12.

13.

Open the BIG-IP SSH session and scroll the Itm log in real time with the following command: tail -f
/var/log/Itm

We’'ll run a packet capture on the victim server to gauge the incoming traffic. On the victim server,
issue the following command: sudo tcpdump -nn not port 22

On the attack host, launch the attack by issuing the following command on the BASH prompt:
sudo hping3 10.20.0.10 —faster -¢c 25000 —icmp

The attack host will begin flooding the victim server with ICMP packets. However, you will notice that
the traffic to the server stops after a short time (10 seconds, the configured sustained attack detection
time.)

After approximately 60 seconds, run the attack again. ICMP traffic will return to the host. This is
because the IP Intelligence categorization of the attack host has expired.

Return to the BIG-IP web UI.

Navigate to Security > Event Logs > DoS > Network > Events. Observe the log entries showing
the details surrounding the attack detection and mitigation.

Navigate to Security > Event Logs > Network > IP Intelligence. Observe the log entries showing

194

Chapter 3. Class - F5 BIG-IP DDoS and DNS DoS Protections



F5 Firewall Solutions Documentation

the mitigation of the sweep attack via the ip-intelligence policy.

14. Navigate to Security > Reporting > Network > IP Intelligence. Observe the statistics showing the
sweep attack and mitigation.

15. Navigate to Security > Reporting > DoS > Dashboard to view an overview of the DoS attacks and
timeline. You can select filters in the filter pane to highlight the specific attack.

16. Finally, navigate to Security > Reporting > DoS > Analysis. View detailed statistics around the
attack.

3.2.3 Conclusion

Congratulations on finishing the lab!

This lab did not cover auto thresholds for protections, nor did we test dynamic signatures. Testing auto
thresholds requires a more real-world environment. For suggested testing guidelines for auto thresholds
and dynamic signatures, engage your F5 account team.

This concludes the DoS/DDoS portion of the lab. You may now close all sessions, log out of the jump host
and log out of the training portal.

Thank you for your time.

3.3 Appendix

3.3.1 DNS Security vectors

The system tracks and rate limits all UDP DNS packets (excluding those whitelisted). TCP DNS packets
are also tracked but only for the DNS requests that reach a virtual server that has a DNS profile associated
with it.

NOTE: This information applies to 13.1.0.1.

For vectors where VLAN is <tunable>, you can tune this value in tmsh: modify sys db dos.dnsvlan value,
where value is 0-4094.
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DoS Attack Dos Information Hardware

cate- | name vector acceler-

gory name ated

DNS DNS A | dns-a- DNS Query, DNS Qtype is A_QRY, VLAN is <tunable> | Yes
Query query in tmsh usingdos.dnsvlan.

DNS DNS AAAA | dns- DNS Query, DNS Qtype is AAAA, VLAN is <tunable> | Yes
Query aaaa- in tmsh usingdos.dnsvlan.

query

DNS DNS Any | dns-any- | DNS Query, DNS Qtype is ANY_QRY, VLAN is <tun- | Yes
Query query able> in tmsh usingdos.dnsvlan.

DNS DNS AXFR | dns- DNS Query, DNS Qtype is AXFR, VLAN is <tunable> | Yes
Query axfr- in tmsh usingdos.dnsvlan.

query

DNS DNS dns- DNS Query, DNS Qtype is CNAME, VLAN is <tunable> | Yes
CNAME chame- in tmsh usingdos.dnsvlan.
Query query

DNS DNS IXFR | dns-ixfr- | DNS Query, DNS Qtype is IXFR, VLAN is <tunable> in | Yes
Query query tmsh usingdos.dnsvlan.

DNS DNS Mal- | dns- Malformed DNS packet Yes
formed malformed

DNS DNS MX | dns-mx- | DNS Query, DNS Qtype is MX, VLAN is <tunable> in | Yes
Query query tmsh usingdos.dnsvlan.

DNS DNS NS | dns-ns- DNS Query, DNS Qtype is NS, VLAN is <tunable> in | Yes
Query query tmsh usingdos.dnsvlan.

DNS DNS dns- DNS Query, DNS Qtype is OTHER, VLAN is <tunable> | Yes
OTHER other- in tmsh usingdos.dnsvlan.
Query query

DNS DNS PTR | dns-ptr- | DNS Query, DNS Qtype is PTR, VLAN is <tunable> in | Yes
Query query tmsh usingdos.dnsvlan.

DNS DNS Ques- | dns- DNS Query, DNS Qtype is ANY_QRY, the DNS query | Yes
tion Items | qdcount- | has more than one question.
I= 1 limit

DNS DNS Re- | dns- UDP DNS Port=53, packet and DNS header flags bit | Yes
sponse response-| 15 is 1 (response), VLAN is <tunable> in tmsh using
Flood flood dos.dnsvlan.

DNS DNS SOA | dns-soa- | DNS Query, DNS Qtype is SOA_QRY, VLAN is <tun- | Yes
Query query able> in tmsh usingdos.dnsvian.

DNS DNS SRV | dns-srv- | DNS Query, DNS Qtype is SRV, VLAN is <tunable> in | Yes
Query query tmsh usingdos.dnsvlan.

DNS DNS TXT | dns-txt- DNS Query, DNS Qtype is TXT, VLAN is <tunable> in | Yes
Query query tmsh usingdos.dnsvlan.

3.3.2 Network Security Vectors

DoS category Attack name Dos vector name | Information Hardware accel-
erated
Flood Ethernet Broad- | ether-brdcst-pkt Ethernet broad- | Yes
cast Packet cast packet flood
Continued on next page
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Table 1 — continued from previous page

DoS category Attack name Dos vector name | Information Hardware accel-
erated
Flood Ethernet Multicast | ether-multicst-pkt | Ethernet destina- | Yes
Packet tion is not broad-
cast, but is multi-
cast
Flood ARP Flood arp-flood ARP packet flood | Yes
Flood IP Fragment Flood | ip-frag-flood Fragmented Yes
packet flood with
IPv4
Flood IGMP Flood igmp-flood Flood with IGMP | Yes
packets (IPv4
packets with IP
protocol number
2)
Flood Routing  Header | routing-header- Routing  header | Yes
Type 0 type-0 type zero s
present in flood
packets
Flood IPv6 Fragment | ipv6-frag-flood Fragmented No
Flood packet flood with
IPv6
Flood IGMP  Fragment | igmp-frag-flood Fragmented Yes
Flood packet flood with
IGMP protocol
Flood TCP SYN Flood tcp-syn-flood TCP SYN flood Yes
Flood TCP SYN ACK | tcp-synack-flood TCP  SYN/ACK | Yes
Flood flood
Flood TCP RST Flood tcp-rst-flood TCP RST flood Yes
Flood TCP Window Size | tcp-window-size The TCP window | Yes
size in packets is
above the maxi-
mum. To tune this
value, in tmsh:
modify sys db
dos.tcplowwindowsize
value, where
value is <=128.
Flood ICMPv4 Flood icmpv4-flood Flood with ICMP | Yes
v4 packets
Flood ICMPv6 Flood icmpv6-flood Flood with ICMP | Yes
v6 packets
Flood UDP Flood udp-flood UDP flood attack | Yes

Continued on next page
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Table 1 — continued from previous page

DoS category

Attack name

Dos vector name

Information

Hardware accel-
erated

Flood

TCP SYN Over-
size

tcp-syn-oversize

Detects TCP
data SYN pack-
ets larger than
the maximum
specified by the
dos.maxsynsize
parameter.

To tune this
value, in tmsh:
modify sys db
dos.maxsynsize
value. The default
size is 64 and
the maximum
allowable value is
9216.

Yes

Flood

TCP Push Flood

tcp-push-flood

TCP push packet
flood

Yes

Flood

TCP
Flood

BADACK

tcp-ack-flood

TCP ACK packet
flood

No

Bad Header - L2

Ethernet MAC
Source Address
== Destination
Address

ether-mac-sa-eqg-
da

Ethernet MAC
source  address
equals the desti-
nation address

Yes

Bad Header - IPv4

Bad IP Version

bad-ver

The IPv4 address
version in the IP
header is not 4

Yes

Bad Header - IPv4

Header
Too Short

Length

hdr-len-too-short

IPv4 header
length is less than
20 bytes

Yes

Bad Header - IPv4

Header Length >
L2 Length

hdr-len-gt-12-len

No room in layer
2 packet for IP
header (including
options) for IPv4
address

Yes

Bad Header - IPv4

L2 Length >> IP
Length

[2-len-ggt-ip-len

Layer 2 packet
length is much
greater than the
payload length in
an IPv4 address
header and the
layer 2 length is
greater than the
minimum  packet
size

Yes

Bad Header - IPv4

No L4

no-l4

No layer 4 payload
for IPv4 address

Yes

Bad Header - IPv4

Bad IP TTL Value

bad-ttl-val

Time-to-live
equals zero for an
IPv4 address

Yes

Continued on next page
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Table 1 — continued from previous page

DoS category

Attack name

Dos vector name

Information

Hardware accel-
erated

Bad Header - IPv4

TTL <= <tunable>

ttl-leg-one

An IP packet with
a destination that
is not multicast
and that has a
TTL greater than
0 and less than or
equal to a tunable
value, which s
1 by default. To
tune this value, in
tmsh: modify sys
db dos.iplowttli
value, where
value is 1-4.

Yes

Bad Header - IPv4

IP  Error
sum

Check-

ip-err-chksum

The header
checksum is not
correct

Yes

Bad Header - IPv4

IP Option Frames

ip-opt-frames

IPv4 address
packet with op-
tion.db  variable
tm.acceptipsourcerg
must be enabled
to receive IP

options.

Yes

ute

Bad Header - IPv4

Bad Source

ip-bad-src

The IPv4
source IP =
255.255.255.255
or 0xe0000000U

Yes

Bad Header - IPv4

IP Option
Length

lllegal

bad-ip-opt

Option present
with illegal length

No

Bad Header - IPv4

Unknown Option
Type

unk-ipopt-type

Unknown IP op-
tion type

No

Bad Header -
IGMP

Bad IGMP Frame

bad-igmp-frame

IPv4 IGMP pack-
ets should have a
header >= 8 bytes.
Bits 7:0 should
be either 0x11,
0x12, 0x16, 0x22
or 0x17, or else
the header is bad.
Bits 15:8 should
be non-zero only if
bits 7:0 are 0x11,
or else the header
is bad.

Yes

Fragmentation

IP Fragment Too
Small

ip-short-frag

IPv4 short frag-
ment error

Yes

Fragmentation

IPv6 Fragment
Too Small

ipv6-short-frag

IPv6 short frag-
ment error

Yes

Continued on next page
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Table 1 — continued from previous page

DoS category

Attack name

Dos vector name

Information

Hardware accel-
erated

Fragmentation IPV6 Atomic Frag- | ipv6-atomic-frag IPvé Frag header | Yes
ment present with M=0
and FragOffset =0
Fragmentation ICMP Fragment icmp-frag ICMP  fragment | Yes
flood
Fragmentation IP Fragment Error | ip-other-frag Other IPv4 frag- | Yes
ment error
Fragmentation IPV6 Fragment | ipv6-other-frag Other IPv6 frag- | Yes
Error ment error
Fragmentation IP Fragment Over- | ip-overlap-frag IPv4 overlapping | No
lap fragment error
Fragmentation IPv6 Fragment | ipv6-overlap-frag IPv6 overlapping | No
Overlap fragment error
Bad Header - IPv6 | Bad IPV6 Version | bad-ipv6-ver The IPv6 address | Yes
version in the IP
header is not 6
Bad Header - IPv6 | IPV6 Length > L2 | ipv6-len-gt-12-len IPv6 address | Yes
Length length is greater
than the layer 2
length
Bad Header - IPv6 | Payload Length < | payload-len-Is-I2- | Specified IPv6 | Yes
L2 Length len payload length is
less than the L2
packet length
Bad Header - IPv6 | Too Many Exten- | too-many-ext-hdrs | For  an IPv6 | Yes
sion Headers address, there
are more than
<tunable> ex-
tended headers
(the default is
4). To tune this
value, in tmsh:
modify sys db
dos.maxipv6exthdrs
value, where
value is 0-15.
Bad Header - IPv6 | IPv6 duplicate ex- | dup-ext-hdr An extension | Yes
tension headers header should

occur only once
in an IPv6 packet,
except for the
Destination  Op-
tions  extension
header

Continued on next page
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Table 1 — continued from previous page

DoS category Attack name Dos vector name | Information Hardware accel-
erated
Bad Header - IPv6 | IPv6  extension | ext-hdr-too-large An extension | Yes
header too large header is too
large. To tune this
value, in tmsh:
modify sys db
dos.maxipv6extsize
value, where
value is 0-1024.
Bad Header - IPv6 | No L4 (Extended | 14-ext-hdrs-go-end | Extended headers | Yes
Headers Go To go to the end or
Or Past End of past the end of the
Frame) L4 frame
Bad Header - IPv6 | Bad IPV6 Hop | bad-ipv6-hop-cnt Both the termi- | Yes
Count nated (cnt=0) and
forwarding packet
(cnt=1) counts are
bad
Bad Header - IPv6 | IPv6 hop count <= | hop-cnt-leg-one The IPv6 ex- | Yes
<tunable> tended header
hop count is less
than or equal
to <tunable>.
To tune this
value, in tmsh:
modify sys db
dos.ipv6lowhopcnt
value, where
value is 1-4.
Bad Header - IPv6 | IPv6 Extended | ipv6-ext-hdr- IPv6 address | Yes
Header Frames frames contains extended
header frames
Bad Header - IPv6 | IPv6 extended | bad-ext-hdr-order | Extension head- | Yes
headers  wrong ers in the IPv6
order header are in the
wrong order
Bad Header - IPv6 | Bad IPv6 Addr ipv6-bad-src IPv6 source IP = | Yes
0xff00::
Bad Header - IPv6 | IPv4 Mapped IPv6 | ipv4-mapped-ipv6 | IPv4 address is in | Yes
the lowest 32 bits
of an IPv6 ad-
dress.
Bad Header - TCP | TCP Header | tcp-hdr-len-too- The Data Offset | Yes
Length Too Short | short value in the TCP
(Length < 5) header is less
than five 32-bit
words
Bad Header - TCP | TCP Header | tcp-hdr-len-gt-12- Yes

Length > L2
Length

len

Continued on next page
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Table 1 — continued from previous page

DoS category Attack name Dos vector name | Information Hardware accel-
erated
Bad Header - TCP | Unknown TCP | unk-tcp-opt-type Unknown TCP op- | Yes
Option Type tion type
Bad Header - TCP | Option  Present | opt-present-with- Option present | Yes
With lllegal Length | illegal-len with illegal length
Bad Header - TCP | TCP Option Over- | tcp-opt-overruns- | The TCP option | Yes
runs TCP Header | tcp-hdr bits overrun the
TCP header
Bad Header - TCP | Bad TCP Check- | bad-tcp-chksum The TCP check- | Yes
sum sum does not
match
Bad Header- TCP | Bad TCP Flags | bad-tcp-flags-all- Bad TCP flags (all | Yes
(All Flags Set) set flags set)
Bad Header- TCP | Bad TCP Flags | bad-tcp-flags-all- Bad TCP flags | Yes
(All Cleared) clr (all cleared and
SEQ#=0)
Bad Header - TCP | SYN && FIN Set syn-and-fin-set Bad TCP flags | Yes
(SYN and FIN set)
Bad Header - TCP | FIN Only Set fin-only-set Bad TCP flags | Yes
(only FIN is set)
Bad Header - TCP | TCP Flags - Bad | tcp-bad-urg Packet contains a | Yes
URG bad URG flag, this
is likely malicious
Bad Header - | Bad ICMP Check- | bad-icmp-chksum | An ICMP frame | Yes
ICMP sum checksum is bad.
Reuse the TCP
or UDP checksum
bits in the packet
Continued on next page
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Table 1 — continued from previous page

DoS category

Attack name

Dos vector name

Information

Hardware accel-
erated

Bad Header
ICMP

Bad ICMP Frame

bad-icmp-frame

The ICMP frame
is either the wrong
size, or not of one
of the valid IPv4 or
IPv6 types. Valid
IPv4 types:
* 0 Echo Re-
ply
«3 Des-
tination
Unreach-
able

4 Source
Quench

5 Redirect
« 8 Echo

* 11 Time Ex-
ceeded

+ 12 Parame-
ter Problem

* 13
tamp

14 Times-
tamp Reply

* 15 Informa-
tion Request

* 16 Informa-
tion Reply

- 17 Ad-
dress Mask
Request

+ 18 Address

Mask Reply
Valid IPv6 types:

. 1 Des-
tination
Unreach-
able

» 2 Packet Too
Big

« 3 Time Ex-
ceeded

Times-

* 4 Parameter
Problem

« 128 Echo

Yes

3.3. Appendix
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Table 1 — continued from previous page

DoS category

Attack name

Dos vector name

Information

Hardware accel-
erated

Bad Header -
ICMP

ICMP Frame Too
Large

icmp-frame-too-
large

The ICMP frame
exceeds the de-
clared IP data
length or the max-
imum  datagram
length. To tune
this value, in tmsh:
modify sys db

dos.maxicmpframes

value, where
value is <=65515.

Yes

ze

Bad Header - UDP

Bad UDP Header
(UDP Length >
IP Length or L2
Length)

bad-udp-hdr

UDP length is
greater than IP
length or layer 2
length

Yes

Bad Header - UDP

Bad UDP Check-
sum

bad-udp-chksum

The UDP check-
sum is not correct

Yes

Other

Host Unreachable

host-unreachable

Host unreachable
error

Yes

Other

TIDCMP

tidemp

ICMP source
quench attack

Yes

Other

LAND Attack

land-attack

Source IP equals
destination IP ad-
dress

Yes

Other

IP Unknown proto-
col

ip-unk-prot

Unknown IP proto-
col

No

Other

TCP Half Open

tcp-half-open

The number of
new or untrusted
TCP connections
that can be estab-
lished. Overrides
the Global SYN
Check threshold
in  Configuration
> Local Traffic >
General.

No

Other

IP uncommon
proto

ip-uncommon-
proto

Sets  thresholds
for and tracks
packets contain-
ing IP protocols
considered to
be uncommon.
By default, all IP
protocols other
than TCP, UDP,
ICMP, IPV6-ICMP,
and SCTP are on
the IP uncommon
protocol list.

Yes

Continued on next page
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Table 1 — continued from previous page

DoS category

Attack name

Dos vector name

Information

Hardware accel-
erated

Bad Header - DNS

DNS Oversize

dns-oversize

Detects oversized
DNS headers.
To tune this
value, in tmsh:
modify sys db
dos.maxdnssize
value, where
value is 256-8192.

Yes

Single Endpoint

Single  Endpoint

Sweep

sweep

Sweep on a single
endpoint. You can
configure packet
types to check for,
and packets per
second for both
detection and rate
limiting.

No

Single Endpoint

Single
Flood

Endpoint

flood

Flood to a single
endpoint. You can
configure packet
types to check for,
and packets per
second for both
detection and rate
limiting.

No

Bad
SCTP

Header-

Bad SCTP Check-
sum

bad-sctp-
checksum

Bad SCTP packet
checksum

No

3.3. Appendix
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Flowmon Integrated Out-of-path DDoS Solution

4.1 Getting Started

Please follow the instructions provided by the instructor to start your lab and access your jump host.

Note: All work for this lab will be performed exclusively from the Windows jumphost. No installation or
interaction with your local system is required.

4.1.1 Lab Topology

The following components have been included in your lab environment:
* 1 x F5 BIG-IP AFM VE (v13.1.0.6)
+ 2 x vyOS routers (v1.1.8)
* 1 x Flowmon Collector (v9.01.04)/DDoS Defender (v4.01.00)
* 1 x Webserver (Ubuntu 16.04)
* 1 x Jumphost (Windows 7)
1 x Attacker (Ubuntu 16.04)

Lab Components

The following table lists VLANS, IP Addresses and Credentials for all components:
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Component VLAN/IP Address(es) Connection Type, Credentials
h RDP 1 P Ord!
Jumphost . Management: 10.1.1.199 external_user/P@sswOrd
» Users: 10.1.10.30
* Internal: 10.1.20.30
« Servers: 10.1.30.30
BIG-IP AFM TMUI i i
G * Management: 10.1.1.7 Ul admin/admin
* Internal: 10.1.20.245
Flowmon Col- TMUI admin/admin
lector/DDoS * Management: 10.1.1.9
Defender * Internal: 10.1.20.10
R 1 h
outer - Management: 10.1.1.10 ssh vyos/vyos
» Users: 10.1.10.243
* Internal: 10.1.20.243
R 2 h
outer - Management: 10.1.1.11 ssh vyos/vyos
« Users: 10.1.10.244
* Internal: 10.1.20.244
Attacker . Management: 10.1.1.4 ssh f5admin/f5admin
» Users: 10.1.10.100
Web h f5admin/f5admi
ebserver + Management: 10.1.1.6 sS admrnitoadmin
« Servers: 10.1.30.252

4.2 Module — Deployment use case and Lab diagram

In this module you will learn about common use-case for AFM/DHD + Flowmon out-of-path DDoS protection
solution and explore Lab diagram.

4.2.1 Deployment use case

A Joint F5 + Flowmon solution is deployed “out-of-path” and provides an out-of-band DDoS mitigation of L3-
4 volumetric DDoS attacks. It's a simple and convenient solution that leverages the existing IT infrastructure
to provide traffic flow information.

Flowmon Collector appliance receives NetFlow/sFlow/IPFIX from edge routers while Flowmon DDoS De-
fender uses i/eBGP/Flowspec to route the traffic to F5 DHD/AFM appliance. F5 DHD/AFM DDoS profile,
VS and other parameters provisioned dynamically through iControl REST.
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Pic.1 Solution Diagram

4.2.2 Lab blueprint setup

Lab blueprint is deployed in Oracle Ravello cloud with access from F5 UDF portal. All Flowmon elements
are pre-configured, F5 AFM VE resources are provisioned and network is configured.

AFM 101112
—
i AFM 13.1.0.1 HSL “—
— - ELK skack
£ % 10.1.20.245
Attacker ¢
10.1.10.100 10.1.10.243 ' -
10.1.20.243 eBGP 10.1.30.244 10.1.30.252
® 10.1.20.2®
SNAT
vRouter1 vRouter2
10.1.1.10 Web server
@ IBGP ..\.\". SFIOW
User
10.1.10.101
Flowmon DDoS Defender
Pic.2 Lab blueprint

4.2. Module — Deployment use case and Lab diagram
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4.2.3 Licensing

BIG-IP is licensed automatically.

Evaluation license has been applied to Flowmon Collector/DDoS Defender. Please contact Lab admin if
there are issues with any lab elements.

4.2.4 Other considerations

Note: Router1 is configured to export sFlow with sampling rate of 1

Note: Learn about sFlow:

https://sflow.org

4.3 Module — DDoS Attack

In this module you will prepare for and launch a SYN flood DoS attack. You will need an active RDP
connection to a Linux Jumphost to perform all necessary prerequisites

4.3.1 Prepare traffic visualization and monitoring

+ Connect to Windows jumphost using RDP

» Open SSH connections to Router1 and Router2

+ Verify Router1 BGP configuration. Protected subnet 10.1.30.0/24 should have a Next Hop defined as Rout

show ip bgp

vyos@vrouterl:~$ show ip bgp

BGP table version is @, local router ID is 10.1.10.243

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, R Removed

Origin codes: i - IGP, e - EGP, 7?7 - incomplete

Network Next Hop Metric LocPrf Weight Path
x> 10.1.10.0/24 0.0.0.0 1 32768 i
* 10.1.30.0/24 10.1.20.244 0321
*> 10.1.20.244 1 021

Total number of prefixes 2

+ Start interface monitoring in Router1 and Router2 monitor interfaces ethernet
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interface: ethl at vrouterl

# Interface RX Rate RX # TX Rate TX #
vrouterl (source: local)
@ ethe 66.00B 1 417.00B 2
| e th1 0.008 ° 0.008 ¢
2  eth2 0.00B 0 0.00B 0
| RX B
150.00 ......cnnns K s s nnnnnssnnnnnnnnnnnnnn s ansnnnnnnnnns
| 125,00 «ciunnnnnnn K e e e e
100.00 ........... K s s s nnnsnsnnnnnnnnnnnnnn st nnnnnnns
75.00 ..iiiinnnnn Kt a s s taaa s sannnasanan s i s
50.00 ...... KawwaKe o nannssnnnnnsnnnnsnnnn sttt R
25,00 ..unus LY [-0.03
1 5 10 15 20 25 30 35 40 45 50 55 60 s
X B
150.00 vvevenennns B a e EErErE s
125.00 cvevenennns T
100.00 ........... Ko nnnnnnnsnnnnnnnnnnnnnns s ansssnnnnnnns
75.00 vivivnnnnns L T
50.00 ...... T R
25.00 ...... K weaKa oo nnnnnnnnnnnnnnss st nnsnnnnnnnnns [-0.03s
1 5 10 15 20 25 30 35 40 45 50 55 60 s

vyos@vrouter1:~$'monitor interfaces ethernet

Press d to enable detailed statistics

: ~ prev interface, v next interface, <- prev node, -> next node, ? help

interface: ethl at vrouter2

# Interface RX Rate RX # TX Rate X #
vrouter2 (source: local)
@ etho 65.00B 0 361.00B 0
[ 1 3 0.008 0 0.00B 0
2 eth3 0.00B [] 0.00B ]
RX
84.00 ......... K wwwnnnnnnnnnnns oo s s nnnnns
70.00 ......... KK w K waawa s sa i s e e s s s EaE s
56.00 ..... T =
42.00 ..... T
28.00 ..... T
14.00 ..... B [-0.03%]
1 5 10 15 20 25 30 35 40 45 50 55 60 s
™
84.00 ...viuninn KaaaKuunaoannnanttan ot nan s snnn R anan
70.00 ...iiuans T T T T T
56,00 siiianinn T T T T T
42.00 ..... L
28.00 ..... L
14.00 ..... T [-0.03%]
1 5 10 15 20 25 30 35 40 45 50 55 60 s

vyos@vrouter2:~%$ monitor interfaces ethernet

+ Select eth1 and press g to enable graphical statistics

Press d to enable detailed statistics

~ prev interface, v next interface, <- prev node, -=> next node, ? help

Note: You may need to expand terminal window for graphs to appear

» Open Web Browser and click on BIG-IP AFM bookmark, then login into BIG-IP TMUI using admin

credentials
» Open DoS Visibility Dashboard in AFM TMUI

4.3. Module — DDoS Attack
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Security » Reporting : DoS : Dashboard

5 ~ Dashboard Analysis URLLatencies  Sweeper Custom Page

/g Statistics
j iApps Last hour v Friday May 11, 12:41:00 - 13:41:39 5min. v < Refresh
ﬂ/q DNS m ! 1250 ! 13:00 ! 1310 13:20 13:30 13:40 m
(%) SSL Orchestrator
Attack Duration Jons
) Local Traffic 0 | Network |se
| Traffic Intelligence o
(¢ 34) Acceleration = AttackIDs 0
Q . Droppe..
2/ Subseriber Management §
- S No data
== Device Management g
H
\J Secuity
Overview =
12:45 1300 1305 1310 13115 13:20 13:25 13:30 13:35 13:40 O TRens 0
Protocol Securi ~ Droppe...
v Critical @l High ' Moderate M Low @ - Dropee.
Netwrk Firewall
No data
Network Address Transiation Attacks
Dos Protection
Event Logs i) # of Attacks per Protocol (i)
Protocal = Applications -
Debug Network & .
0
Options Dos Analysis HITe I T—
Seftings Sweeper DNS
£3) Network
Scheduled Reports Custom Page SIP
= Triggers v
Disnlav amenu far "httos://2at13eba-Gece-4449-Becd bl Network L

* In a new Browser tab click on Flowmon Web interface bookmark. Once Flowmon main menu opens,
click on Flowmon DDoS Defender icon and login using admin credentials

» Open Attack List in Flowmon DDoS Defender WebUI

75 Program
Programmal

Gold suppart service

= Flowmon DDoS Defender  ~ @« 2 [aomndlx

Attack list
@ Attack List
& Report chapters D Attack status. Start time End time Segment Action status User comment. Tools.
A Configuration 16 (JENDED  2018-02-06 14:28:00 2018-02-06 14:39:32 test network (3 , © @ Mitigation Start, (© @ Detected, ( @ Detected, ( Not Active, ( € Mitigation Stop, @ Ended ’ © Lo aEa
/15 [JENDED  2018-02-0511:37:00 2018-02-05 11:46:04 test network () O itigation Start, , © @ Detected, (3 Not Active, Mitigation Stop, (2 Ended ’ ®Lom
14 [JENDED 20180124 09:47:00 2018-01-2409:55:32 test network ( D @ Mitigation Start, © Not Active, © @Y Mit Ended , oL@ s
13 (JENDED  2018.012409:30:30 2018.01.2409:40:32 test network © itigation Start, © , © O Detected, ( Not Active, © ) Mitigation Stop,  Ended , ® L@
12 (JENDED 20180124 09:14:00 2018.01.2409:19:03 test_natwork (3 5 ) Mitigation Start, ( Not © © Detected, () Not Active, , © Ended ’ oL@
1 CJENDED 20180123 15:31:30 20180123 15:36:33  test network () ) ) Mitigation start, Detected, (9 Not Active, , © Ended , ©oma
10 [JENDED 20180123 15:24:30 2018.01-23 15:26:03 test network (3  Mitigation Start, © Not Hitigation Stop, ( Not Cor , oL ma
9 [JENDED 20180123 15:19:30 20180123 15:21:04 test network ( 5 ) Mitigation Start, © No ’, ®Loma
8 [JENDED 20180123 15:11:30 2018-01-23 15:13:03  test_network © Hitigation Start, © , oM ]
7 (JENDED  2018.01-23 15:07:00 2018.01.23 15:08:32 test_natwork (3 , © ) Mitigation Start, © , oLom

Note: Disregard any active alarms Flowmon may show in the upper right screen corner. These are artifcts
of this lab environment

4.3.2 Initiate DDoS attack

Run SYN flood (hping3) from Attacker VM

* Click on Attacker SSH icon to open Attacker VM ssh session
» From Attacker VM run SYN flood towards Web server
./syn_£flood

f5admin@attacker:~$ ./syn_flood

[sudo] password for f5admin:

HPING 10.1.30.252 (ens3 10.1.30.252): S set, 40 headers + 1200 data bytes
hping in flood mode, no replies will be shown

« Observe traffic growth in both Router1 and Router2. After 15-45 seconds traffic will drop in Router2
due to DDoS detection and mitigation start
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interface: ethl at vrouterl bmon 2.6.1 I interface: ethl at vrouter2 bmon 2.0.1
# Interface RX Rate RX #  TX Rate T # # Interface RX Rate RX # TX Rate T #

vrouterl (source: local) vrouter2 (source: local)
0 __etho 66.008 1 13.34KiB 19 65.008 [] 449,008 ]

-t 510.008 8 3.47MiB 2903 12.74KiB 18 0.008 0
2 eth2 3.73Mi8 3116 0.008 ] 0.008 [} 12.74KiB 18

RX

B
714.00 ...x%.. .
595.00 *.kk:
476.00 Hxxeks
357.00 Hxwonk
238.00 Hxwonknr, .
119.00 *xwonkns, .

1 5 10 15 20 25 30 35 40 45 50 55 60
X MiB

[-0.06%]
s

[-0.06%]
1 5 10 15 20 25 30 35 40 45 50 55 60
Press d to enable detailed statistics

[-0.83%]
10 15 20 25 30 35 40 45 50 55 60s

[-0.03%]

1 5 10 15 20 25 30 35 40 45 50 55 605

~ prev_interface, v next interface, <

prev node, -> next node, ? help

DDoS mitigation start

Press d to enable detailed statistics

~prev_interface, v next interface, <- prev node, -> next node, 7 _help

An ACTIVE attack with the new ID will appear in Flowmon DDoS defender ‘Active attacks’ screen. Flow-
mon dynamically provisions AFM DDoS profile and VS, and initiates traffic diversion to AFM using BGP

advertisement

Flowmon DDoS Defender

Gold Support servic

Gold Support

e wil expire soont "
v service wil expire n 6 days! @ » 2 [admini|x
Attack list
@ AttackList
& Report chapters . . -
ID Attack status Start time End time Segment Action status User comment Tools

A Configuration 417 @IACTVE  2018:02-0909:41:00 Active test_network @ @ Detected, ( () Mitigation Start, ( @ Detected , ©LPEe
16 [CJENDED  2018-02-06 14:28:00 2018-02-06 14:39:32 test_network (2 @ Detected, () () Mitigation Start, () @) Detected, () @ Detected, (5 Not Active, () ) Mitigation Stop, (3 Ended 7’ ®© L ma
15 [CJENDED  2018-02-0511:37:00 2018-02-05 11:46:04 test_network (2 @ Detected, () () Mitigation Start, () Not Active, () @ Detected, (2} Not Active, () @) Mitigation Stop, (%) Ended 7’ ® O |
14 [JENDED  2018-012409:47:00 2018-01-2409:55:32 test_network (3 @) Detected, ) (Y Mitigation Start, (3 @) Detected, (3 Not Active, (3 () Mitigation Stop, (3 Ended ’ © L@ a

Action status

Gelected subnets
10.1.30.0/24

Scrubbing center actions
€2 Locking AFM
> Connecting to main device
Configuring subnet 10.1.30.0/24

€2 Creating DDaS Profile
& Creating Virtual Server

2 Disconnecting from device

€2 Unlocking AFM

Redirection actions
&2 Locking vyos1_router
& Applying redirection
€2 Unlocking vyos1_router

Status: @ Success

4.3. Module — DDoS Attack
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BGP route change and traffic drop

» Router1 shows new route to protected 10.1.30.0/24 subnet
show ip bgp

vyos@vrouterl:~%$ show ip bgp
BGP table version is @, local router ID is 108.1.10.243
Status codes: s suppressed, d damped, h history, * valid, = best, i - internal,

r RIB-failure, S Stale, R Removed
Origin codes: i — IGP, e - EGP, ? - incomplete

Network Next Hop

Metric LocPrf Weight Path
*> 0.0.0.9

10.1.1.1 @ 32768 7

>110.1.30.08/24 10.1.20.245 108 B i

Total number of prefixes 3

* As traffic is being routed through AFM, Router2 shows no significant network activity while Router1
still experiences high traffic load

@ © ® 7 vyos@vrouterl: ~ — -ssh -p 47006 45143099-036f-4ach-b7c5-137170113c34.access.udf f5.com... | =
interface: eth4 at vrouterl bnon 2.0.1
# Interface RX Rate RX # TX Rate ™ # # Interface RX Rate RX # TX Rate T #
vrouterl (source: local) vrouter2 (source: local)
eth3 117.008 1 8 9 _eth2 119.008 1 217.008 0
[ 1 SO 499.008 8 % 48133 [ 1 33 0.008 o 10.22KiB 15
2 eths 90.14MiB 75372 o ] 2 eths 10.32KiB 16 41.008 0
RX B
630.00 ...... Kt et
525.00 btk ¥
420.00
315.00
210.00
105.00 [-4.34%]
1 5 10 15 20 25 30 35 48 45 50 55 60 s 1 5 10 15 20 25 30 35 40 45 50 55 60 s
TX|  MiB X KiB
58,62 Ptk s et ea s HKe et *a 10.25
48. 85 [Ptk ok KRR IR oK 45K KK 8.54
39 6.84
29.31 5.13
19.54 3.42
9.77 [-4.34%] 1.71 [-0.01%)
5 10 15 28 25 30 35 48 45 58 55 60 1 5 10 15 20 25 30 35 40 45 50 55 60 s
Press d to enable detailed statistics Press d to enable detailed statistics ——————————————
~ prev_interface, v next interface, <- prev node, -> next node, ?
T

AFM DDoS profile and virtual server

Note: Flowmon uses iControl REST interface to provision necessary parameters in AFM

* In AFM TMUI Navigate to Security —> DoS protection —> DoS profiles and confirm that the DoS
profile has been provisioned for the protected subnet

* In Local Traffic —> Virtual Servers —> Virtual Server List confirm that VS with corresponding Attack
ID has been created
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Local Trafic » Virtual Servers : Virtu

2 - | Vinual Server Lst

1 seacn Create...
@nus (v [~ Staws = Name  Description |+ Application |+ Destination | + Service Port |+ Type Resources | * Partition / Path
O @ OTEGiest-17om0tie0 Flowmon DDoS Atack D 17 10130024 O(Ary) Fowarding (P) EGt.  Common

AFM DDoS mitigation

In AFM TMUI navigate to Security —> DoS Protection —> DoS Overview and confirm that AFM is perform-
ing DoS mitigation using the provisioned DoS profile

Security » DoS Protection : DoS Overview

J 5 ~ DoS Overview DoS Profiles Device Configuration ~ | Signatures Eviction Policy List [

View Filter
‘ Filter Type Dos Attack &) |
‘ Auto Refresh Disabled Refresh |
‘ Enter Vector Name Tl Attack Status ‘ ‘ Average Aggregate EPS ‘ ‘ Cu
Profile ‘M\we ‘Sme=|Famlly¢|Laamlnge mme“v‘mmelv\mmelvlmmaﬂmecunanl |1mln ‘1hnur ‘Agglugets|i
OTEO-test_-33-0xa011e00_dos TCP SYN flood Mitigate o Leaming OTEO- ) Dropped 9 Dropped @ None 39506 38125 0 39506 ]
test_-33-
0xa011e00
dos-device-config TCP SYN Oversize Mitigate (@ Leaming Device  {f§ Dropped @ None @ None 42515 40185 68 2515 C

Note: Statistics -> DoS Visibility TMUI menu provides graphical attack data

It may take up to ~5 minutes for DoS Visibility Dashboard to show our simulated DDoS attack. You may
need to click Refresh for data to appear

I Firewall: Consistent
|| ONLINE (ACTIVE)

|| standalone

m Security » Reporting : DoS : Dashboard

7+ »~ Dashboard Analysis URL Latencies Sweeper Custom Page

Dashboard Last hour v Thursday May 24, 15:09:00 - 16:09:18 5 min. v Z Refresh
DoS Visibility

) mﬁ-im ' 15:20 ! 15:30 !
Analytics
Performance Attack Duration

4.3.3 Attack stop

Stop SYN flood

Press (ctr1-c) to finish the attack. Traffic will drop on Router1
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interface: ethl at vrouterl bmon 2.0.1

# Interface RX Rate RX # TX Rate TX #

vrouterl (source: local)
0 ethe 65.008 0 345,008

1 S 0.00B [} 0.008

2 eth2 0.008 0 0.00B

(SR

RX
o L Kevurunn Kiwunns
470.
376.
282.
188.

94,

L Fokok
Skkk [-0.03%]
30 35 40 45 50 55 60 s

TX

[-0.03%]
1 5 10 1 2 25 30 35 40 45 50 55 60 s
Press d to enable detailed statistics

~ prev interface, v next interface, <- prev node, —> next node, ? help

SO Rr LR

Note: STOP HERE. It will take 5-10 minutes for Flowmon to mark the attack as NOT ACTIVE. This is done
in order to avoid ‘flip-flop’ effect in repeated attack situation

Mitigation stop

Flowmon DDoS Defender Attack List screen shows the current attack with status NOT ACTIVE. Attack will
transition to ENDED state when Flowmon performs Mitigation Stop routine

Gold support senvice wil exire soot God Suppot
Flowmon DDoS Defender  ~ i wil it i dayi @ - 2 [aemndix

Attack list
Attack List
Report chapters
1D Attack status Start time End time Segment Action status User comment Tools
Configuration 17 ([ NOT ACTIVE 2018-02-09 09:41:00 2018-02-09 10:04:33 test_network () @) Detected, (&) () Mitigation Start, (5 @ Detected, () @) Detected, (5 Not Active 7 ® L@

Flowmon DDoS Defender  ~ n 2| admin & | X
Attack list
Attack List
Report chapters
ID  Attackstatus  Start time End time Segment Action status User comment Tools
Configuration 17 (JENDED  2018-02-09 09:41:00 2018-02-09 10:04:33 test _network () @ Detected, ) @) Mitigation Start, () @ Detected, () @ Detected, () Not Active, ) ) Mitigation Stop, () Ended 7 © L@ a
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Action status x

Selected subnets
10.1.30.0/24

Redirection actions
&) Locking vyos1_router
£ Removing redirection
& Unlocking vyos1_router

Scrubbing center actions
& Locking AFM
) Connecting to main device
Removing configuration for subnet 10.1.30.0/24

€2 Removing Virtual Server
& Removing DDoS Profile

& Disconnecting from device

£ Unlocking AFM

Status: € Success m

*It typically takes ~ 5min for Flowmon DDoS Defender to update attack status

AFM configuration, BGP route removal

As part of Mitigation Stop routine Flowmon removes BGP route from Router1 and Virtual Server and DDoS
Profile from AFM

show ip bgp

vyos@vrouterl:~% show ip bgp

BGP table version is @, local router ID is 10.1.16.243

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, R Removed

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
%> 0.0.0.0 18.1.1.1 @ 32768 7
k A A A i I 1 32768 1
1 021

Total number of prefixes 3

In AFM TMUI navigate to Security —> DoS Protection — DoS Profiles
Verify that only default “dos” profile present
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| Firewall: Consistent

f; || ONLINE (ACTIVE)
7 | standalone

Eviction Policy List (&

Device Configuration ~ | Signatures

Create

| 1Apps

@DNS

& SSL Orchestrator

| Viewin Partiion/Path

Overview Common

Delete

In AFM TMUI navigate to Local Traffic — Virtual Servers —> Virtual Server List

Verify that Virtual Server matching Attack ID has been removed

Local Traffic » Virtual Servers : Virtual Server List

£+ | Vinual ServerList | Virtual Address List | Statistics

Create...

[} 1A
1 Searoh

@ o RS S Dot Appksie [ oorion] 8 Savin ot [ Ty ssamcen] S ek |
| Norecords to aisplay

() Local Traffic

Congratulations! You have successfully completed the lab!
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